Bug 633931 - Last tigervnc upgrade broke Caps-Lock
Last tigervnc upgrade broke Caps-Lock
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tigervnc (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
: 632076 634347 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-14 13:11 EDT by Alfredo Ferrari
Modified: 2013-04-30 19:47 EDT (History)
6 users (show)

See Also:
Fixed In Version: tigervnc-1.0.90-0.15.20100420svn4030.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-21 02:02:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
starce of "service vncserver start" (24.16 KB, application/octet-stream)
2010-09-16 13:26 EDT, Alfredo Ferrari
no flags Details
vnc configuration file (1.04 KB, application/octet-stream)
2010-09-16 13:32 EDT, Alfredo Ferrari
no flags Details
output of "service vncserver start" when set -x is added (2.20 KB, application/octet-stream)
2010-09-20 06:58 EDT, Alfredo Ferrari
no flags Details
diff between old and new /etc/init.d/vncserver (255 bytes, application/octet-stream)
2010-09-20 06:59 EDT, Alfredo Ferrari
no flags Details

  None (edit)
Description Alfredo Ferrari 2010-09-14 13:11:36 EDT
Description of problem:
Caps-lock does no longer work after upgrading to the last version

Version-Release number of selected component (if applicable):
tigervnc-server-1.0.90-0.13.20100420svn4030.fc13.

How reproducible:
Always, both on i686 and x86_64

Steps to Reproduce:
1. start a tigervnc server
2. use vncviewer to connect to that server
3. Set caps-lock and type whichever alphabetic character
  
Actual results:
Characters are never capitalized

Expected results:
Characters should be capitalized

Additional info:
It worked correctly until version tigervnc-1.0.90-0.12.20100420svn4030.fc13 included. Downgrading to tigervnc-1.0.90-0.12.20100420svn4030.fc13 restore the Caps-lock functionality
Comment 1 Adam Tkac 2010-09-15 06:43:27 EDT
*** Bug 632076 has been marked as a duplicate of this bug. ***
Comment 2 Orion Poplawski 2010-09-15 17:09:13 EDT
*** Bug 634347 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2010-09-16 09:54:16 EDT
tigervnc-1.0.90-0.14.20100420svn4030.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/tigervnc-1.0.90-0.14.20100420svn4030.fc13
Comment 4 Alfredo Ferrari 2010-09-16 13:26:50 EDT
Created attachment 447806 [details]
starce of "service vncserver start"
Comment 5 Alfredo Ferrari 2010-09-16 13:32:09 EDT
Created attachment 447807 [details]
vnc configuration file
Comment 6 Alfredo Ferrari 2010-09-16 13:32:46 EDT
Stop it!! The server does not even start using tigervnc-1.0.90-0.14.20100420svn4030.fc13. On both i686 and x86_64 typing

service vncserver start

it fails with:

[root@pcalfr alfredo]# service vncserver start
Starting VNC server: 1:alfredo Ambiguous output redirect.
                                                           [FAILED]

I attach the full strace of service vncserver start as well as my config file
Comment 7 Adam Tkac 2010-09-20 03:14:32 EDT
(In reply to comment #6)
> Stop it!! The server does not even start using
> tigervnc-1.0.90-0.14.20100420svn4030.fc13. On both i686 and x86_64 typing
> 
> service vncserver start
> 
> it fails with:
> 
> [root@pcalfr alfredo]# service vncserver start
> Starting VNC server: 1:alfredo Ambiguous output redirect.
>                                                            [FAILED]
> 
> I attach the full strace of service vncserver start as well as my config file

I'm not able to reproduce this issue. Would it be possible to manually add "set -x" to the /etc/init.d/vncserver file, run `service vncserver start` again and attach output here, please?

$ cat /etc/init.d/vncserver
#!/bin/bash
...
. /etc/init.d/functions

set -x

[ -r /etc/sysconfig/vncservers ] && . /etc/sysconfig/vncservers
...
Comment 8 Alfredo Ferrari 2010-09-20 06:57:29 EDT
Done. I am going to attach the output (vnc.out) in a moment. I also made a diff of the /etc/init.d/vncserver scripts, old and new, and clearly the only changed line (see diff.out attached as well in a moment) is the culprit. using the "old"
/etc/init.d/vncserver with tigervnc-1.0.90-0.14.20100420svn4030.fc13, the server starts with no issue and a quick check seems to confirm that everything is fine (at least caps Lock is surely fine)
Comment 9 Alfredo Ferrari 2010-09-20 06:58:50 EDT
Created attachment 448428 [details]
output of "service vncserver start" when set -x is added
Comment 10 Alfredo Ferrari 2010-09-20 06:59:33 EDT
Created attachment 448429 [details]
diff between old and new /etc/init.d/vncserver
Comment 11 Adam Tkac 2010-09-20 07:51:49 EDT
(In reply to comment #9)
> Created attachment 448428 [details]
> output of "service vncserver start" when set -x is added

I think I've figured what's broken. Which shell is default for "alfredo" user?

When you add "-s /bin/bash" parameter to the "runuser" command in the /etc/init.d/vncserver script (runuser -s /bin/bash -l ${USER} -c "...") does it solve your issue?
Comment 12 Alfredo Ferrari 2010-09-21 02:07:28 EDT
... tcsh and the answer is yes, with -s /bin/bash the server starts with no problem.

Thanks!
Comment 13 Alfredo Ferrari 2010-09-21 02:09:36 EDT
.... oops... too quick to answer! Yes the server starts with no problem, but then the user is locked into bash, which obviously is very uncomfortable (all intializations, scripts etc broken...) to say the least
Comment 14 Adam Tkac 2010-09-21 04:39:46 EDT
(In reply to comment #13)
> .... oops... too quick to answer! Yes the server starts with no problem, but
> then the user is locked into bash, which obviously is very uncomfortable (all
> intializations, scripts etc broken...) to say the least

tigervnc-1.0.90-0.15.20100420svn4030.fc13 should be fine, I've pushed it to -testing repo (http://admin.fedoraproject.org/updates/tigervnc-1.0.90-0.15.20100420svn4030.fc13).
Comment 15 Fedora Update System 2010-09-21 20:35:54 EDT
tigervnc-1.0.90-0.15.20100420svn4030.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update tigervnc'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/tigervnc-1.0.90-0.15.20100420svn4030.fc13
Comment 16 Leland C. Scott 2010-09-22 17:39:08 EDT
I just installed the same package (0.15) on my 32 bit F-13 system and I can
confirm the caps-lock still doesn't work for me.

(In reply to comment #15)
> tigervnc-1.0.90-0.15.20100420svn4030.fc13 has been pushed to the Fedora 13
> testing repository.  If problems still persist, please make note of it in this
> bug report.
>  If you want to test the update, you can install it with 
>  su -c 'yum --enablerepo=updates-testing update tigervnc'.  You can provide
> feedback for this update here:
> https://admin.fedoraproject.org/updates/tigervnc-1.0.90-0.15.20100420svn4030.fc13
Comment 17 Orion Poplawski 2010-09-22 17:58:13 EDT
0.15 works fixes caps lock for me.
Comment 18 Leland C. Scott 2010-09-22 18:42:18 EDT
Looks like I didn't update the server, just the client. It works now for me too after updating the "tiger-server" package. The instruction below only did the client I noticed after double checking.

(In reply to comment #16)
> I just installed the same package (0.15) on my 32 bit F-13 system and I can
> confirm the caps-lock still doesn't work for me.
> (In reply to comment #15)
> > tigervnc-1.0.90-0.15.20100420svn4030.fc13 has been pushed to the Fedora 13
> > testing repository.  If problems still persist, please make note of it in this
> > bug report.
> >  If you want to test the update, you can install it with 
> >  su -c 'yum --enablerepo=updates-testing update tigervnc'.  You can provide
> > feedback for this update here:
> > https://admin.fedoraproject.org/updates/tigervnc-1.0.90-0.15.20100420svn4030.fc13
Comment 19 Fedora Update System 2010-10-21 02:01:44 EDT
tigervnc-1.0.90-0.15.20100420svn4030.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.