Bug 63486 - Gnome panel crashes when selecting launcher icon.
Gnome panel crashes when selecting launcher icon.
Status: CLOSED DUPLICATE of bug 62844
Product: Red Hat Public Beta
Classification: Retired
Component: gnome-core (Show other bugs)
skipjack-beta2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-14 12:52 EDT by theenglishman
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-14 17:28:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description theenglishman 2002-04-14 12:52:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020401

Description of problem:
The GNOME panel crashes when the Icon: "No Icon" button is selected to choose an
icon for a launcher on the panel.
This is the same for new and existing launchers.
It is possible to create a launcher with the default icon.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Right click on panel
2.Select panel->add to panel->new launcher
3.Click on "No Icon" button in dialogue box
4.Watch it crash

or

1.Right click on existing launcher on panel
2.Select "properties"
3.Click on "No Icon" button in dialogue box
4.Watch it crash



Actual Results:  Panel crashes, then restarts, apparently in last state before
crash.

Expected Results:  Icon chooser dialogue box should appear.

Additional info:
Comment 1 Havoc Pennington 2002-04-14 13:39:24 EDT
Should only happen if you have a bad locale - do "echo $LANG" 
or "cat /etc/sysconfig/i18n"

Try choosing a different language in gdm when logging in, and let me know if it
goes away.
Comment 2 theenglishman 2002-04-14 17:04:56 EDT
LANG was set to en_GB.iso885915 before.
Used gdm to select British English at login. 
GDM_LANG and LANG are now set to en_GB.ISO-8859-1
Icon chooser now displays correctly.

I would still expect to have the locale set correctly on a freshly installed
system - even if it is a default en_US or similar.

This bug can be closed, however I would like to see the fact that it was not
correctly setup to start with resolved first.

(As an aside, there appear to be some problems with locale_config: see bug 63492).
Comment 3 Havoc Pennington 2002-04-14 17:28:20 EDT
Jeremy is the locale bug back, or fixed in latest?
Comment 4 Jeremy Katz 2002-04-14 17:34:03 EDT
Fixed later by actually fixing X to understand en_GB.iso885915 and
en_US.iso885915 (since we need to use iso8859-15 so that you can use the euro. 
ick)  

*** This bug has been marked as a duplicate of 62844 ***

Note You need to log in before you can comment on or make changes to this bug.