Bug 634940 - "Device or Resource Busy" in repository setup time when installing from Hard disk
"Device or Resource Busy" in repository setup time when installing from Hard ...
Status: CLOSED DUPLICATE of bug 627789
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-17 08:01 EDT by Hedayat Vatankhah
Modified: 2010-09-18 14:34 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-18 14:34:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hedayat Vatankhah 2010-09-17 08:01:33 EDT
Description of problem:
I've tried installing Fedora 14 Beta TC1 from an ext4 partition in an external hard disk (connected by USB). Installer is successfully loaded and I can pass the partitioning section. When installer tries to retrieve installation repo information, it stops with error: Device or Resource Busy. And I should exit the installer (there is another bug in this step too: after the error, the installer asks me if I want to install from network. I press "Cancel" and then, it asks me to select a network interface to setup networking from (thinking that I want to install from network)).
 
How reproducible:
100%

Steps to Reproduce:
1. Copy Fedora 14 Beta TC1 in an ext4 partition in an external hard disk (due to bug #631796 I cannot try installing from my internal hard disk)
2. Select Hard drive install as the installation method in the installer
3. Go through the installation process 
  
Actual results:
When the installer tries to get repository information, it'll show a "Device or Resource Busy" error


Expected results:
Installation should go without the error
Comment 1 Brian Lane 2010-09-17 18:42:58 EDT
This sounds like bug 627789. Was the error "Error setting up repository - 16, Device busy"?
Comment 2 Hedayat Vatankhah 2010-09-18 03:04:38 EDT
It was 16, but I think it was "Device or Resource Busy". Also after hitting OK, I got a screen which asked me to select a new installation method (NFS, HTTP, CD/DVD). 
Also (which is a different and not important bug as you are exiting the installer anyway) when I select "Cancel" in this dialog, it still asks me to select a network interface!
Comment 3 Hedayat Vatankhah 2010-09-18 03:06:22 EDT
BTW, it is probably caused by the same problem anyway.
Comment 4 Brian Lane 2010-09-18 14:34:01 EDT

*** This bug has been marked as a duplicate of bug 627789 ***

Note You need to log in before you can comment on or make changes to this bug.