Bug 640768 - Broken dependency: chunkd-0.6-0.8.gc49c6d38.fc14 requires libchunkdc.so.0()(64bit)
Broken dependency: chunkd-0.6-0.8.gc49c6d38.fc14 requires libchunkdc.so.0()(6...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: chunkd (Show other bugs)
14
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Fedora Extras Quality Assurance
AcceptedNTH repoclosure_hash:abf68aae...
:
: 640817 (view as bug list)
Depends On:
Blocks: f14-repo-nonmedia
  Show dependency treegraph
 
Reported: 2010-10-06 15:08 EDT by James Laska
Modified: 2013-09-02 02:51 EDT (History)
6 users (show)

See Also:
Fixed In Version: hail-0.8-0.2.gf9c5b967.1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-19 02:31:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to add Obsoletes: (978 bytes, patch)
2010-10-06 20:45 EDT, Pete Zaitcev
no flags Details | Diff

  None (edit)
Description James Laska 2010-10-06 15:08:18 EDT
Added repo-1 repo from http://download.fedoraproject.org/pub/fedora/linux/development/14/x86_64/os
Added repo-2 repo from http://download.fedoraproject.org/pub/fedora/linux/updates/testing/14/x86_64
Reading in repository metadata - please wait....
Checking Dependencies
Repos looked at: 2
   repo-1
   repo-2
Num Packages in Repos: 22082
package: chunkd-devel-0.6-0.8.gc49c6d38.fc14.x86_64 from repo-1
  unresolved deps: 
     libchunkdc.so.0()(64bit)
Comment 1 James Laska 2010-10-06 16:37:50 EDT
*** Bug 640817 has been marked as a duplicate of this bug. ***
Comment 2 Pete Zaitcev 2010-10-06 19:24:18 EDT
The problem is that chunkd-0.6 comes from its own package (inherited from the depths of time), but these days hail provides it. Fortunately hail's version
is 0.8, which is > 0.6, so there shold be a way to transition this smoothly.
Not sure how to do it yet. Researching...
Comment 3 Pete Zaitcev 2010-10-06 20:45:37 EDT
Created attachment 452017 [details]
Patch to add Obsoletes:
Comment 4 Fedora Update System 2010-10-06 21:00:33 EDT
hail-0.8-0.2.gf9c5b967.1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/hail-0.8-0.2.gf9c5b967.1.fc14
Comment 5 Fedora Update System 2010-10-07 15:52:15 EDT
hail-0.8-0.2.gf9c5b967.1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hail'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/hail-0.8-0.2.gf9c5b967.1.fc14
Comment 6 Adam Williamson 2010-10-08 15:03:43 EDT
Dependency and conflict issues are automatically accepted as nice-to-have.
Comment 7 Adam Williamson 2010-10-12 20:26:36 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Pete Zaitcev 2010-10-14 20:47:16 EDT
Jeff, Bodhi sent me e-mail saying "update has reached 7 days in testing and
can be pushed to stable now if the maintainer wishes". I guess I'm not
in position to push it since you're the maintainer.
Comment 9 James Laska 2010-10-15 08:30:20 EDT
Odd, I'm still seeing this issue even when testing with the F-14 'stable' and 'updates-testing' repos (note, there is no 'updates' repo until F-14 is released).

I suspect it may be the result of an odd multilib push?

# yum list chunkd
Available Packages
chunkd.i686                     0.6-0.8.gc49c6d38.fc14                    fedora
chunkd.x86_64                   0.8-0.2.gf9c5b967.fc14                    fedora

== chunkd-0.6-0.8.gc49c6d38.fc14 ==
Summary: Broken dependency: chunkd-devel-0.6-0.8.gc49c6d38.fc14.i686 requires chunkd = 0:0.6-0.8.gc49c6d38.fc14
Product: Fedora
Version: 14
Component: chunkd
Whiteboard:
	repoclosure_hash:296ca049a308b9cd851e553865463d5370cbd1e06e2f4af787b5b8c9e065bb0d
Binaries affected:
	chunkd-devel-0.6-0.8.gc49c6d38.fc14.i686
	chunkd-devel-0.6-0.8.gc49c6d38.fc14.x86_64
Description:
Added repo-1 repo from http://download.fedoraproject.org/pub/fedora/linux/development/14/x86_64/os
Added repo-2 repo from http://download.fedoraproject.org/pub/fedora/linux/updates/testing/14/x86_64
Reading in repository metadata - please wait....
Checking Dependencies
Repos looked at: 2
   repo-1
   repo-2
Num Packages in Repos: 22197
package: chunkd-devel-0.6-0.8.gc49c6d38.fc14.i686 from repo-1
  unresolved deps: 
     chunkd = 0:0.6-0.8.gc49c6d38.fc14
     libchunkdc.so.0
package: chunkd-devel-0.6-0.8.gc49c6d38.fc14.x86_64 from repo-1
  unresolved deps: 
     chunkd = 0:0.6-0.8.gc49c6d38.fc14
     libchunkdc.so.0()(64bit)

Found existing bug: http://bugzilla.redhat.com/640817 (CLOSED)
Comment 10 Jesse Keating 2010-10-15 13:23:23 EDT
chunkd got retired, merged into hail, however "chunkd" was never blocked in koji, so composes were picking up both hail's version of chunkd, and chunkd's version of chunkd, which mismatched.  Hilarity ensued.

Blocking chunkd, this should clear up in the next set of composes.
Comment 11 Jeff Garzik 2010-10-15 14:05:31 EDT
This probably also affects bug 640798 ?
Comment 12 Jesse Keating 2010-10-19 02:31:11 EDT
Closed.
Comment 13 Fedora Update System 2010-10-28 02:18:55 EDT
hail-0.8-0.2.gf9c5b967.1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.