Bug 643129 - [gtk2] Gtk-Message: Failed to load module "pk-gtk-module"
Summary: [gtk2] Gtk-Message: Failed to load module "pk-gtk-module"
Keywords:
Status: CLOSED DUPLICATE of bug 747449
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk2
Version: 14
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 734189 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-10-14 18:12 UTC by Joachim Frieben
Modified: 2012-07-22 13:03 UTC (History)
30 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-10 18:29:53 UTC


Attachments (Terms of Use)

Description Joachim Frieben 2010-10-14 18:12:17 UTC
Description of problem:
When running 'gnome-shell --replace' from the command line, an error message

  "Gtk-Message: Failed to load module "pk-gtk-module": libpk-gtk-module.so: cannot
   open shared object file: No such file or directory"

is returned. However, file /usr/lib64/gtk-2.0/modules/libpk-gtk-module.so does exist, and it is actually owned by PackageKit-gtk-module-0.6.9-4.fc14.x86_64.

Version-Release number of selected component (if applicable):
gtk2-2.22.0-1.fc14.1.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Run 'gnome-shell --replace' from the command line.
  
Actual results:
Above error message is returned.

Expected results:
No error message is returned.

Additional info:
None.

Comment 1 Julius B. 2010-12-02 18:14:33 UTC
I can confirm this running Fedora 14 (i686) and GNOME Shell's git trunk as of 2010-12-02.

Comment 2 Pierre-Yves Luyten 2010-12-22 20:58:04 UTC
https://bugzilla.redhat.com/show_bug.cgi?id=491220 probably means this one can be closed too?

Nevertheless, some details below if usefull.

The same error happens here. This bug wasn't happening before , it was the
gnome-shell-2.31.5-7.fc14.i686
Then I updated gnome-shell with "--enablerepo=rawhide" option and the bug is happening.

PackageKit-gtk-module-0.6.9-4.fc14.i686
gnome-shell-2.91.3-2.fc15.i686

A launchpad bug indcates to temporarilly turn off this module using gconf editor , gnome-setting-daemon settings.

Comment 3 Phil V 2011-01-12 23:29:19 UTC
This also happens when I run acroread in Fedora 13:

Gtk-Message: Failed to load module "pk-gtk-module": libpk-gtk-module.so: cannot open shared object file: No such file or directory

yum tells me: PackageKit-gtk-module-0.6.6-2.fc13.x86_64 already installed and latest version

Comment 4 Joachim Frieben 2011-01-13 07:21:38 UTC
(In reply to comment #3)
Acroread is a 32 bit binary, but you have only installed the 64 bit version of libpk-gtk-module.so which explains the error message.

Comment 5 Lukas Zapletal 2011-06-01 08:22:08 UTC
Please don't close. Running Fedora 15:

$ eog
Gtk-Message: Failed to load module "pk-gtk-module"

$ rpm -q PackageKit-gtk-module
PackageKit-gtk-module-0.6.14-2.fc15.i686

$ locate pk-gtk-module
/usr/lib/gnome-settings-daemon-3.0/gtk-modules/gpk-pk-gtk-module.desktop
/usr/lib/gtk-2.0/modules/libpk-gtk-module.so

Dependency was added (in 491220 etc) but it obviously did not help.

Comment 6 Joachim Frieben 2011-06-01 09:56:42 UTC
(In reply to comment #5)
$ eog
$ rpm -q eog
eog-3.0.1-1.fc15.x86_64
$ rpm -q PackageKit-gtk-module
PackageKit-gtk-module-0.6.14-2.fc15.x86_64

At least for the x86_64 flavour of current F15 including packages from updates-testing, eog runs as expected without the error message reported in comment 3.

Comment 7 Lukas Zapletal 2011-06-02 11:09:20 UTC
Yeah I run 32 bits. It's an upgraded system.

Comment 8 Jim 2011-06-08 00:35:43 UTC
I get similar error message running gedit from the command line. Running F15 x86_64. I don't recall it happening with F14. E,g,:

$gedit &
Gtk-Message: Failed to load module "pk-gtk-module"

Comment 9 Joachim Frieben 2011-06-08 03:33:59 UTC
(In reply to comment #8)
No message here for F15 x86_64 with updates-testing when running gedit from the command line.

Comment 10 Teer Sandal 2011-06-12 07:37:42 UTC
I'v got the same error with GTK based application in Fedora 15. All of them display message "Gtk-Message: Failed to load module "pk-gtk-module"" at start.
I have updated eog, gedit, gcalctool from updates-testing repo.

$ uname -r
2.6.38.7-30.fc15.x86_64
$ rpm -q eog
eog-3.0.1-1.fc15.x86_64
$ rpm -q PackageKit-gtk-module
PackageKit-gtk-module-0.6.15-1.fc15.x86_64
rpm -q gedit
gedit-3.0.2-2.fc15.x86_64
$ rpm -q gcalctool
gcalctool-6.0.1-2.fc15.x86_64

$ eog
Gtk-Message: Failed to load module "pk-gtk-module"
$ gedit
Gtk-Message: Failed to load module "pk-gtk-module"
$ gcalctool 
Gtk-Message: Failed to load module "pk-gtk-module"

Comment 11 Matthew Saltzman 2011-06-15 02:25:17 UTC
I'm seeing this too, in A Fedora 15 system preupgraded from F14 (64-bits, both 32- and 64-bit PackageKit-gtk-module-0.6.14-2.fc15 installed) and on a 640bit system upgraded from F14 by DVD, with just the 64-bit RPM installed.

Comment 12 Dean Brettle 2011-06-16 08:35:48 UTC
'strace gedit' indicates that gedit is trying to load libpk-gtk-module.so from (among other places):

/usr/lib64/gtk-3.0/modules/libpk-gtk-module.so

but it is the only libpk-gtk-module.so is at:

/usr/lib64/gtk-2.0/modules/libpk-gtk-module.so

So it looks like the gtk3 version of libpk-gtk-module.so is missing.  This would appear to be regression on the previously fixed bug 610064.

Comment 13 Joachim Frieben 2011-06-16 09:16:48 UTC
(In reply to comment #12)
rpm -qf /usr/lib64/gtk-2.0/modules/libpk-gtk-module.so \
        /usr/lib64/gtk-3.0/modules/libpk-gtk-module.so
PackageKit-gtk-module-0.6.15-1.fc15.x86_64
PackageKit-gtk3-module-0.6.15-1.fc15.x86_64
Thus, both modules are present.

Comment 14 Joachim Frieben 2011-06-16 09:32:52 UTC
(In reply to comment #12)
Uh, comment 13 actually applied to current F15. For current F14, no change compared to my original report is observed.
To which release did comment 12 refer to? For current F14, neither eog nor gedit or any other GNOME application that I have tested actually emits said warning.

Comment 15 Dean Brettle 2011-06-16 15:00:42 UTC
My comment 12 referred to F15 which was recently upgraded from F13.  Installing PackageKit-gtk3-module solved the problem for me.  Thanks!

I'm not sure whether this means that a) the apps that are producing the message are missing a dependency on PackageKit-gtk3-module, b) an underlying library (gtk3?) is missing the dependency, or c) the message is just an ignorable warning.

Comment 16 Teer Sandal 2011-06-16 18:49:43 UTC
Installing PackageKit-gtk3-module solved the problem for me, too.
Thanks!

Comment 17 Jim 2011-06-19 03:05:40 UTC
And installing PackageKit-gtk3-module solved the problem for me, too.

Thanks.

Comment 18 Jeff Buhrt 2011-07-07 02:47:22 UTC
This also seems to be a missing dependency on i386. Installing PackageKit-gtk3-module after upgrading from F14 to F15 solved the problem on i386.

Comment 19 Lukas Zapletal 2011-07-07 07:14:35 UTC
I can confirm that helps.

Comment 20 Arangamanikkannan Manickam 2011-07-17 08:09:52 UTC
I have the same problem. But I am running Fedora 14 64-bit version. Also, I have another problem with opening downloaded files from firefox right from the "Downloads" window. I have installed the latest version of firefox in my home folder. 

Any help would be greatly appreciated.

Kannan.

Comment 21 seoaqua 2011-07-26 10:47:23 UTC
i got the same error when i run adobe air install bin in Fedora 15 64bit

Comment 22 Greg 2011-08-12 16:27:57 UTC
I got the same error message with Eclipse(downloaded from eclipse.org, not the fedora package).

I was able to resolve it by installing PackageKit-gtk-module via yum (yum install PackageKit-gtk-module)

My box is using the F15 LXDE x64 spin.

Comment 23 Dominik 'Rathann' Mierzejewski 2011-10-11 13:03:09 UTC
*** Bug 734189 has been marked as a duplicate of this bug. ***

Comment 24 Tore H. Larsen 2011-10-14 22:31:27 UTC
Still around on F16 beta w/updates.

$ grep pk-gtk .xsession-errors
Gtk-Message: Failed to load module "pk-gtk-module"
Gtk-Message: Failed to load module "pk-gtk-module"

$ eog
Gtk-Message: Failed to load module "pk-gtk-module"

Comment 25 RudraB 2011-10-16 17:54:10 UTC
installing PackageKit-gtk3-module sloves the problem for f16 as well.

Comment 26 Michael Cronenworth 2011-11-10 18:29:53 UTC

*** This bug has been marked as a duplicate of bug 747449 ***

Comment 27 Turgut Kalfaoglu 2012-03-11 06:26:34 UTC
I can certify that it happens with Fedora 17 Alpha too.

$ rpm -qa|grep PackageKit-gtk3
PackageKit-gtk3-module-0.7.3-1.fc17.x86_64

$ alacarte 

** WARNING **: Trying to register gtype 'GMountMountFlags' as enum when in fact it is of type 'GFlags'

** WARNING **: Trying to register gtype 'GDriveStartFlags' as enum when in fact it is of type 'GFlags'
Gtk-Message: Failed to load module "pk-gtk-module"
Traceback (most recent call last):
  File "/usr/bin/alacarte", line 22, in <module>
    from Alacarte.MainWindow import MainWindow
  File "/usr/lib/python2.7/site-packages/Alacarte/MainWindow.py", line 19, in <module>
    import gtk, gmenu, gobject, gio
ImportError: No module named gmenu

$

Comment 28 RudraB 2012-05-20 22:34:55 UTC
Its happenning with f17 beta also; though harmless

$ sudo yum install PackageKit-gtk3-module
Loaded plugins: langpacks, presto, refresh-packagekit, remove-with-leaves
Package PackageKit-gtk3-module-0.7.4-3.fc17.x86_64 already installed and latest version
Nothing to do

Comment 29 John B 2012-05-30 03:54:50 UTC
Also happening on f17 after upgrading from beta, and also on a fresh f17 install. It is harmless and annoying at the same time. ;)

Comment 30 Oleg Andreev 2012-05-30 12:27:50 UTC
Judging from PackageKit.spec, the GTK2 pk-gtk-module is deprecated (http://pkgs.fedoraproject.org/gitweb/?p=PackageKit.git;a=blob;f=PackageKit.spec;h=33a848ca1aba5c64d6e892501d2c0cdea50e0462;hb=HEAD#l74).

What module or environment variable requests loading pk-gtk-module?

Comment 31 Oleg Andreev 2012-05-30 12:29:55 UTC
Judging from PackageKit.spec, the GTK2 pk-gtk-module is deprecated (http://pkgs.fedoraproject.org/gitweb/?p=PackageKit.git;a=blob;f=PackageKit.spec;h=33a848ca1aba5c64d6e892501d2c0cdea50e0462;hb=HEAD#l74).

What module or environment variable requests loading pk-gtk-module?

I also do not see this as a duplicate of #747449.

Comment 32 Matthew Saltzman 2012-06-01 02:20:30 UTC
$ emacs
Gtk-Message: Failed to load module "pk-gtk-module"

This is a fresh Fedora 17 install on x86_64.  PakcageKit-gtk3-module is installed, and I don't see anything else relevant to try to install.

$ sudo yum list PackageKit\*
Loaded plugins: langpacks, presto, refresh-packagekit
Installed Packages
PackageKit.x86_64                             0.7.4-3.fc17           @anaconda-0
PackageKit-command-not-found.x86_64           0.7.4-3.fc17           @anaconda-0
PackageKit-device-rebind.x86_64               0.7.4-3.fc17           @anaconda-0
PackageKit-glib.x86_64                        0.7.4-3.fc17           @anaconda-0
PackageKit-gstreamer-plugin.x86_64            0.7.4-3.fc17           @anaconda-0
PackageKit-gtk3-module.x86_64                 0.7.4-3.fc17           @anaconda-0
PackageKit-yum.x86_64                         0.7.4-3.fc17           @anaconda-0
PackageKit-yum-plugin.x86_64                  0.7.4-3.fc17           @anaconda-0
Available Packages
PackageKit-backend-devel.i686                 0.7.4-3.fc17           fedora     
PackageKit-backend-devel.x86_64               0.7.4-3.fc17           fedora     
PackageKit-browser-plugin.x86_64              0.7.4-3.fc17           fedora     
PackageKit-cron.x86_64                        0.7.4-3.fc17           fedora     
PackageKit-debug-install.x86_64               0.7.4-3.fc17           fedora     
PackageKit-docs.noarch                        0.7.4-3.fc17           fedora     
PackageKit-glib.i686                          0.7.4-3.fc17           fedora     
PackageKit-glib-devel.i686                    0.7.4-3.fc17           fedora     
PackageKit-glib-devel.x86_64                  0.7.4-3.fc17           fedora     
PackageKit-qt.i686                            0.7.4-3.fc17           fedora     
PackageKit-qt.x86_64                          0.7.4-3.fc17           fedora     
PackageKit-qt-devel.i686                      0.7.4-3.fc17           fedora     
PackageKit-qt-devel.x86_64                    0.7.4-3.fc17           fedora     
PackageKit-smart.x86_64                       0.7.4-3.fc17           fedora     
PackageKit-zif.x86_64                         0.7.4-3.fc17           fedora

Comment 33 Need Real Name 2012-06-03 06:10:41 UTC
same thing in F17
#emacs
Gtk-Message: Failed to load module "pk-gtk-module"

#gnuplot
gnuplot> plot sin(x)/x 
Gtk-Message: Failed to load module "pk-gtk-module"

Comment 34 Aaron Lu 2012-06-03 13:54:13 UTC
Same here with a fresh installed F17 x86_64.

[aaron@localhost ~]$ gvim
Gtk-Message: Failed to load module "pk-gtk-module"

[aaron@localhost ~]$ rpm -qa |grep PackageKit
PackageKit-command-not-found-0.7.4-4.fc17.x86_64
PackageKit-glib-0.7.4-4.fc17.x86_64
PackageKit-device-rebind-0.7.4-4.fc17.x86_64
PackageKit-yum-plugin-0.7.4-4.fc17.x86_64
PackageKit-yum-0.7.4-4.fc17.x86_64
PackageKit-gtk3-module-0.7.4-4.fc17.x86_64
PackageKit-0.7.4-4.fc17.x86_64
PackageKit-gstreamer-plugin-0.7.4-4.fc17.x86_64

Comment 35 RR 2012-06-05 13:39:04 UTC
Same with fresh F17 installation

# seaudit
Gtk-Message: Failed to load module "pk-gtk-module"
GLib (gthread-posix.c): Unexpected error from C library during 'pthread_cond_timedwait': Zły argument.  Aborting.

# uname -a
Linux 3.3.7-1.fc17.i686.PAE #1 SMP Mon May 21 22:42:05 UTC 2012 i686 i686 i386 GNU/Linux

#rpm -qa | grep PackageKit
PackageKit-glib-0.7.4-4.fc17.i686
PackageKit-gtk3-module-0.7.4-4.fc17.i686
PackageKit-yum-0.7.4-4.fc17.i686
PackageKit-gstreamer-plugin-0.7.4-4.fc17.i686
PackageKit-device-rebind-0.7.4-4.fc17.i686
PackageKit-command-not-found-0.7.4-4.fc17.i686
PackageKit-yum-plugin-0.7.4-4.fc17.i686
PackageKit-0.7.4-4.fc17.i686

Comment 36 benoît barthés 2012-06-07 13:18:50 UTC
gtg

** (process:8029): WARNING **: Trying to register gtype 'GMountMountFlags' as enum when in fact it is of type 'GFlags'

** (process:8029): WARNING **: Trying to register gtype 'GDriveStartFlags' as enum when in fact it is of type 'GFlags'

** (process:8029): WARNING **: Trying to register gtype 'GSocketMsgFlags' as enum when in fact it is of type 'GFlags'
Gtk-Message: Failed to load module "pk-gtk-module"
/usr/lib/python2.7/site-packages/GTG/taskeditor/editor.py:71: Warning: cannot register existing type `GdkDisplayManager'
  self.builder.add_from_file(GnomeConfig.GLADE_FILE)
/usr/lib/python2.7/site-packages/GTG/taskeditor/editor.py:71: Warning: g_once_init_leave: assertion `result != 0' failed
  self.builder.add_from_file(GnomeConfig.GLADE_FILE)
/usr/lib/python2.7/site-packages/GTG/taskeditor/editor.py:71: Warning: g_type_register_static: assertion `parent_type > 0' failed
  self.builder.add_from_file(GnomeConfig.GLADE_FILE)
/usr/lib/python2.7/site-packages/GTG/taskeditor/editor.py:71: Warning: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed
  self.builder.add_from_f

Comment 37 muzuiget 2012-07-22 13:03:57 UTC
some problem on Fedora 17 x64 when install PackageKit.i686

I think it better to split the python files to a new package with ".noarch".


Note You need to log in before you can comment on or make changes to this bug.