Bug 643679 - Review Request: globus-gridmap-callout-error - Globus Toolkit - Globus Gridmap Callout Errors
Summary: Review Request: globus-gridmap-callout-error - Globus Toolkit - Globus Gridma...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Steve Traylen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-10-17 09:52 UTC by Mattias Ellert
Modified: 2011-03-14 05:39 UTC (History)
7 users (show)

Fixed In Version: globus-gridmap-callout-error-0.3-1.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-13 18:52:58 UTC
steve.traylen: fedora-review+
tibbs: fedora-cvs+


Attachments (Terms of Use)

Description Mattias Ellert 2010-10-17 09:52:06 UTC
Spec URL: http://www.grid.tsl.uu.se/review/globus-gridmap-callout-error.spec
SRPM URL: http://www.grid.tsl.uu.se/review/globus-gridmap-callout-error-0.3-1.fc12.src.rpm

Description:
The Globus Toolkit is an open source software toolkit used for building Grid
systems and applications. It is being developed by the Globus Alliance and
many others all over the world. A growing number of projects and companies are
using the Globus Toolkit to unlock the potential of grids for their cause.

The globus-gridmap-callout-error package contains:
Globus Gridmap Callout Errors

Comment 1 Dennis van Dok 2011-02-16 13:58:23 UTC
Unpacking the source rpm failed for me:

rpm -i globus-gridmap-callout-error-0.3-1.fc12.src.rpm warning: user ellert does not exist - using root
warning: group ellert does not exist - using root
error: unpacking of archive failed on file /home/dennisvd/rpmbuild/SOURCES/epstopdf-2.9.5gw;4d5bd741: cpio: MD5 sum mismatch

What is epstopdf doing in this src.rpm anyway?

Comment 2 Mattias Ellert 2011-02-16 15:26:31 UTC
Are you trying to build on RHEL/SL/CentOS 5?

RHEL 5 has an older version of rpm, that can not verify the SRPM created on Fedora 12 because it uses newer a checksum algorithm.

I downloaded the SRPM and it installed without problem on Fedora 14 for me. If I try to install it on CentOS 5 I get a similar error as you.

The epstopdf is there for working around a bug in RHEL5, as explained in the specfile:

#		This is a workaround for the broken epstopdf script in RHEL5
#		See: https://bugzilla.redhat.com/show_bug.cgi?id=450388
Source9:	epstopdf-2.9.5gw

Comment 3 Dennis van Dok 2011-02-16 18:09:17 UTC
Yes, I used CentOS 5.

In the meantime I have obtained the sources from elsewhere and successfully built an rpm. I will verify the product soon.

The spec file describes how the source tarball was created (I reproduced these steps) but the epstopdf to me is unclear. I found epstopdf.pl in a recent texlive and this seemed to work, but could you provide the provenance of this source file?

I would like to review the package, but my understanding is that a fedora member should do this and I am not.

Comment 4 Steve Traylen 2011-02-24 18:12:16 UTC
Note to Denis, if you want to be able review packages see:
http://fedoraproject.org/wiki/PackageMaintainers/Join


Review of globus-gridmap-callout-error

Mock , f14 x86_64 okay.
rpmlint  of .spec, srpm, noarch and x86_64 bit packages:

$ rpmlint ./globus-gridmap-callout-error.spec \
    ../SRPMS/globus-gridmap-callout-error-0.3-1.fc14.src.rpm \
    ../RPMS/noarch/globus-gridmap-callout-error-doc-0.3-1.fc14.noarch.rpm \
    ../RPMS/x86_64/globus-gridmap-callout-error-*
./globus-gridmap-callout-error.spec: W: invalid-url Source0: globus_gridmap_callout_error-0.3.tar.gz
globus-gridmap-callout-error.src: W: invalid-url Source0: globus_gridmap_callout_error-0.3.tar.gz
globus-gridmap-callout-error-debuginfo.x86_64: E: description-line-too-long C This package provides debug information for package globus-gridmap-callout-error.
globus-gridmap-callout-error-devel.x86_64: W: no-documentation
5 packages and 1 specfiles checked; 1 errors, 3 warnings.

which are all okay, Source is from a bigger source.
long line is only in the debuginfo package which is to hard to work around.

Globus Guidelines:
http://fedoraproject.org/wiki/Packaging:Globus


- Package meets naming and packaging guidelines
Globus
- Spec file matches base package name.
Globus
- Spec has consistant macro usage.
It does.
- Meets Packaging Guidelines.
Yes, the globus ons in particular.
- License
ASL 2.0
- License field in spec matches
All files have an apche header.
- License file included in package
GLOBUS_LICENSE
- Spec in American English
It is.
- Spec is legible.
It is.
- Sources match upstream md5sum:
Reconstucting the source:

wget -N http://www-unix.globus.org/ftppub/gt5/5.0/5.0.2/installers/src/gt5.0.2-all-source-installer.tar.bz2

tar -jxf gt5.0.2-all-source-installer.tar.bz2 gt5.0.2-all-source-installer/source-trees/gsi/gridmap_callout/error

tar zxvf globus_gridmap_callout_error-0.3.tar.gz

$ diff --brief -r globus_gridmap_callout_error-0.3/ gt5.0.2-all-source-installer/source-trees/gsi/gridmap_callout/error
Only in globus_gridmap_callout_error-0.3/: GLOBUS_LICENSE

which is expected.

- Package needs ExcludeArch
Not checked.
- BuildRequires correct
It is.
- Spec handles locales/find_lang
None present.
- Package is relocatable and has a reason to be.
Not relocatable.
- Package has %defattr and permissions on files is good.
It does.
- Package has a correct %clean section.
It does.
- Package has correct buildroot
%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
- Package is code or permissible content.
Yes.
- Doc subpackage needed/used.
Yes a doc sub package is created.
- Packages %doc files don't affect runtime.
Fine
- Headers/static libs in -devel subpackage.
Fine.
- Spec has needed ldconfig in post and postun
It doe.s
- .pc files in -devel subpackage/requires pkgconfig
Yes for Fedora but see below.
- .so files in -devel subpackage.
Yes.
- -devel package Requires: %{name} = %{version}-%{release}
- .la files are removed.
They are indeed.
- Package is a GUI app and has a .desktop file
No gui.
- Package compiles and builds on at least one arch.
Mock
- Package has no duplicate files in %files.
There are not.
- Package doesn't own any directories other packages own.
It's fine.
- Package owns all the directories it creates.
It does.
- final provides and requires are sane:

===== globus-gridmap-callout-error-0.3-1.fc14.src.rpm
== provides
== requires
grid-packaging-tools  
globus-common-devel(x86-64) >= 3
globus-gssapi-error-devel(x86-64) >= 2
globus-core(x86-64) >= 4
doxygen  
graphviz  
ghostscript  
tex(latex)  

===== globus-gridmap-callout-error-0.3-1.fc14.x86_64.rpm
== provides
libglobus_gridmap_callout_error.so.0()(64bit)  
globus-gridmap-callout-error = 0.3-1.fc14
globus-gridmap-callout-error(x86-64) = 0.3-1.fc14
== requires
/sbin/ldconfig  
/sbin/ldconfig  
globus-common  
libglobus_common.so.0()(64bit)  
libglobus_gridmap_callout_error.so.0()(64bit)  

===== globus-gridmap-callout-error-debuginfo-0.3-1.fc14.x86_64.rpm
== provides
globus-gridmap-callout-error-debuginfo = 0.3-1.fc14
globus-gridmap-callout-error-debuginfo(x86-64) = 0.3-1.fc14
== requires

===== globus-gridmap-callout-error-devel-0.3-1.fc14.x86_64.rpm
== provides
pkgconfig(globus-gridmap-callout-error) = 0.3
globus-gridmap-callout-error-devel = 0.3-1.fc14
globus-gridmap-callout-error-devel(x86-64) = 0.3-1.fc14
== requires
/usr/bin/pkg-config  
globus-common-devel(x86-64) >= 3
globus-core(x86-64) >= 4
globus-gridmap-callout-error(x86-64) = 0.3-1.fc14
globus-gssapi-error-devel(x86-64) >= 2
libglobus_gridmap_callout_error.so.0()(64bit)  
pkgconfig(globus-common) >= 3
pkgconfig(globus-core) >= 4
pkgconfig(globus-gssapi-error) >= 2

===== globus-gridmap-callout-error-doc-0.3-1.fc14.noarch.rpm
== provides
globus-gridmap-callout-error-doc = 0.3-1.fc14
== requires
globus-gridmap-callout-error = 0.3-1.fc14

SHOULD Items:

- Should build in mock.
It does.
- Should build on all supported archs
Not checked.
- Should function as described.
Not checked.
- Should have sane scriptlets.
It does.
- Should have subpackages require base package with fully versioned depend.
They do including the isa tag
- Should have dist tag
Yes.
- Should package latest version
Not checked but it's the "right" version.


Issues:

Just the one EPEL 5 needs a Requires for pkgconfig unless this gets pulled in by one of the
devel allready pulled in which is quite possible. Check before committing.

On the whole a text book globus package.


APPROVED.

Comment 5 Mattias Ellert 2011-02-24 18:48:02 UTC
New Package SCM Request
=======================
Package Name: globus-gridmap-callout-error
Short Description: Globus Toolkit - Globus Gridmap Callout Errors
Owners: ellert
Branches: f13 f14 f15 el4 el5 el6
InitialCC:

Comment 6 Jason Tibbitts 2011-02-25 03:09:49 UTC
Git done (by process-git-requests).

Comment 7 Fedora Update System 2011-02-25 04:36:29 UTC
globus-gridmap-callout-error-0.3-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/globus-gridmap-callout-error-0.3-1.fc13

Comment 8 Fedora Update System 2011-02-25 04:36:36 UTC
globus-gridmap-callout-error-0.3-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/globus-gridmap-callout-error-0.3-1.fc15

Comment 9 Fedora Update System 2011-02-25 04:36:44 UTC
globus-gridmap-callout-error-0.3-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/globus-gridmap-callout-error-0.3-1.el6

Comment 10 Fedora Update System 2011-02-25 04:36:52 UTC
globus-gridmap-callout-error-0.3-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/globus-gridmap-callout-error-0.3-1.el5

Comment 11 Fedora Update System 2011-02-25 04:37:00 UTC
globus-gridmap-callout-error-0.3-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/globus-gridmap-callout-error-0.3-1.fc14

Comment 12 Fedora Update System 2011-02-25 04:37:07 UTC
globus-gridmap-callout-error-0.3-1.el4 has been submitted as an update for Fedora EPEL 4.
https://admin.fedoraproject.org/updates/globus-gridmap-callout-error-0.3-1.el4

Comment 13 Fedora Update System 2011-02-25 08:20:16 UTC
globus-gridmap-callout-error-0.3-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update globus-gridmap-callout-error'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/globus-gridmap-callout-error-0.3-1.fc13

Comment 14 Fedora Update System 2011-03-13 18:52:52 UTC
globus-gridmap-callout-error-0.3-1.el4 has been pushed to the Fedora EPEL 4 stable repository.

Comment 15 Fedora Update System 2011-03-13 18:53:13 UTC
globus-gridmap-callout-error-0.3-1.el6 has been pushed to the Fedora EPEL 6 stable repository.

Comment 16 Fedora Update System 2011-03-13 18:53:58 UTC
globus-gridmap-callout-error-0.3-1.el5 has been pushed to the Fedora EPEL 5 stable repository.

Comment 17 Fedora Update System 2011-03-13 21:17:08 UTC
globus-gridmap-callout-error-0.3-1.fc13 has been pushed to the Fedora 13 stable repository.

Comment 18 Fedora Update System 2011-03-13 21:18:30 UTC
globus-gridmap-callout-error-0.3-1.fc14 has been pushed to the Fedora 14 stable repository.

Comment 19 Fedora Update System 2011-03-14 05:39:38 UTC
globus-gridmap-callout-error-0.3-1.fc15 has been pushed to the Fedora 15 stable repository.


Note You need to log in before you can comment on or make changes to this bug.