Bug 643982 - Internal error reading console log output. vm won't start
Internal error reading console log output. vm won't start
Status: CLOSED DUPLICATE of bug 623957
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-18 13:58 EDT by darrell pfeifer
Modified: 2010-10-19 18:58 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-19 18:06:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description darrell pfeifer 2010-10-18 13:58:44 EDT
Description of problem:


Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 878, in run_domain
    vm.startup()
  File "/usr/share/virt-manager/virtManager/domain.py", line 1321, in startup
    self._backend.create()
  File "/usr/lib64/python2.7/site-packages/libvirt.py", line 333, in create
    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: internal error Process exited while reading console log output:
Supported machines are:
pc         Standard PC (alias of pc-0.13)
pc-0.13    Standard PC (default)
pc-0.12    Standard PC
pc-0.11    Standard PC, qemu 0.11
pc-0.10    Standard PC, qemu 0.10
isapc      ISA-only PC


Version-Release number of selected component (if applicable):

virt-manager-0.8.5-1.fc15.noarch

How reproducible:

Attempting to start an old F13 vm. This happened after bug 638457 was fixed.

Additional info:
Comment 1 Chris Lalancette 2010-10-19 18:06:22 EDT
Yeah, this is a known bug.  Unfortunately we made a mistake in Fedora 13 and added a "fedora13" machine type that never should have existed.

There are two ways to get around it:
1)  Update your packages qemu-0.13.0-0.6.rc1.fc14 or later, which should contain a backwards compatible fix for this.

2)  Edit your domain XML (virsh edit <domain>), remove the part of the XML that says "machine='fedora-13'", and save the guest.  libvirt will fill in the "correct" machine type going forward, and this shouldn't happen again.

Chris Lalancette

*** This bug has been marked as a duplicate of bug 623957 ***
Comment 2 darrell pfeifer 2010-10-19 18:58:20 EDT
1) Can you push the latest qemu into rawhide? It currently only seems to be updated in f14, not f15

2) virsh 0.8.4 checks for a bad machine time and doesn't allow the change.

error: unknown OS type no OS type

Note You need to log in before you can comment on or make changes to this bug.