Bug 64564 - Installer terminates after formatting partitions
Installer terminates after formatting partitions
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-07 20:14 EDT by Kenneth G. Fuchs
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-13 16:32:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is the anacdump.txt file that anaconda generates when it fails. (669 bytes, text/plain)
2002-05-07 20:47 EDT, Kenneth G. Fuchs
no flags Details

  None (edit)
Description Kenneth G. Fuchs 2002-05-07 20:14:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.61 [en] (X11; I; Linux 2.2.10 i686)

Description of problem:
Selected custom install everything.  Both grapical and text installs fail right
after formatting partitions.  Resulting anacdump.txt is attached for a graphical
install.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot Red Hat Linux 7.0 CD-ROM
2. Language Selection: English
3. Keyboard Configuration: Generic 104-key PC, U.S. English, Enable dead keys
4. Mouse Configuration: Use default of "3 Button Mouse (PS/2)". <MS
IntelliMouse>
    Check "Emulate 3 buttons".
5. Red Hat Linux 7.0 System Installer: <Press Next button.>
6. Install Options: Check "Custom System".
7. Automatic Partitioning: Check "Manually partition with fdisk".
8. fdisk (page 1): Press hda button.
9. fdisk (page 2): Type p<CR>.  Displays 18 partitions comprising one Windows
2000
   and five GNU/Linux OSes with room for Red Hat Linux 7.0.  Type q<CR>.
10. Disk Druid: Set hda8 = /boot (15MB), hda13 = swap (133MB) and hda14 = / (3
GB).
11. Choose partitions to format: Default of hda8 (/boot) and hda14 (/) is used.
12. Lilo Configuration: Default of "Create boot disk" is used.  Change "linux"
Boot label
     to "RH7.0" or somthing similar.
13. Network Configuration: Enter valid values for static IP address.  Use
"Activate on
     boot".
14. Time Zone Selection: Check "America/Chicago  Central Time".
15. Account Configuration: Enter root password twice.  (No other accounts
entered.)
16. Authentication Configuration: Use defaults of MD5 and shadow passwords. 
Check
     "Enable NIS" and enter NIS Domain.  Check "Use broadcast to find NIS
Server".
17. Package Group Selection: Check every group including Everything (1981MB).
18. Monitor Configuration: Default of "Dell D1025TM" is correct and is used.
19. X Configuration: Default of ATI Mach 64 and 4096K ised used.  KDE is
selected.
20. About to Install:  <Press Next button.>

Actual Results:  Fails right after formatting.  See attached anacdump.txt.

Expected Results:  All selected packages should be installed.  Installation
should terminate after successfully installing Red Hat Linux 7.0.

Additional info:

Machine is basic configuration of Dell Optiplex GX1 (400MHz Pentium II).
Comment 1 Kenneth G. Fuchs 2002-05-07 20:47:29 EDT
Created attachment 56587 [details]
This is the anacdump.txt file that anaconda generates when it fails.
Comment 2 Michael Fulbright 2002-05-09 14:42:49 EDT
Please try the 7.3 release, its has many many bug fixes.
Comment 3 Kenneth G. Fuchs 2002-05-13 11:35:27 EDT
We need to install Red Hat Linux 7.0, not 7.3.  Can we use the Red Hat Linux 7.3 installer to install Red Hat Linux 7.0?  We need a solution that 
installs Red Hat Linux 7.0 successfully.
Comment 4 Michael Fulbright 2002-05-13 16:32:24 EDT
No you cannot install 7.0 with the 7.3 installer.
Comment 5 Michael Fulbright 2002-05-13 16:38:10 EDT
Did you happen to define any mountpoints for non-Linux partitions (like VFAT)
while in the installer?

I would recommend you look at these bugs, they appear to have similar problems:

Bug 18571
Bug 34971
Bug 35399
Bug 53632

We do not release fixes for older releases, as we roll all our fixes into the
next release.
Comment 6 Kenneth G. Fuchs 2002-05-15 14:21:30 EDT
This bug (64564) is identical (exact same anacdump.txt contents) to bug #18571.

I repeated the install and got the same anacdump.txt that I attached (7 May 2002).  Looking at virtual console #4, I noted that 8 of the 10 swap 
partitions were initialized.  Thus, it appears that the install failed while initializing swap partitions (not after, as I wrongly assumed in my intial bug 
report).

Work around: Modify step 9 of the steps to reproduce.  A total of ten 128M swap partitions are defined (6 on hda and 4 on hdb).  Using fdisk on hda, 
simply change three of the swap partitions' type from 82 (Linux swap) to 16 (Hidden FAT16) with the t command.  After the install is complete they 
could be switched back to 82.  Now, only seven swap partitions are defined which are successully intitialzed and software installation proceeds to 
completion.  It may work to hide enough swap partitions to leave exactly eight swap partitions defined by fdisk and unhide and initialize them after 
the installation, but I didn't try this.  It was safer to leave seven swap partitions defined and not risk testing the boundaries of the bug too closely.

The person that reported #18571 said they tried four 256M partitions, but that failed.  So, it may not be the number of swap paritions, but the total 
space of swap partitions that is the problem.  If this is the case, the Red Hat Linux 7.0 limit is between 1024M (4 * 256M) and  896M (7 * 128M).

The installer should allow the user to decide whether or not to format or even use a swap partition.  The Red Hat Linux 7.0 installer doesn't seem to 
offer this flexibility.  It seems to want to initialize and setup all Linux swap partitions for the Red Hat Linux 7.0 instance it is installing.  This may not 
work well for a virtual machine setup where numerous operating systems need access to their own private swap partition.  I'm not aware of any 
independent operating systems that can share swap space simultaneously without the potential of causing each other to fail.

A loosely related problem:  I often have more than 16 partitions on a single hard drive and Red Hat Linux 7.0 seems to define special character files 
(/dev/hd[a-]?) for partitions (? =) 1-16 only.  To install to partitions 17 and greater, I usually install to a partition number less than 17 and use tar to 
copy it to the final destination partition, create the missing special character files and adjust /etc/fstab accordingly.  The loose connection is one of 
my swap partitions was hda17 and it can't be used until I manually create special character file /dev/hda17.  I think Red Hat Linux 7.2 defines 
special character files for partitions 1-32, but as hard drives get larger, there is more room for more partitions.  A limit of 32 may not be enough, 
especially when numerous small boot, swap and other special partitions are defined in addition to the usual root, other system partitions plus data 
partitions plus the extra partitions needed to support multiboot, various operating systems and multiple filesystems.

General comments about how Bugzilla is being used:

    I think bugs should be considered duplicates only when they have identical symptoms.

    The number of "duplicates" is sometimes unmanageable.  For example, bug #18032 has nearly 500 duplicates listed.  It's hard to find useful
     information among all the duplicate bug notifications.

Thank you for your help in installing Red Hat Linux 7.0.

Sincerely,

Ken Fuchs
Comment 7 Kenneth G. Fuchs 2002-05-16 19:00:38 EDT
From the attached anacdump.txt file, one can see that the installer crashes with an "Operation not permitted" error from swapon when it tries to 
utilize the 9th swap partition with swapon.  This is the same error generated when swapon is manually used to attempt adding a 9th swap partition.  
The Red Hat GNU/Linux 7.0 mkswap(8) manual page says that Linux is currently limited to at most 8 swap areas (partitions + files).  This limit is 
different on Red Hat GNU/Linux 7.2, since swapon can be used to add a 9th and 10th partition and possibly more.  Thus, this problem has nothing 
to do with total swap space size as I mentioned in my previos comment as a possible cause.  This problem is solely caused by the installer trying 
to add more swap areas than the kernel can handle and handling the resulting "Operation not permitted" error inappropriately (crashing rather than 
ignoring it).  Forunately, the simple work around of hiding swap partitions in excess of eight works (i.e. changing the partition type from 82 to 16).

Note You need to log in before you can comment on or make changes to this bug.