Bug 64594 - RedHat menu entries missing from KDE menu
Summary: RedHat menu entries missing from KDE menu
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
high
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
: 68024 (view as bug list)
Depends On:
Blocks: 68121
TreeView+ depends on / blocked
 
Reported: 2002-05-08 14:20 UTC by Andreas Metzler
Modified: 2007-03-27 03:53 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-17 12:59:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andreas Metzler 2002-05-08 14:20:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020417

Description of problem:
The RedHat menu entries (/etc/X11/applnk/) are not integrated in the KDE menu.

Version-Release number of selected component (if applicable):
3.0.0-12

How reproducible:
Always

Suggested Fix:
ln -s /etc/X11/applnk /usr/share/applnk/RedHat

Comment 1 Unmanarc 2002-05-08 19:05:00 UTC
 THX!!! 
 
I have the same problem, Redhat must solve the problem by RHN Updates. 
 
Good Luck!. 


Comment 2 Gerald Teschl 2002-05-08 19:11:59 UTC
Think I found the problem:

If I have an entry "Language=C" in ~/.kde/share/config/kdeglobals,
then the desktop files under /etc/X11/applnk will not show
up in the menues. If I remove the "C", they will show up.


Comment 3 Unmanarc 2002-05-08 19:23:26 UTC
 yes, and this bashline can also solve the problem :)  
  
ls -1 /etc/X11/applnk/ | awk '{print "cp -a /etc/X11/applnk/"$1"  
/usr/share/applnk/"}' | bash  
  
this copy applnk directories to applnk, but better is solve the problem with   
 remove "C" from this file, because if I install new program, this program 
will copy itself to /etc/X11/applnk/ and no to /etc/X11/applnk/ and I'll to 
excecute my line already. 
 


Comment 4 Kirk 2002-05-09 01:10:56 UTC
I upgrade from 7.2 to 7.3.  I have the same problem.  Additionally, when I went
into Gnome the items were there, but they were below the other items in the same
menu, not in  the usual order.  I looked at Gnome menu editor, and these entries
were listed in the "to be merged" section.  (I don't use Gnome much, so I'm not
sure what this means.)

Here's another variation for a solution (for KDE anyway):
KDE>Control Center>Country & Language>Add Language>"English US"

This makes the line in ~/.kde/share/config/kdeglobals say

Language=en_US:C

I restarted KDE and my menus returned. 


Comment 5 stuart boreen 2002-05-14 23:18:27 UTC
I also did not see all my menu items after a 7.2 to 7.3 upgrade.
I went to control center and added US English and all the items I could see in
the menu editor now show up in the K menu.
There should be an "up2date" fix for this because customizing menus is very
important!

Comment 6 okram 2002-05-15 12:43:03 UTC
Same problem here, except adding US English does NOT solve the problem.

Comment 7 Adam Pribyl 2002-05-16 18:02:39 UTC
Can not use Enaglish US.. in cz environment. Still using it does not help.

Comment 8 Gerald Teschl 2002-05-27 19:01:49 UTC
It looks like if the default language is not en_US it does not
work. At least the entries are gone for every user who uses
german as main language here. Moreover, the entries are entirely
ignored by kde. In particular, all apps are not available to
the file manager as well. This is a serious problem here and
should be fixed ASAP!

Comment 9 Martin Piskernig 2002-05-27 19:32:32 UTC
Same problem here. Together with the dcopserver bug (#65460) this calls 
for an immediate kdebase (and maybe also kdelibs) update! I don't know 
how many more bugs are there lurking in the KDE packages which could 
have been found by QA easily.


Comment 10 Michael Schwendt 2002-06-08 13:41:04 UTC
Had language 'C' after an upgrade from 7.2 to 7.3 and needed to change the
language to "English US" to get back many menu entries in "System"
(/etc/X11/applnk).

KMenu > Preferences > Personalization > Country & Language

I've noticed not all menu entries are translated to many languages. I'm unable
to get those menu entries for KDE language "German" and a "de_DE@euro" locale.


Comment 11 Stefan Frings 2002-06-11 07:53:40 UTC
Some menue entries are not visible but in the menu editor they are visible. If I edit them (does not matter what I edit, but I need to edit something to 
enable the "apply" button) and klick on apply they appear in the menu. I use Redhat 7.3, KDE 3.0.0 with german language.

Comment 12 Ronny Buchmann 2002-06-14 14:41:10 UTC
this problem doesn't appear with kdebase-3.0.0-2 (also not with kdebase in 2nd
skipjack, dont have it here to tell release number)

Comment 13 Wojciech Kazubski 2002-06-17 12:24:01 UTC
The entries are missing in polish locale too.
If they are edited, the new version is stored in the user directory
(~/.kde/share/applnk) and so becomes visible.

Comment 14 Ronny Buchmann 2002-07-11 07:20:51 UTC
this bug is actually in kdelibs not kdebase.

proof:
after upgrading kdelibs w/o kdebase from 3.0.0-4 to 3.0.0-12 (valhalla) the menu
entries disappeared

please change bug accordingly

Comment 15 Havoc Pennington 2002-07-15 01:46:50 UTC
*** Bug 68024 has been marked as a duplicate of this bug. ***

Comment 16 Ngo Than 2003-12-17 12:59:03 UTC
it's fixed in Fedora Core1 release. 


Note You need to log in before you can comment on or make changes to this bug.