Bug 648050 - [abrt] Assertion failure: "xcb_io.c:221: poll_for_event: Assertion `(((long) (event_sequence) - (long) (dpy->request)) <= 0)" running setroubleshoot-server-2.2.102-1.fc14 [NEEDINFO]
[abrt] Assertion failure: "xcb_io.c:221: poll_for_event: Assertion `(((long) ...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
14
i686 Unspecified
low Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
abrt_hash:1687fd35564f98b00769a9856bc...
:
: 474009 475304 643094 645545 646795 647314 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-30 13:50 EDT by satellitgo
Modified: 2011-06-15 04:30 EDT (History)
22 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-01 08:42:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
nphilipp: needinfo? (mclasen)


Attachments (Terms of Use)
File: backtrace (19.98 KB, text/plain)
2010-10-30 13:50 EDT, satellitgo
no flags Details

  None (edit)
Description satellitgo 2010-10-30 13:50:55 EDT
abrt version: 1.1.13
architecture: i686
Attached file: backtrace
cmdline: /usr/bin/python -Es /usr/bin/sealert -s
component: setroubleshoot
crash_function: poll_for_event
executable: /usr/bin/python
kernel: 2.6.35.6-45.fc14.i686
package: setroubleshoot-server-2.2.102-1.fc14
rating: 4
reason: Process /usr/bin/python was killed by signal 6 (SIGABRT)
release: Fedora release 14 (Laughlin)
time: 1288460162
uid: 500

How to reproduce
-----
1.yum groupinstall gnome-desktop from f14 RC1-live-soas sugar-terminal
2.yum install sugar-emulator liveusb-creator livecd-tools spin-kickstarts
3.log out of sugar and switch to gnome with gdm
Comment 1 satellitgo 2010-10-30 13:50:56 EDT
Created attachment 456658 [details]
File: backtrace
Comment 2 Carl G. 2010-10-31 14:25:02 EDT
*** Bug 645545 has been marked as a duplicate of this bug. ***
Comment 3 satellitgo 2010-11-09 10:33:51 EST
Package: setroubleshoot-server-2.2.102-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.start f14 desktop live in Virtualbox
2.
3.
Comment 4 Karel Klíč 2010-11-09 11:48:19 EST
*** Bug 643094 has been marked as a duplicate of this bug. ***
Comment 5 Karel Klíč 2010-11-09 11:48:25 EST
*** Bug 646795 has been marked as a duplicate of this bug. ***
Comment 6 Karel Klíč 2010-11-09 11:48:29 EST
*** Bug 647314 has been marked as a duplicate of this bug. ***
Comment 7 Stef Walter 2010-11-09 23:34:22 EST
Package: setroubleshoot-server-2.2.102-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
Logged into my desktop. An SELinux window popped up complaining about ntpd. I tried to report the bug, and crash.
Comment 8 Daniel Walsh 2010-11-10 09:25:13 EST
Looks to me like a python crash.
Comment 9 Dave Malcolm 2010-11-10 11:17:14 EST
Thank you for reporting this bug.

How reproducible is this problem?  If you run the program from a terminal, is an error message printed?

What is the output of running the following command?
  rpm -qa gtk2 libxcb pygtk2

Looking at the backtrace, it looks like this: assertion failed
  xcb_io.c:221: poll_for_event: Assertion `(((long) (event_sequence) - (long) (dpy->request)) <= 0)
inside frame 3 of the program's single thread inside "poll_for_event", deep within GTK's main loop.  Something's gone wrong in the communication between GTK and the X server.

Reassigning component from "python" to "gtk2";  hopefully the gtk2 maintainer will be able to figure this out further or reassign as necessary.
Comment 10 Brian Lockwood 2010-11-21 12:22:21 EST
Package: setroubleshoot-server-2.2.102-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


Comment
-----
Click on report in the crash reporter for se linux
Comment 11 Brian Lockwood 2010-11-21 12:23:17 EST
Package: setroubleshoot-server-2.2.102-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Every time I click report in bug report
2.
3.


Comment
-----
No
Comment 12 Brian Lockwood 2010-11-21 13:40:43 EST
Package: setroubleshoot-server-2.2.102-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Click on "Update Policy" when the SELinux report appears.
2.
3.
Comment 13 Norm Powroz 2010-12-02 11:45:59 EST
Package: setroubleshoot-server-2.2.102-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Started setroubleshoot, which reported several postifx errors (cannot perform "getattr" on postfix/drop)
2.
clicked "Delete"
3.That's all folks.
Comment 14 Nils Philippsen 2010-12-06 05:35:59 EST
*** Bug 474009 has been marked as a duplicate of this bug. ***
Comment 15 Nils Philippsen 2010-12-06 06:23:34 EST
*** Bug 475304 has been marked as a duplicate of this bug. ***
Comment 16 Jon R. Kibler 2011-03-31 20:19:46 EDT
Package: setroubleshoot-server-2.2.102-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Clicked on "Update Policy"
2.
3.
Comment 17 Daniel Walsh 2011-04-01 08:42:01 EDT
Jon please update your system

yum -y update
Comment 18 Brian Lane 2011-05-06 13:34:33 EDT
What version is this supposed to be fixed in? I am still seeing it with gtk2-2.24-4-1.fc15 on an updated F15 Beta install when canceling ntp during firstboot (see bug 475304 and bug 702659)
Comment 19 Brian Lane 2011-05-06 13:37:47 EDT
*** Bug 702659 has been marked as a duplicate of this bug. ***
Comment 20 Nils Philippsen 2011-06-15 04:27:42 EDT
The reporter of bug #475304 has seen it happen again on F-15 and I could confirm it by running firstboot, configuring for NTP and cancelling the "Contacting NTP server" dialog:

nils@gibraltar:~> sudo firstboot
Loading /lib/kbd/keymaps/i386/qwertz/de-latin1-nodeadkeys.map.gz
python2: xcb_io.c:221: poll_for_event: Assertion `(((long) (event_sequence) - (long) (dpy->request)) <= 0)' failed.
firstboot: Fatal IO error 4 (Interrupted system call) on X server :0.0.
nils@gibraltar:~>

Matthias, do you want this bug reopened or a new one?
Comment 21 Nils Philippsen 2011-06-15 04:30:47 EDT
*** Bug 475304 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.