This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 62196 - Intermittent Konqueror & Bugzilla Form Submit errors
Intermittent Konqueror & Bugzilla Form Submit errors
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kdelibs (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
Ben Levenson
:
: 62616 62936 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-28 06:05 EST by Warren Togami
Modified: 2007-04-18 12:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-12 03:33:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2002-03-28 06:05:48 EST
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0; Linux) 
 
Description of problem: 
When I submit several differnet forms within Red Hat Bugzilla, Konqueror 
displays a page something like: 
 
Software error:Couldn't get form data at CGI.pl line 1444. 
 
For help, please send mail to the webmaster (bugzilla@redhat.com), giving this 
error message and the time and date of the error. 
 
This occurs roughly 50% of the time.  When it does occur I can always click 
back then resubmit, and it works after a try or two. 
 
Version-Release number of selected component (if applicable): 
Konqueror 2.9.9 (Skipjack) and Konqueror 3.0.0 (3-27-2002 up2date). 
 
How reproducible: 
Sometimes 
 
Steps to Reproduce: 
1. Use Konqueror to submit forms while querying or input bugs in Bugzilla. 
2. Occasional error pages, reloading usually brings expected result. 
  
Expected Results: 
I am guessing that this is an obscure Konqueror problem because it is the only 
web browser that exhibits this behavior in Bugzilla.
Comment 1 Warren Togami 2002-03-29 05:32:26 EST
Bero mentioned a Konqueror form submit patch being in kdelibs-3.0.0-2 but it has
not yet hit up2date.

Additional Info:  I noticed that the Konqueror w/ Bugzilla bug occurs only when
Bugzilla takes longer than 1-2 seconds to return the result of the form submit.
 In cases where the reaction is quicker than that, the submit is successful. 
Strange...
Comment 2 Preston Brown 2002-04-01 09:15:38 EST
 For extra data: I validated this bug internally.
Comment 3 Bernhard Rosenkraenzer 2002-04-03 08:51:50 EST
*** Bug 62616 has been marked as a duplicate of this bug. ***
Comment 4 Bernhard Rosenkraenzer 2002-04-03 09:05:36 EST
Timeout in http KIO slave. I've fixed it in 3.0.0-6. 
Comment 5 Bernhard Rosenkraenzer 2002-04-03 09:05:59 EST
(kdelibs 3.0.0-6, that is). 
Comment 6 Warren Togami 2002-04-05 20:38:19 EST
Tested in Skipjack beta 2    
It still occurs sometimes in Bugzilla when I submit some Bugzilla forms, like  
when I tried to submit this bug update. 
 
... 
 
5th attempt...
Comment 7 Warren Togami 2002-04-08 04:06:32 EDT
Bug 62936 is a duplicate of this bug.  Another confirmation that the form 
submit bug of Konqueror is not yet fixed. 
Comment 8 Bernhard Rosenkraenzer 2002-04-08 05:58:38 EDT
*** Bug 62936 has been marked as a duplicate of this bug. ***
Comment 9 Warren Togami 2002-04-08 06:02:29 EDT
http://www.longs.com/cgi-bin/longs/home/guest.jsp?redirect=/prescription/efills.jsp  
  
This page exhibits similar form submit misbehavior.  Most of the time when I  
first submit the prescription refill form, it comes back saying, "We're sorry,  
but your personalized session on Longs.com has timed out, or you've tried to  
use a bookmark from a previous visit. To protect your privacy, we have our  
site configured to log you off after a certain period of inactivity."  
  
If I click Back and resubmit the form, it accepts it on the 3rd, 4th, or 5th  
try.  I think this info may help to narrow the problem down a bit more.
Comment 10 Warren Togami 2002-04-14 08:18:08 EDT
Doh.  Sometimes attaching files to Bugzilla with Konqueror has a similar 
errors.  Took several tries to attach some patches in Bugzilla. 
Comment 11 Warren Togami 2002-05-09 06:58:34 EDT
Re-tested: Still appears to be broken in Red Hat Linux 7.3. 
 
Bug 64554 is a duplicate of this bug.
Comment 12 Warren Togami 2002-08-07 07:05:14 EDT
I haven't seen this behavior in Limbo.  Could this have been the same issue as 
Bug 64236?

Note You need to log in before you can comment on or make changes to this bug.