Bug 65178 - sane does not identify my scanner
sane does not identify my scanner
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: sane-backends (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
: 67116 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-19 09:15 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-22 11:07:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
resullts of debug with 1.0.5 (134 bytes, text/plain)
2002-06-20 20:34 EDT, Need Real Name
no flags Details
results of debug with sane-backends.1.0.7-6.1 installed (267 bytes, text/plain)
2002-06-20 20:36 EDT, Need Real Name
no flags Details
second run of rpm -V sane-backends with different result (1.56 KB, text/plain)
2002-06-22 11:00 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-05-19 09:15:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; CDonDemand; rv:0.9.4)
Gecko/20011019 Netscape6/6.2

Description of problem:
Ihave an hp scanner. Under 7.2 it worked fine. Under 7.3 I get message that no
scan device is found. sane-find-scanner identifies the scanner. The /dev/sg0
permissions are set to allow anyone to access it. Scanimage, xscanimage, and
Xsane all say there is no device attached. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run scanimage
2.
3.
	

Actual Results:  What can I say. I think the above note explains it.

Expected Results:  scanner should be identified

Additional info:
Comment 1 Tim Waugh 2002-05-24 06:37:03 EDT
Known issue. 

*** This bug has been marked as a duplicate of 64964 ***
Comment 2 Tim Waugh 2002-06-20 06:24:34 EDT
This turns out not to be a duplicate of bug #64964 after all.
Comment 3 Tim Waugh 2002-06-20 06:26:59 EDT
To clarify this report, I believe the scanner is a HP C6720?  
  
Please attach output of:  
  
  SANE_DEBUG_EPSON=129 scanimage -L 
Comment 4 Tim Waugh 2002-06-20 07:17:48 EDT
*** Bug 67116 has been marked as a duplicate of this bug. ***
Comment 5 Tim Waugh 2002-06-20 07:18:37 EDT
Oops, of course I meant the following: 
 
  SANE_DEBUG_HP=128 scanimage -L 
 
(128, not 129; and HP, not EPSON)
Comment 6 Need Real Name 2002-06-20 20:34:25 EDT
Created attachment 61984 [details]
resullts of debug with 1.0.5
Comment 7 Need Real Name 2002-06-20 20:36:42 EDT
Created attachment 61985 [details]
results of debug with sane-backends.1.0.7-6.1 installed
Comment 8 Need Real Name 2002-06-20 20:40:48 EDT
Sorry to be so awkward in attaching the files. Basically, I ran the
SANE_DEBUG_HP=128 scanimage -L under both sane-backends 1.0.5 and 1.0.7 for you.
I am not sure you learn anything from them . The scanner is identified under
1.0.5 and no scanner is identified  under 1.0.7. There are no more details in
teh output. Under 1.0.5 there was considerable output to the terminal, but it
did not show up in the file. The only output to the terminal under 1.0.7 was
what you see in the file.
Comment 9 Tim Waugh 2002-06-21 05:38:25 EDT
What does 'ls -l /dev/scanner' say? 
 
Also, what does 'rpm -V sane-backends' say?
Comment 10 Need Real Name 2002-06-21 09:05:11 EDT
ls -l /dev/scanner shows
lrwxrwxrwx    1 root     root            8 May 18 15:18 /dev/scanner -> /dev/sg0

results of rpm -V sane-backends show:
....L...   /usr/lib/sane/libsane-abaton.so.1
....L...   /usr/lib/sane/libsane-agfafocus.so.1
....L...   /usr/lib/sane/libsane-apple.so.1
....L...   /usr/lib/sane/libsane-artec.so.1
....L...   /usr/lib/sane/libsane-as6e.so.1
....L...   /usr/lib/sane/libsane-avision.so.1
....L...   /usr/lib/sane/libsane-bh.so.1
....L...   /usr/lib/sane/libsane-canon.so.1
....L...   /usr/lib/sane/libsane-coolscan.so.1
....L...   /usr/lib/sane/libsane-dc210.so.1
....L...   /usr/lib/sane/libsane-dc240.so.1
....L...   /usr/lib/sane/libsane-dc25.so.1
....L...   /usr/lib/sane/libsane-dll.so.1
....L...   /usr/lib/sane/libsane-dmc.so.1
....L...   /usr/lib/sane/libsane-epson.so.1
....L...   /usr/lib/sane/libsane-hp.so.1
....L...   /usr/lib/sane/libsane-m3096g.so.1
....L...   /usr/lib/sane/libsane-microtek.so.1
....L...   /usr/lib/sane/libsane-microtek2.so.1
....L...   /usr/lib/sane/libsane-mustek.so.1
....L...   /usr/lib/sane/libsane-mustek_pp.so.1
....L...   /usr/lib/sane/libsane-nec.so.1
....L...   /usr/lib/sane/libsane-net.so.1
....L...   /usr/lib/sane/libsane-pie.so.1
....L...   /usr/lib/sane/libsane-plustek.so.1
....L...   /usr/lib/sane/libsane-qcam.so.1
....L...   /usr/lib/sane/libsane-ricoh.so.1
....L...   /usr/lib/sane/libsane-s9036.so.1
....L...   /usr/lib/sane/libsane-sharp.so.1
....L...   /usr/lib/sane/libsane-snapscan.so.1
....L...   /usr/lib/sane/libsane-sp15c.so.1
....L...   /usr/lib/sane/libsane-st400.so.1
....L...   /usr/lib/sane/libsane-tamarack.so.1
....L...   /usr/lib/sane/libsane-umax.so.1
....L...   /usr/lib/sane/libsane-umax_pp.so.1
....L...   /usr/lib/sane/libsane-v4l.so.1
Comment 11 Need Real Name 2002-06-22 11:00:42 EDT
Created attachment 62184 [details]
second run of rpm -V sane-backends with different result
Comment 12 Need Real Name 2002-06-22 11:07:24 EDT
I have it fixed. 

With the results of rpm -V I looked for libsane-hp.so.1 on my system and it did
not exist. I therefore created a sym link for s0.1 to so.1.0.7. Now with
libsane-hp.so.1 linked to libsane-hp.so.1.0.7 it runs. I reran rpm -V and the
results are in the sane-backends.verify.txt that I uploaded. Interestingly, all
but the libsane-hp.so.1 are listed as missing. I do not know why they all were
not  listed as "missing" in the first run of rpm -V that I did.  For whatever
reason none of the links were created even with the patch to 1.0.7-6. 

From my perspective this could be closed. I am able to scan, copy. Thanks for
your time.
Comment 13 Tim Waugh 2002-06-23 05:41:37 EDT
How odd.  Well, glad it works now.  Closing.

Note You need to log in before you can comment on or make changes to this bug.