Bug 655783 - RFE: Check if dependent packages can be updated.
Summary: RFE: Check if dependent packages can be updated.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt
Version: rawhide
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Nikola Pajkovsky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 588310 (view as bug list)
Depends On: 555205 588310
Blocks: ABRTF17
TreeView+ depends on / blocked
 
Reported: 2010-11-22 13:22 UTC by Nils Philippsen
Modified: 2014-02-02 22:15 UTC (History)
10 users (show)

Fixed In Version: abrt-2.0.7-2.fc16
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-16 19:55:10 UTC


Attachments (Terms of Use)

Description Nils Philippsen 2010-11-22 13:22:11 UTC
This RFE expands on bug #588310 and bug #623062:

I think it would be helpful if abrt checked that the package being reported and all its dependencies are up to date. If one or more components of the stack are available in newer versions, it should simply tell the user to update instead of filing possibly obsolete bug reports.

Of course, this requires that versions of dependent packages are considered at all (bug #623062) and that information about updates is available (bug #588310).

Comment 1 Jiri Moskovcak 2011-12-07 07:34:20 UTC
Fixed in git (commit: b5726c7e28200937cbbbb2e9df3dc3e0a90c3794 and few others..)

Comment 2 Jiri Moskovcak 2011-12-07 07:35:27 UTC
*** Bug 588310 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Update System 2011-12-10 11:07:28 UTC
abrt-2.0.7-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/abrt-2.0.7-2.fc16

Comment 4 Fedora Update System 2011-12-11 21:58:52 UTC
Package abrt-2.0.7-2.fc16, libreport-2.0.8-3.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.7-2.fc16 libreport-2.0.8-3.fc16'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-16990/libreport-2.0.8-3.fc16,abrt-2.0.7-2.fc16
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2011-12-16 19:55:10 UTC
abrt-2.0.7-2.fc16, libreport-2.0.8-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.