Bug 660681 - (Mellanox6.1) Add IPoIB support in DHCP
Summary: (Mellanox6.1) Add IPoIB support in DHCP
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: dhcp
Version: 6.1
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: beta
: 6.1
Assignee: Jiri Popelka
QA Contact: Release Test Team
URL:
Whiteboard:
: 671008 (view as bug list)
Depends On:
Blocks: 580566 613642 660679 660686 661501
TreeView+ depends on / blocked
 
Reported: 2010-12-07 15:28 UTC by Vladimir Sokolovsky
Modified: 2018-11-14 16:52 UTC (History)
8 users (show)

Fixed In Version: dhcp-4.1.1-15.P1.el6
Doc Type: Enhancement
Doc Text:
The dhcp package now provides support for IPoIB (IP over InfiniBand) interfaces.
Clone Of: 660679
Environment:
Last Closed: 2011-05-19 14:05:09 UTC
Target Upstream Version:


Attachments (Terms of Use)
Patches created against dhcp-4.1.0p1-15.el6 (7.74 KB, application/x-gzip)
2011-01-24 16:43 UTC, Vladimir Sokolovsky
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0697 0 normal SHIPPED_LIVE dhcp bug fix and enhancement update 2011-05-18 18:10:16 UTC

Description Vladimir Sokolovsky 2010-12-07 15:28:55 UTC
+++ This bug was initially created as a clone of Bug #660679 +++

Description of problem:
DHCP does not support IPoIB interfaces

Expected results:
IPoIB interface: ib<N> interface to get the network configuration from the DHCP

Additional info:
Patch for DHCP will be provided soon by Mellanox

Comment 4 Ondrej Vasik 2011-01-20 14:50:23 UTC
Vladimir, what's the progress of the patch from Mellanox? Deadline for 6.1 update inclusion is closing... Do you have some ETA we can work with?

Comment 5 Jiri Popelka 2011-01-20 16:04:40 UTC
*** Bug 671008 has been marked as a duplicate of this bug. ***

Comment 6 Vladimir Sokolovsky 2011-01-24 16:43:46 UTC
Created attachment 474985 [details]
Patches created against dhcp-4.1.0p1-15.el6

IPoIB-dhcp-4.1.0p1-15.tar.gz includes the following patches:

dhcp-4.1.0p1-gpxe-cid.patch
dhcp-4.1.0p1-improved-xid.patch
dhcp-4.1.0p1-lpf-ib.patch
dhcp-4.1.0p1-rhel6-gpxe.patch
dhcp-4.1.0p1-rhel6.patch

These patches were created against dhcp-4.1.0p1-15.el6

Comment 13 Jan Stodola 2011-04-27 16:08:11 UTC
Tested on build RHEL6.1-20110420.0:
[root@rdma3 ~]# rpm -qa | grep dhc
dhclient-4.1.1-19.P1.el6.x86_64
dhcp-4.1.1-19.P1.el6.x86_64

Testing environment: Two machines connected to an IB switch, the first one configured as a DHCP server listening on ib0 interface, the second one was a DHCP client.

[root@rdma3 ~]# lspci | grep InfiniBand
0c:00.0 InfiniBand: QLogic, Corp. IBA6120 InfiniBand HCA (rev 02)
0e:00.0 InfiniBand: QLogic, Corp. IBA6120 InfiniBand HCA (rev 02)

After running "dhclient ib0" on the client machine, an IP address from the server was received and network interface ib0 was set based on the server configuration, I was able to login via ssh from the server to the client and vice-versa.

Moving to VERIFIED.

Comment 14 Tomas Capek 2011-05-10 14:27:28 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The dhcp package now provides support for IPoIB (IP over InfiniBand) interfaces.

Comment 15 errata-xmlrpc 2011-05-19 14:05:09 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0697.html


Note You need to log in before you can comment on or make changes to this bug.