Bug 665062 - add support for the postlogin PAM stack to util-linux-ng
Summary: add support for the postlogin PAM stack to util-linux-ng
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Karel Zak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: FutureFeature
Depends On: 665059
Blocks: 486152 F15Target
TreeView+ depends on / blocked
 
Reported: 2010-12-22 15:46 UTC by Paolo Bonzini
Modified: 2011-02-08 19:22 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 486152
Environment:
Last Closed: 2011-02-08 19:22:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to the package (1.42 KB, patch)
2010-12-22 15:55 UTC, Paolo Bonzini
pbonzini: review?
Details | Diff

Description Paolo Bonzini 2010-12-22 15:46:12 UTC
In order to use the automount feature of ecryptfs, for the ~/Private folder, some modifications to /etc/pam.d/system-auth are required.  In order to integrate pam_ecryptfs.so awareness into authconfig, we decided to create a new PAM stack.  This is because of the wide usage of "sufficient" modules for the primary authentication modules (pam_unix, pam_krb5, pam_sss, pam_ldap) in the configurations generated by authconfig.

Comment 1 Paolo Bonzini 2010-12-22 15:55:21 UTC
Created attachment 470226 [details]
patch to the package

Comment 2 Paolo Bonzini 2011-02-01 16:15:09 UTC
Comment on attachment 470226 [details]
patch to the package

Patch used to build http://koji.fedoraproject.org//koji/taskinfo?taskID=2754239 -- please review and apply.


Note You need to log in before you can comment on or make changes to this bug.