Bug 665095 - NewPkg: add qpid-cpp to RHEL 5.8
Summary: NewPkg: add qpid-cpp to RHEL 5.8
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: qpid-cpp
Version: 5.7
Hardware: All
OS: Linux
high
medium
Target Milestone: rc
: 5.8
Assignee: Ted Ross
QA Contact:
URL:
Whiteboard:
: 683491 (view as bug list)
Depends On: 683490 740330 740332 740335
Blocks: 665092 733358
TreeView+ depends on / blocked
 
Reported: 2010-12-22 17:41 UTC by Perry Myers
Modified: 2011-10-20 16:14 UTC (History)
7 users (show)

Fixed In Version: qpid-cpp-0.12-6.el5
Doc Type: Bug Fix
Doc Text:
Note that while qpid-cpp is built for all architectures in RHEL 5.8, it is only supported in the context of being used with Matahari.
Clone Of:
Environment:
Last Closed: 2011-10-20 16:14:54 UTC


Attachments (Terms of Use)

Description Perry Myers 2010-12-22 17:41:32 UTC
Description of problem:
qpid-cpp provides the libraries for qpid, QMF consoles and QMF Agents along with qpid brokers.

In RHEL 5 we need support for QMF Agent libraries so that Matahari can be deployed on RHEL5 hosts.  We do not necessarily need qpid brokers directly in RHEL5.

So this bug is to add qpid-cpp package to RHEL5 with a limited subset of the overall qpid-cpp functionality, specifically QMFv2 Agent support on the following architectures: PPC, ia64, x86, x86_64, zSeries

Comment 1 Ted Ross 2011-02-02 15:17:05 UTC
For reference, here is the list of sub-packages in qpid-cpp:

qmf
qmf-devel
qpid-cpp-client
qpid-cpp-client-devel
qpid-cpp-client-rdma
qpid-cpp-client-ssl
qpid-cpp-server
qpid-cpp-server-cluster
qpid-cpp-server-devel
qpid-cpp-server-rdma
qpid-cpp-server-ssl
qpid-cpp-server-store
qpid-cpp-server-xml
rh-qpid-cpp-tests
ruby-qmf
qpid-cpp-debuginfo

Comment 3 Denise Dumas 2011-03-15 14:19:42 UTC
Ted, this needs to follow package review process - see instructions at http://intranet.corp.redhat.com/ic/intranet/PackageListProcess

Comment 8 Perry Myers 2011-09-30 19:32:30 UTC
Comment #1 is slightly out of date, since qpid-qmf has since been split off of qpid-cpp as a separate top level component.  Here is the revised list of packages in qpid-cpp component:

qpid-cpp-client
qpid-cpp-client-devel
qpid-cpp-client-devel-docs
qpid-cpp-client-rdma
qpid-cpp-client-ssl
qpid-cpp-debuginfo
qpid-cpp-server
qpid-cpp-server-cluster
qpid-cpp-server-devel
qpid-cpp-server-rdma
qpid-cpp-server-ssl
qpid-cpp-server-store
qpid-cpp-server-xml

Of this list, I think the following subpacakges will need to be excluded from the RHEL 5 build, as they are MRG product specific:

qpid-cpp-client-rdma
qpid-cpp-server-cluster
qpid-cpp-server-rdma
qpid-cpp-server-store
qpid-cpp-server-xml

Removing these packages from both the build and spec file/rpm packaging should remove any dependencies on xquilla, xerces-c.  The dependency on graphviz should also be removed from the spec file.  None of those 3 packages should be put in RHEL 5.

Comment 9 Perry Myers 2011-09-30 19:38:04 UTC
*** Bug 683491 has been marked as a duplicate of this bug. ***

Comment 10 Russell Bryant 2011-10-11 19:20:45 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Note that while qpid-cpp is built for all architectures in RHEL 5.8, it is only supported in the context of being used with Matahari.


Note You need to log in before you can comment on or make changes to this bug.