Bug 671922 - ValueError: isys.umount() can only umount by mount point
ValueError: isys.umount() can only umount by mount point
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
AcceptedNTH
: Reopened
: 676803 (view as bug list)
Depends On:
Blocks: F15Alpha-accepted/F15AlphaFreezeExcept F15Beta/F15BetaBlocker
  Show dependency treegraph
 
Reported: 2011-01-22 17:41 EST by John Reiser
Modified: 2011-02-25 13:33 EST (History)
7 users (show)

See Also:
Fixed In Version: anaconda-15.20-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-25 13:33:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda traceback and debug info (1.36 MB, text/plain)
2011-01-22 17:41 EST, John Reiser
no flags Details

  None (edit)
Description John Reiser 2011-01-22 17:41:20 EST
Created attachment 474765 [details]
anaconda traceback and debug info

Description of problem: Installer error and traceback upon [Next] from bootloader dialog page when askmethod, Local harddrive, USB VFAT produced by livecd-iso-to-disk.


Version-Release number of selected component (if applicable):
anaconda-15.16

How reproducible: every time


Steps to Reproduce:
1. Compose install DVD from today's rawhide using pungi.
2. Make LiveUSB installer using https://fedoraproject.org/wiki/How_to_create_and_use_Live_USB#How_to_Make_a_bootable_USB_Drive_to_Install_Fedora_instead_of_using_a_physical_DVD.  Patch livecd-iso-to-disk for bug #671900 (initrd.img supersedes install.img)
3. Boot DVD for Install with additional kernel parameter " askmethod".  (Booting LiveUSB fails due to only a partial fix for bug #671900.)
4. Choose Local harddrive method, select the LiveUSB partition, leave Directory field empty.
5. Basic disks, Custom partitioning, select existing partition for /, reformat as ext4.
  
Actual results: "ValueError: isys.umount() can only umount by mount point"
upon [Next] from bootloader dialog page.


Expected results: no error.


Additional info:
Comment 1 John Reiser 2011-01-22 17:49:27 EST
In the LiveUSB partition:
$ ls -lR
total 2569020
-rwxr-xr-x. 1 jreiser jreiser 2630615040 2011-01-22 10:05 Fedora-15-x86_64-DVD.iso
drwx------. 3 jreiser jreiser       4096 2011-01-22 13:10 images
drwx------. 2 jreiser jreiser       4096 2010-10-13 19:37 LiveOS
-rwxr-xr-x. 1 jreiser jreiser      44198 2011-01-22 10:32 rpm-qa.out
drwx------. 2 jreiser jreiser       4096 2011-01-22 13:10 syslinux

./images:
total 146768
-rwxr-xr-x. 1 jreiser jreiser    843776 2011-01-22 10:08 efiboot.img
-rwxr-xr-x. 1 jreiser jreiser 149436416 2011-01-22 10:08 efidisk.img
-rwxr-xr-x. 1 jreiser jreiser         0 2011-01-22 13:10 install.img
drwx------. 2 jreiser jreiser      4096 2011-01-22 10:09 pxeboot
-rwxr-xr-x. 1 jreiser jreiser       665 2011-01-22 10:08 trans.tbl

./images/pxeboot:
total 145080
-rwxr-xr-x. 1 jreiser jreiser 144738515 2011-01-22 10:09 initrd.img
-rwxr-xr-x. 1 jreiser jreiser       441 2011-01-22 10:09 trans.tbl
-rwxr-xr-x. 1 jreiser jreiser   3815664 2011-01-22 10:09 vmlinuz

./LiveOS:
total 0

./syslinux:
total 146376
-rwxr-xr-x. 1 jreiser jreiser      2048 2011-01-22 13:10 boot.cat
-rwxr-xr-x. 1 jreiser jreiser        84 2011-01-22 13:10 boot.msg
-rwxr-xr-x. 1 jreiser jreiser       132 2011-01-22 13:10 grub.conf
-rwxr-xr-x. 1 jreiser jreiser 144738515 2011-01-22 13:10 initrd.img
-rwxr-xr-x. 1 jreiser jreiser     24576 2011-01-22 13:10 isolinux.bin
-r-xr-xr-x. 1 jreiser jreiser     32768 2011-01-22 13:10 ldlinux.sys
-rwxr-xr-x. 1 jreiser jreiser    160984 2011-01-22 13:10 memtest
-rwxr-xr-x. 1 jreiser jreiser    462737 2011-01-22 13:10 splash.jpg
-rwxr-xr-x. 1 jreiser jreiser       948 2011-01-22 13:10 syslinux.cfg
-rwxr-xr-x. 1 jreiser jreiser    462737 2010-10-13 19:37 syslinux-vesa-splash.jpg
-rwxr-xr-x. 1 jreiser jreiser      2215 2011-01-22 13:10 trans.tbl
-rwxr-xr-x. 1 jreiser jreiser    162860 2011-01-22 13:10 vesamenu.c32
-rwxr-xr-x. 1 jreiser jreiser   3815664 2011-01-22 13:10 vmlinuz
$
Comment 2 David Lehman 2011-01-24 11:50:54 EST
anaconda 15.16 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/isys/__init__.py", line 142, in umount
    raise ValueError, "isys.umount() can only umount by mount point"
  File "/usr/lib64/python2.7/site-packages/pyanaconda/image.py", line 201, in umountImage
    isys.umount(tree, removeDir=False)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/yuminstall.py", line 426, in _mountInstallImage
    umountImage(self.tree)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/yuminstall.py", line 455, in configBaseURL
    self._mountInstallImage()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/yuminstall.py", line 356, in setup
    self.configBaseURL()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/yuminstall.py", line 1231, in doBackendSetup
    self.ayum.setup()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/backend.py", line 199, in doBackendSetup
    if anaconda.backend.doBackendSetup(anaconda) == DISPATCH_BACK:
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 211, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 130, in gotoNext
    self.moveStep()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1265, in nextClicked
    self.anaconda.dispatch.gotoNext()
ValueError: isys.umount() can only umount by mount point

Local variables in innermost frame:
what: /mnt/source
removeDir: False
Comment 3 James Laska 2011-02-08 15:24:50 EST
Adding for review during F15Alpha meeting.  I don't believe any "custom" partitioning scenarios can be considered for the Alpha criteria [1].  But I'd appreciate any additional input on the scope of this failure.

[1] https://fedoraproject.org/wiki/Fedora_15_Alpha_Release_Criteria
Comment 4 He Rui 2011-02-11 05:54:50 EST
*** Bug 676803 has been marked as a duplicate of this bug. ***
Comment 5 He Rui 2011-02-11 06:02:56 EST
It's also triggered when testing F15-alpha-tc1 using repo=nfsiso:<server>:<path>.
Comment 6 Chris Lumens 2011-02-11 09:40:41 EST
Yeah, that should be fixed in the latest build (listed in the Fixed In Version) field too.  I believe the TC1 one uses an earlier build, though.
Comment 7 James Laska 2011-02-11 10:02:59 EST
Until TC#2 is available, an updates.img for use with TC#1 may help (see http://jlaska.fedorapeople.org/updates/f15-alpha-tc1.img)
Comment 8 Robyn Bergeron 2011-02-11 14:16:15 EST
AGREED: 671922 - Likely impacts Beta release criteria. Already fixed in anaconda-15.20, available in TC#2 for testing.
Comment 9 James Laska 2011-02-17 16:04:41 EST
I'm no longer seeing this particular issue in TC2.  However, a new issue has surfaced and will be tracked as bug#678414
Comment 10 Adam Williamson 2011-02-25 13:33:06 EST
fix confirmed in a stable anaconda release.

Note You need to log in before you can comment on or make changes to this bug.