Bug 672010 - duplicate paths in device tree
Summary: duplicate paths in device tree
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 14
Hardware: i686
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: David Lehman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 733942 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-01-23 08:12 UTC by A.J. Werkman
Modified: 2011-08-31 02:31 UTC (History)
4 users (show)

Fixed In Version: anaconda-16.16-1.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-31 02:31:42 UTC
Type: ---


Attachments (Terms of Use)
The bug report (387.23 KB, text/plain)
2011-01-23 08:12 UTC, A.J. Werkman
no flags Details

Description A.J. Werkman 2011-01-23 08:12:14 UTC
Created attachment 474790 [details]
The bug report

Description of problem:
Exception on manual disk partitioning

Version-Release number of selected component (if applicable):
Anaconda 14.22

How reproducible:
Everytime

Steps to Reproduce:
1. Start installation on a harddisk, that has already three NTFS disk partitions and sufficient free space to install fedora
3. In the custom disk partitioning screen create a boot partition, root partition and swap partition, but don't select "force to be a primary partition"
4. select the boot partition again and select "edit".
5. On the partition editing screen now select "force to be a primary partition"
6. See the exception occur.
  
Actual results:
Exception makes the installation abort

Expected results:
Anaconda should show a screen saying that creating a primary partition is not possible and continue installation process.

Additional info:

Comment 1 Ales Kozumplik 2011-01-24 14:57:58 UTC
dupe of bug 627153?

Comment 2 A.J. Werkman 2011-01-24 15:17:51 UTC
No it is not about modfying NTFS partitions.

The NTFS partitions in this case are there to fill up the partition table so that there is no space anymore to create a primary partition after I had created all the linux partitions to be extended partitions.

Comment 3 David Lehman 2011-01-24 16:51:45 UTC
anaconda 14.22 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 2149, in devices
    raise DeviceTreeError("duplicate paths in device tree")
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/__init__.py", line 449, in partitioned
    for device in self.devicetree.devices:
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/partitioning.py", line 823, in doPartitioning
    disks = storage.partitioned
  File "/usr/lib/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line 1582, in refresh
    doPartitioning(self.storage)
  File "/usr/lib/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line 1697, in editPartition
    if self.refresh():
  File "/usr/lib/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line 1639, in editCB
    self.editPartition(device)
DeviceTreeError: duplicate paths in device tree

Comment 4 David Lehman 2011-08-17 01:12:21 UTC
Finally, a good reproducer for this bug.

What's happening, more or less, is we're raising an exception during partition allocation and failing to return things to a usable state before returning to the main partitioning screen. This case involves an extended partition. I'm curious to see whether that is a common thread of the various reproducers.

Comment 5 A.J. Werkman 2011-08-28 19:22:43 UTC
As you have already three primary partitions on the disc the disc partitioning tool of fedora creates the boot-, root- and swap partitions on an extended partition. This extended partition is on the fourth location of the BIOS partitoning table.

As in the next step by changing the boot partition request to "Force to be primary" you create a "problem", because there is no room for a primary partion anymore. This should be explained to the user in an eror screen. And the "Force to be primary" request should be ignored.

Today I reproduced this test on F16-Alpha.RC5 and saw that the bug is still there!

I was not able to report the exception directly from anaconda to the bugzilla, as I was doing the test in an IPv6 setting and bugzilla.redaht.com still does not resolve to an IPv6 address.

I will shortly try this again in IPv4 namespace to upload the report to bugzilla.

Should I change Version of this bug to Fedora 16?

Comment 6 A.J. Werkman 2011-08-28 19:34:54 UTC
Report is saved under #733942

Comment 7 David Lehman 2011-08-29 16:22:37 UTC
*** Bug 733942 has been marked as a duplicate of this bug. ***

Comment 8 David Lehman 2011-08-29 16:24:10 UTC
Note the fixed in version. The fix will be in the first beta trees.

Comment 9 Fedora Update System 2011-08-30 19:52:03 UTC
anaconda-16.16-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/anaconda-16.16-1.fc16

Comment 10 Fedora Update System 2011-08-31 02:31:09 UTC
anaconda-16.16-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.