Bug 672135 - users with no "real name" in /etc/passwd show up as blank
users with no "real name" in /etc/passwd show up as blank
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
AcceptedNTH
: Regression
: 673921 (view as bug list)
Depends On:
Blocks: F15Beta-accepted/F15BetaFreezeExcept F15-accepted/F15FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2011-01-23 23:55 EST by Paolo Bonzini
Modified: 2015-01-14 18:26 EST (History)
10 users (show)

See Also:
Fixed In Version: gdm-2.91.94-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-02 16:11:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 644156 None None None Never

  None (edit)
Description Paolo Bonzini 2011-01-23 23:55:19 EST
Description of problem:
If a user didn't fill in his real name in /etc/passwd, their entry in gdm shows up as blank.  gdm should default to the login name.

Version-Release number of selected component (if applicable):
2.91.4-5

How reproducible:
100%

Steps to Reproduce:
1. Create a new user with useradd
2. Start graphical login.
3.
  
Actual results:
The new user's entry is blank.

Expected results:
The new user's entry shows the login name as it did in F14 and earlier.
Comment 1 James Laska 2011-03-01 10:34:54 EST
I'm seeing the same thing, but I suspect it might be related to using SSSD (krb and ldap) for using auth and identification.

gdm-2.91.91-1.fc15.x86_64
sssd-1.5.1-8.fc15.x86_64
Comment 2 Michal Schmidt 2011-03-01 11:08:05 EST
No. This is perfectly reproducible without SSSD. Simply have an empty GECOS field in /etc/passwd.
Comment 3 James Laska 2011-03-03 10:34:14 EST
*** Bug 673921 has been marked as a duplicate of this bug. ***
Comment 4 James Laska 2011-03-03 10:36:42 EST
Proposing this as a final release blocker (and Beta NTH).  We don't have any release criteria that cover this use case, but this seems like a somewhat public/high_profile area which we would want to address.
Comment 5 Jared Smith 2011-03-07 15:51:59 EST
I agree with making this a release blocker and Beta nice-to-have.
Comment 6 Adam Williamson 2011-03-11 14:14:00 EST
Discussed at 2011-03-11 blocker review meeting. We decided we can't really make a convincing case for this being a final blocker; if someone wants to re-propose it and make such a case, please do. For now, accepted as NTH for Beta and Final.
Comment 7 Ken Dreyer 2011-03-12 09:58:14 EST
appears to be fixed upstream
Comment 8 Michal Schmidt 2011-04-02 16:11:29 EDT
The upstream fix reached Fedora. gdm shows login names as expected.

Note You need to log in before you can comment on or make changes to this bug.