This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 67275 - USB modem not found
USB modem not found
Status: CLOSED DUPLICATE of bug 100503
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
: 98777 99112 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-21 15:31 EDT by John Reiser
Modified: 2014-03-16 22:28 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-23 16:13:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2002-06-21 15:31:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.19-6.2.16-KRUD-perfctr2.3.6
i586)

Description of problem:
/usr/bin/neat does not find USB modem.  (Modem works in minicom.)

Version-Release number of selected component (if applicable):
redhat-config-netowrk-1.0.0-1

How reproducible:
Always

Steps to Reproduce:
1. Run the configuration wizard.
2. Delete all existing modem devices, if any.
3. Shutdown.
4. Plug in USB modem (previously known to kudzu as
   /dev/input/ttyACM0 c 166 0).
5. Boot, allow kudzu to run.
6. Verify modem appears in /proc/bus/usb/devices.
7. /usr/bin/neat; Add Modem; ==> "No modem found".
	

Actual Results:  "No modem found".

Expected Results:  USB modem configured.
(And why does kudzu use /dev/input/ttyACM0, but everyone else
seems to prefer /dev/ttyACM0.  And why should it matter,
as long as /dev/modem is linked to the right place?

And if user is allowed to activate/deactivate the device,
the the configurator should change the permissions to rw-rw-rw
(read and write for every user).

Additional info:
Comment 1 Trond Eivind Glomsrxd 2002-06-21 16:07:30 EDT
redhat-config-network uses kudzu to detect modems.
Comment 2 John Reiser 2002-06-22 01:12:37 EDT
Additional info: kudzu did detect the modem and configure it at boot.
But Network Configuration didn't see it.
Modem is Zoom Telephonics 2986 (USB vendor:model 0803:9700)
Comment 3 John Reiser 2002-10-05 19:25:12 EDT
Essentially the same problem is still there in RHL 8.0 (Psyche).

Anaconda sees the USB modem during initial device detection (fresh Workstation
install from HardDisk, text mode), although I cannot find a transcript of that
to show here [shouldn't it be saved somewhere?].  There is no mention of the
modem in /root/anaconda-ks.cfg .

The modem appears three times in /etc/sysconfig/hwconf, with different
usbclass/usbsubclass/usbprotocol in each appearance.  There really is only one
modem.
-
class: OTHER 
bus: USB 
detached: 0
driver: unknown
desc: "Zoom Telephonics, Inc. 2986L FaxModem"
usbclass: 0
usbsubclass: 2
usbprotocol: 1
usbbus: 4 
usblevel: 1
usbport: 0
vendorId: 0803
deviceId: 9700
-
class: OTHER
bus: USB
detached: 0
driver: unknown
desc: "Zoom Telephonics, Inc. 2986L FaxModem"
usbclass: 0
usbsubclass: 0
usbprotocol: 0
usbbus: 4
usblevel: 1
usbport: 0
vendorId: 0803
deviceId: 9700
-
class: MODEM
bus: USB
detached: 0
driver: unknown
desc: "Zoom Telephonics, Inc. 2986L FaxModem"
usbclass: 2
usbsubclass: 2
usbprotocol: 1
usbbus: 4
usblevel: 1
usbport: 0
vendorId: 0803
deviceId: 9700
-

The modem shows in /proc/bus/usb/devices:
-----
T:  Bus=04 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  2 Spd=12  MxCh= 0
D:  Ver= 1.00 Cls=02(comm.) Sub=00 Prot=00 MxPS= 8 #Cfgs=  2
P:  Vendor=0803 ProdID=9700 Rev= 1.00
S:  Manufacturer=Zoom Telephonics, Inc.
S:  Product=Zoom V90 USB Faxmodem 
C:  #Ifs= 2 Cfg#= 1 Atr=a0 MxPwr=400mA
I:  If#= 0 Alt= 0 #EPs= 0 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
I:  If#= 1 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
E:  Ad=02(O) Atr=02(Bulk) MxPS=  16 Ivl=0ms
E:  Ad=84(I) Atr=03(Int.) MxPS=  63 Ivl=2ms
C:* #Ifs= 2 Cfg#= 2 Atr=a0 MxPwr=400mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=02(comm.) Sub=02 Prot=01 Driver=acm
E:  Ad=84(I) Atr=03(Int.) MxPS=  32 Ivl=128ms
I:  If#= 1 Alt= 0 #EPs= 2 Cls=0a(data ) Sub=02 Prot=01 Driver=acm
E:  Ad=02(O) Atr=02(Bulk) MxPS=  64 Ivl=0ms
E:  Ad=86(I) Atr=02(Bulk) MxPS=  64 Ivl=0ms
-----

From a logged-in X11 console, selecting RedHat > System Settings > Network
brings up Network Configuration.  On the Devices tab, click Add... which brings
up Select Device Type.  Choose Modem connection, click Forward, which results in
 "probing..." then an Warning dialog box "! No modem was found on your system".
Comment 4 Harald Hoyer 2003-07-30 05:41:19 EDT
*** Bug 98777 has been marked as a duplicate of this bug. ***
Comment 5 Harald Hoyer 2003-07-30 05:42:31 EDT
*** Bug 99112 has been marked as a duplicate of this bug. ***
Comment 6 Bill Nottingham 2005-09-23 16:13:12 EDT

*** This bug has been marked as a duplicate of 100503 ***

Note You need to log in before you can comment on or make changes to this bug.