Bug 673556 - Extra fork when tcsh processes backquotes
Summary: Extra fork when tcsh processes backquotes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: tcsh
Version: 6.0
Hardware: All
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Vojtech Vitek
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On: 594536 640251 689383
Blocks: 688170
TreeView+ depends on / blocked
 
Reported: 2011-01-28 17:45 UTC by Branislav Náter
Modified: 2015-03-04 23:57 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, when command substitution with backquotes was used, extra fork() was performed. With this update, only one fork() is performed.
Clone Of: 640251
: 688170 (view as bug list)
Environment:
Last Closed: 2011-02-02 15:31:20 UTC


Attachments (Terms of Use)
Upstream patch against tcsh-6.17.00 (861 bytes, patch)
2011-01-31 10:19 UTC, Vojtech Vitek
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0193 normal SHIPPED_LIVE tcsh bug fix update 2011-02-02 15:31:12 UTC

Comment 2 RHEL Product and Program Management 2011-01-28 18:08:22 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 5 Vojtech Vitek 2011-01-31 10:19:24 UTC
Created attachment 476160 [details]
Upstream patch against tcsh-6.17.00

Comment 7 Jaromir Hradilek 2011-01-31 16:27:43 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, when command substitution with backquotes was used, extra fork() was performed. With this update, only one fork() is performed.

Comment 8 Branislav Náter 2011-02-01 12:24:02 UTC
Bugfix successfully verified on package tcsh-6.17-12.el6.{i386,x86_64,s390x,ppc64} using /CoreOS/tcsh/Regression/bz640251-Extra-fork-when-tcsh-processes-backquotes TC.

Comment 9 errata-xmlrpc 2011-02-02 15:31:20 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0193.html


Note You need to log in before you can comment on or make changes to this bug.