Bug 688170 - Extra fork when tcsh processes backquotes
Summary: Extra fork when tcsh processes backquotes
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: tcsh617
Version: 5.0
Hardware: All
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Vojtech Vitek
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Keywords:
: 689383 (view as bug list)
Depends On: 594536 640251 673556 689383
Blocks: 688166
TreeView+ depends on / blocked
 
Reported: 2011-03-16 14:21 UTC by Vojtech Vitek
Modified: 2015-03-04 23:57 UTC (History)
13 users (show)

(edit)
Previously, when a command was substituted using backquotes, a second, redundant fork() system call was performed. This could have caused problems when a child process needed to find the PID of its tcsh parent. With this new package, only one fork() is performed.
Clone Of: 673556
(edit)
Last Closed: 2011-07-21 08:47:54 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1072 normal SHIPPED_LIVE new package: tcsh617 2011-07-21 08:47:46 UTC

Comment 2 Vojtech Vitek 2011-03-17 14:25:52 UTC
Package review of the new tcsh617 package including a patch for this bz was successful. See bug 676136.

Comment 6 Ondrej Vasik 2011-03-25 12:32:15 UTC
*** Bug 689383 has been marked as a duplicate of this bug. ***

Comment 8 Miroslav Svoboda 2011-07-01 22:00:06 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, when a command was substituted using backquotes, a second, redundant fork() system call was performed. This could have caused problems when a child process needed to find the PID of its tcsh parent. With this new package, only one fork() is performed.

Comment 9 errata-xmlrpc 2011-07-21 08:47:54 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1072.html

Comment 10 errata-xmlrpc 2011-07-21 12:09:54 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1072.html


Note You need to log in before you can comment on or make changes to this bug.