Bug 67578 - HP DJ890 printer prints garbage under 7.3, 7.2 version OK
HP DJ890 printer prints garbage under 7.3, 7.2 version OK
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: ghostscript (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Aaron Brown
:
: 67779 74078 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-27 14:09 EDT by twallace
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-08 08:29:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gs705.prn (407.43 KB, application/octet-stream)
2002-07-03 09:46 EDT, Tim Waugh
no flags Details
gs705hpijs.prn (1.57 MB, application/octet-stream)
2002-07-04 04:55 EDT, Tim Waugh
no flags Details

  None (edit)
Description twallace 2002-06-27 14:09:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020529

Description of problem:
Cannot print to DJ 890 printer (cdj890 driver) with ghostscript.
Rolled back to version from Redhat 7.2 (with --force, --nodeps) and
everything seems fine.  Printer gets into error state, form feeds a couple of
pages, and prints some gibberish, typically, under 7.3.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install local printer as Deskjet 890C with printtool
2.try to print anything
3.
	

Actual Results:  gibberish, blank pages, error state for printer

Expected Results:  print my postscript file

Additional info:

Older version of ghostscript works fine
Comment 1 Tim Waugh 2002-07-03 08:54:57 EDT
It was just ghostscript that you downgraded?  Did you also downgrade hpijs?
Comment 2 Tim Waugh 2002-07-03 08:56:02 EDT
Also, had you applied the updates prior to downgrading?
Comment 3 twallace 2002-07-03 09:07:47 EDT
I installed with disks I made 6 June with 24 updated RPMS, including
ghostscript-6.52-9.4.i386. I downgraded only the ghostscript rpm to make it work
Comment 4 Tim Waugh 2002-07-03 09:44:25 EDT
Please save the following attachment and try: 
 
  cat attachment > /dev/lp0 
 
as root (assuming it's on /dev/lp0!).  This is the output from GNU Ghostscript 
7.05, using the US Letter test page.  Let me know if the problem is still 
there.
Comment 5 Tim Waugh 2002-07-03 09:46:22 EDT
Created attachment 63504 [details]
gs705.prn
Comment 6 twallace 2002-07-03 18:17:43 EDT
Unfortunately I get the same type of output as before: a line of HP graphics
characters, a few down the edge of the page, a couple of blank pages, and the
printer lights flashing (indicating error state)
Comment 7 Tim Waugh 2002-07-04 04:52:59 EDT
Okay, I'll take a look at what changed for that driver between 7.2 and 7.3 
then. 
 
In the mean time, please save the following attachment and try:  
  
  cat attachment > /dev/lp0  
  
as root.  This is the output from the hpijs driver (with GNU Ghostscript 
7.05), using the US Letter test page.  Let me know if that works (it should).  
Thanks.
Comment 8 Tim Waugh 2002-07-04 04:55:24 EDT
Created attachment 63664 [details]
gs705hpijs.prn
Comment 9 twallace 2002-07-06 10:12:54 EDT
Yes, hpijs attachment worked fine
Comment 10 Tim Waugh 2002-07-08 13:03:24 EDT
FWIW, hpijs is the recommended driver for this printer.
Comment 11 Tim Waugh 2002-07-08 13:28:16 EDT
This seems to be because of the way that the chp2200 driver is added; it clobbers cdj890 and 
others.  Since the recommended driver for the HP Business Inkjet 2200 is hpijs anyway, I'll 
take out chp2200 again.  That should fix cdj890.
Comment 12 Tim Waugh 2002-07-09 04:10:05 EDT
Should be fixed in ghostscript-7.05-15.
Comment 13 Tim Waugh 2002-07-17 05:42:26 EDT
*** Bug 67779 has been marked as a duplicate of this bug. ***
Comment 14 Tim Waugh 2002-09-16 05:51:02 EDT
*** Bug 74078 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.