Bug 677310 - Cannot move/resize dialog windows
Cannot move/resize dialog windows
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: mutter (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F15GNOMEfail
  Show dependency treegraph
 
Reported: 2011-02-14 05:32 EST by Zdenek Kabelac
Modified: 2011-02-22 10:32 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-22 08:07:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zdenek Kabelac 2011-02-14 05:32:41 EST
Description of problem:

Mutter as a recent window manager in Fedora Rawhide is hardly usable, as there seems to be lack of any configuration - i.e.  I cannot move/resize dialog window in Mozilla, Thunderbird... - I'm finding this highly annoying and this needs to be fixed.

I assume all modal dialogs are now unmovable? - this is completely broken idea, especially if there is no config button to switch this off.

I assume it also affect the problem that configuration windows are not resizable.

Version-Release number of selected component (if applicable):
mutter-2.91.6-2.fc15.x86_64

How reproducible:


Steps to Reproduce:
1. Save anything in i.e. Mozilla
2.
3.
  
Actual results:


Expected results:
Opened windows are fully resizable and movable 

Additional info:
Comment 1 Owen Taylor 2011-02-22 08:07:43 EST
We're not planning to change these design decisions for GNOME 3.0: if applications design dialogs in arbitrary ways and use them for arbitrary purposes, then we don't have a lot of ability to treat them specially to make them more usable for the user - for example, grouping modal dialogs closely with the parent window. So applications may need some adaptation to work best with the GNOME desktop.

Firefox about dialog issue is bug 677427
Comment 2 Zdenek Kabelac 2011-02-22 10:32:35 EST
I've expected this decission after I've seen some Gnome presentation -

Though I'll never understand this decision of Gnome developers to force user to get IMHO extremely poor user experience with this desktop - but how can I change this behaviour with  modification of  gnome-shell java script? -  It looks like many things could be change there - but particularly this piece looks like even more deeply buried in the mutter's internal C code.

From my understanding - there will not be any user settings (and not just for this - but for nearly anything) - but why it's even prohibited to modify this IMHO unclever  design decision in .js engine ?

Is there any chance to at least support modification on .js level of coding 
(so at least I could go back to 1995 - where edit of fvwm config text files was a nice way to spend my time)

Note You need to log in before you can comment on or make changes to this bug.