Bug 678689 - Disks sda, sdb contain BIOS RAID metadata, but are not part of any recognized BIOS RAID sets. Ignoring disks sda, sdb.
Disks sda, sdb contain BIOS RAID metadata, but are not part of any recognized...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 679620 681284 (view as bug list)
Depends On:
Blocks: F15Beta/F15BetaBlocker
  Show dependency treegraph
 
Reported: 2011-02-18 16:16 EST by Sandro Mathys
Modified: 2013-12-25 12:12 EST (History)
10 users (show)

See Also:
Fixed In Version: anaconda-15.26-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-05 17:39:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
program.log from after the warning shows up (3.11 KB, text/plain)
2011-02-18 16:17 EST, Sandro Mathys
no flags Details
storage.log from after the warning shows up (56.31 KB, text/plain)
2011-02-18 16:17 EST, Sandro Mathys
no flags Details
syslog from after the warning shows up (96.75 KB, text/plain)
2011-02-18 16:18 EST, Sandro Mathys
no flags Details
Patch to fix scanning of md fwraid (442 bytes, patch)
2011-03-02 12:31 EST, David Lehman
no flags Details | Diff

  None (edit)
Description Sandro Mathys 2011-02-18 16:16:23 EST
The above warning was shown while trying to install Fedora 15 TC2 from DVD. Either after choosing "basic storage" or after choosing "advanced storage" and after selecting it choosing "next".

The two disks are in a striping RAID controlled by an Intel RAID controller. There's a third disk in the system that is not part of the RAID.

I was able to always reproduce this so far. Installation is not possible like this.

I could not yet try with a LiveCD due to the well-known bug that doesn't let you start the installation from live media. Will revisit as soon as that's fixed, i.e. probably during the weekend.
Comment 1 Sandro Mathys 2011-02-18 16:17:33 EST
Created attachment 479611 [details]
program.log from after the warning shows up
Comment 2 Sandro Mathys 2011-02-18 16:17:59 EST
Created attachment 479612 [details]
storage.log from after the warning shows up
Comment 3 Sandro Mathys 2011-02-18 16:18:28 EST
Created attachment 479613 [details]
syslog from after the warning shows up
Comment 4 Sandro Mathys 2011-02-18 16:33:59 EST
Adding F15Blocker according to this test case:
http://fedoraproject.org/wiki/QA:Testcase_Install_to_BIOS_RAID

...which blocks the beta release according to:
https://fedoraproject.org/wiki/Test_Results:Fedora_15_Alpha_TC2_Install#General_Tests

From the description of that case:
"This install verifies that installing on a BIOS RAID device works properly."

From the expected results of that case:
"1. All installable BIOS RAID devices are successfully detected by installer and are available for partitioning."
Comment 5 Sandro Mathys 2011-02-18 16:49:16 EST
I've got to clarify/correct what I said above a little.

The warning itself won't stop the installation - but (unless I choose my third disk as a target) I won't be able to perform the installation as I have "not enough space" in the partitioning step.
Comment 6 Chris Lumens 2011-02-22 20:55:28 EST
*** Bug 679620 has been marked as a duplicate of this bug. ***
Comment 7 Steven Haigh 2011-02-22 21:12:24 EST
For the record, this still exists on Alpha RC1.

While you could (in theory) install to a drive not included in the IMSM raid, as the raid isn't assembled, and there is no mdadm on the DVD, it is not possible to install to an IMSM raid at this time.
Comment 8 Antal L 2011-02-26 08:39:49 EST
I can confirm this bug also exists on FC14, AMD64 using the live installer. Strange because I don't use HW-raid (and never did in the past), only SW-raid. 
So far I'm unable to install FC14.
Comment 9 Steven Haigh 2011-02-26 08:59:10 EST
I believe that this only affects the live CD on F14. Installation still works correctly from either the DVD or install CD / netinstall. As F14 isn't the latest anymore, I doubt this will get fixed for F14.
Comment 10 Antal L 2011-02-26 09:31:40 EST
At least 14 is the latest stable release...

I already tried the dvd, but also without any luck. Will try the netinstall later, but I don't expect it to work.

On my system I am using SW raid, but it complains about 'bios raid metadata'. When opening a terminal on the live cd I am able to mount and access my sw raid partitions perfectly. Only anaconda complains.
Comment 11 Chris Lumens 2011-03-01 11:41:50 EST
*** Bug 681284 has been marked as a duplicate of this bug. ***
Comment 12 Clyde E. Kunkel 2011-03-02 10:18:57 EST
Fedora 14 installer worked for me on an Intel Bios Raid 10 set.  Used final x86_64 DVD.

For Fedora 15, I see the problem this bz reports, but am able to do the install by using the mdadm.conf generated in F14, putting it in /etc in tty-2 and assembling the array (don't forget that PATH doesn't have /sbin in it yet).

Yes, this is a blocker for F15 Beta.
Comment 13 David Lehman 2011-03-02 12:31:58 EST
Created attachment 481916 [details]
Patch to fix scanning of md fwraid
Comment 14 Sandro Mathys 2011-03-02 13:02:30 EST
I can confirm that patch (which is also part of the patch for bug 680226) to fix this issue. I then hit bug 681608, though.
Comment 15 David Lehman 2011-03-03 11:22:02 EST
Patches that (attempt to) fix all known intel firmware RAID issues for F15 are available in bug 681608 for those doing live installs. For those doing non-live installs, just ask and I'll be happy to provide an updates image for you to test with.
Comment 16 Clyde E. Kunkel 2011-03-03 12:59:00 EST
(In reply to comment #15)
> Patches that (attempt to) fix all known intel firmware RAID issues for F15 are
> available in bug 681608 for those doing live installs. For those doing non-live
> installs, just ask and I'll be happy to provide an updates image for you to
> test with.

Please, sir, may I have one?
Comment 17 David Lehman 2011-03-03 14:07:13 EST
(In reply to comment #16)
> (In reply to comment #15)
> > Patches that (attempt to) fix all known intel firmware RAID issues for F15 are
> > available in bug 681608 for those doing live installs. For those doing non-live
> > installs, just ask and I'll be happy to provide an updates image for you to
> > test with.
> 
> Please, sir, may I have one?

It won't help you much at this point unless you're using the simple/basic storage path, but you can find updates against anaconda-15.20.1-1 here:

  http://dlehman.fedorapeople.org/updates-fwraid-f15.3.img



Due to limitations with the new tools used to handle the intel fwraid (mdadm), we have to use a combination of dmraid and mdadm to handle those arrays. This ends up adding a requirement that both tools agree on the name of the devices, which apparently cannot be relied upon. Working on that now...
Comment 18 Steven Haigh 2011-03-03 16:58:33 EST
I'll standby until a DVD image is released with these updates. That way I can test the entire solution. Are these scheduled for F15 Beta TC1 at this stage?
Comment 19 David Lehman 2011-03-09 14:07:45 EST
Fixed for Fedora 15 in anaconda-15.22-1.
Comment 20 hengchangdai 2011-03-09 17:44:51 EST
I got this problem wheh I install Fedora 15 on Sony Vaio VPC z12 which have two SSD disks. But Fedora 14 is OK.
Comment 21 James Laska 2011-03-11 14:40:27 EST
Discussed at 2011-03-11 blocker review meeting.  This issue is fixed and available for testing in anaconda-15.22-1.  The issue has been accepted as a beta blocker.
Comment 22 Steven Haigh 2011-03-11 21:13:16 EST
I tested the boot.iso made by James Laska by creating a USB key install.

The install proceeded as it should, however anaconda installed grub to /dev/sdc - which was the USB key. As such, I cannot boot to either Windows or F15 without booting off the USB key first.

# cat /etc/grub.conf 
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You do not have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /, eg.
#          root (hd1,3)
#          kernel /boot/vmlinuz-version ro root=/dev/md127p4
#          initrd /boot/initrd-[generic-]version.img
#boot=/dev/sdc
default=0
timeout=5
splashimage=(hd1,3)/boot/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.38-0.rc8.git0.1.fc15.x86_64)
	root (hd1,3)
	kernel /boot/vmlinuz-2.6.38-0.rc8.git0.1.fc15.x86_64 ro root=UUID=db570be9-689a-434b-a505-74d96538166a rd_MD_UUID=0d242700:88229f97:87e814e7:870bc4de rd_MD_UUID=3981b2e3:f2e47cb0:1285fa11:ef98308b rd_NO_LUKS rd_NO_LVM rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us rhgb quiet
	initrd /boot/initramfs-2.6.38-0.rc8.git0.1.fc15.x86_64.img
title Windows 7
	rootnoverify (hd1,0)
	chainloader +1

# cat /boot/grub/device.map
(hd1)	/dev/md127
(hd0)	/dev/sdc

As of this moment, I am unsure how to get grub to install on /dev/md127. The following doesn't seem to work as I would expect it to:

# grub-install /dev/md127
expr: non-integer argument
Installation finished. No error reported.
This is the contents of the device map /boot/grub/device.map.
Check if this is correct or not. If any of the lines is incorrect,
fix it and re-run the script `grub-install'.

(hd1)	/dev/md127
(hd0)	/dev/sdc
Comment 23 David Lehman 2011-03-11 21:59:37 EST
Pay attention to the "Boot Loader" column in the "Install Target Devices" pane on the right side of the screen that follows the one that asks you which type of partitioning you want. That's how you tell anaconda which disk to install the bootloader to.
Comment 24 Fedora Update System 2011-03-29 16:52:12 EDT
anaconda-15.26-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/anaconda-15.26-1.fc15
Comment 25 Fedora Update System 2011-03-29 22:25:43 EDT
Package anaconda-15.26-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-15.26-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/anaconda-15.26-1.fc15
then log in and leave karma (feedback).
Comment 26 Fedora Update System 2011-04-05 17:37:38 EDT
anaconda-15.26-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 27 Bradley 2011-06-06 15:52:56 EDT
Anaconda-15.26-1.fc15 did not fix the issue.

Fixing the issue involved going in to disk utility through a live CD and creating a new partition map (IE reformatting your drive to MBR or GPT / GUID).

This fixed my issue coming from a Windows based BIOS RAID on an AMD chipset.
Comment 28 Jan Kundrát 2013-12-25 12:12:58 EST
Adding a "nodmraid" option to the installer's kernel command line is another workaround. Tested on Scientific Linux 6.5 and Supermicro's H8DGT-HF motherboard (AMD SP5100 chipset).

Note You need to log in before you can comment on or make changes to this bug.