Bug 679825 - Static network configuration in kickstart doesn't work.
Static network configuration in kickstart doesn't work.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
AcceptedNTH
:
Depends On:
Blocks: F15Beta-accepted/F15BetaFreezeExcept 677609
  Show dependency treegraph
 
Reported: 2011-02-23 10:45 EST by Radek Vykydal
Modified: 2011-04-05 17:39 EDT (History)
4 users (show)

See Also:
Fixed In Version: anaconda-15.26-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-05 17:39:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch with fix (5.55 KB, text/plain)
2011-02-23 10:45 EST, Radek Vykydal
no flags Details

  None (edit)
Description Radek Vykydal 2011-02-23 10:45:53 EST
Created attachment 480499 [details]
patch with fix

This is on f15 Alpha TC2

Reproducer:
Install with kickstart from cd or hdd (so that network doesn't go up to fetch it). Instead of static config from kickstart, default dhcp is used.

Attaching patch with fix.
Comment 1 Radek Vykydal 2011-02-23 10:49:13 EST
Proposing as f15 blocker.
Comment 2 Radek Vykydal 2011-03-03 06:04:04 EST
Adding to F15Beta per the beta release criteria [1]:

"8. The installer must be able to use all kickstart delivery methods"

[1] https://fedoraproject.org/wiki/Fedora_15_Beta_Release_Criteria
Comment 3 Radek Vykydal 2011-03-04 12:53:22 EST
Fixed in master, anaconda-16.1-1.
Comment 4 Radek Vykydal 2011-03-04 12:54:27 EST
(In reply to comment #3)
> Fixed in master, anaconda-16.1-1.
16.2-1 it is.
Comment 5 Radek Vykydal 2011-03-11 01:59:35 EST
Should be fixed in anaconda-15.23-1.
Comment 6 James Laska 2011-03-11 14:47:33 EST
(In reply to comment #2)
> Adding to F15Beta per the beta release criteria [1]:
> 
> "8. The installer must be able to use all kickstart delivery methods"
> 
> [1] https://fedoraproject.org/wiki/Fedora_15_Beta_Release_Criteria

That specific criteria was intended to capture ks= delivery methods.  I don't think we have specific criteria that cover specific kickstart commands or options (outside of any intersection those commands/options have with existing criteria).  I still have it on my plate to draft some kickstart-related release criteria.  

This bug definitely qualifies as a Nice to have, and since we aren't in a freeze, you are more than welcome to commit a fix for this.
Comment 7 Fedora Update System 2011-03-29 16:59:38 EDT
anaconda-15.26-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/anaconda-15.26-1.fc15
Comment 8 Fedora Update System 2011-03-29 22:26:34 EDT
Package anaconda-15.26-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-15.26-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/anaconda-15.26-1.fc15
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2011-04-05 17:38:25 EDT
anaconda-15.26-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.