This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 680474 - Anaconda doesn't recognize my LVM on RAID1 setup
Anaconda doesn't recognize my LVM on RAID1 setup
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F15Beta/F15BetaBlocker
  Show dependency treegraph
 
Reported: 2011-02-25 12:10 EST by info@kobaltwit.be
Modified: 2011-04-05 17:39 EDT (History)
4 users (show)

See Also:
Fixed In Version: anaconda-15.26-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-05 17:39:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/tmp/anaconda.log (5.57 KB, text/plain)
2011-02-25 12:56 EST, info@kobaltwit.be
no flags Details
/tmp/storage.log (135.08 KB, text/plain)
2011-02-25 12:57 EST, info@kobaltwit.be
no flags Details
/tmp/syslog (88.10 KB, text/plain)
2011-02-25 12:57 EST, info@kobaltwit.be
no flags Details

  None (edit)
Description info@kobaltwit.be 2011-02-25 12:10:22 EST
Description of problem:
One of my PC's has two harddrives configured in a RAID 1 configuration (softraid). On of the RAID devices (md1) hosts an LVM physical volume. When I try to install F15 (pre-alpha), it doesn't recognize this setup.
It does recognize the RAID1 devices, but it fails to detect the LVM setup that it hosts. This means I can't install F15 next to my existing F14 in an separate LVM partition. Let me know what additional information you would need for this issue.
Comment 1 Chris Lumens 2011-02-25 12:38:30 EST
/tmp/anaconda.log, /tmp/storage.log, and /tmp/syslog from when you hit the problem would be handy.  Thanks.
Comment 2 info@kobaltwit.be 2011-02-25 12:56:34 EST
Created attachment 481044 [details]
/tmp/anaconda.log

Ok, here they come...
Comment 3 info@kobaltwit.be 2011-02-25 12:57:04 EST
Created attachment 481045 [details]
/tmp/storage.log
Comment 4 info@kobaltwit.be 2011-02-25 12:57:32 EST
Created attachment 481047 [details]
/tmp/syslog
Comment 5 info@kobaltwit.be 2011-02-25 13:00:20 EST
For completeness: /dev/md1 is the RAID1 partition holding the LVM PV, /dev/md7 is a separate /boot partition.
Comment 6 David Lehman 2011-02-28 12:35:29 EST
This should be the same issue as bug 676519, which was fixed in anaconda-15.21-1 on rawhide. Setting this bug to block F15Beta instead of that one since this one is against F15.
Comment 7 Clyde E. Kunkel 2011-03-03 17:16:16 EST
  http://dlehman.fedorapeople.org/updates-fwraid-f15.3.img

Fixes this for me when used with 15.20.1

Thanks.

(PS, adding /sbin to PATH?  Doesn't affect install, only us bit twiddlers.)
Comment 8 David Lehman 2011-03-09 14:07:33 EST
Fixed for Fedora 15 in anaconda-15.22-1.
Comment 9 James Laska 2011-03-11 14:40:35 EST
Discussed at 2011-03-11 blocker review meeting.  This issue is fixed and available for testing in anaconda-15.22-1.  The issue has been accepted as a beta blocker.
Comment 10 info@kobaltwit.be 2011-03-17 13:37:20 EDT
I'd love to verify this, but I'm currently blocked by Bug 688682.
Comment 11 James Laska 2011-03-25 11:34:59 EDT
I'm not seeing this using anaconda-15.24-1 (installation images available from http://download.fedoraproject.org/pub/fedora/linux/development/15/).  The test blocker you mentioned is now resolved in the latest pygobject2 which should also be included.

I tested doing an install with LVM on top of RAID devices.  After the install completed, I started the installer again, and it recognized the existing RAID and LVM devices.  I'll move this to VERIFIED once we have confirmation from the reporter (info@kobaltwit.be).
Comment 12 info@kobaltwit.be 2011-03-25 13:10:29 EDT
I tried again today with a boot.iso from yesterday evening, but I still can't go into custom partitioning. Got a backtrace that already was in bugzilla under bug 684283, but that bug is marked as a duplicate of bug 682543. James reports (just today that bug 682543 should be fixed now. I'm not sure where I should get a more recent boot.iso with this fix to test again.
Comment 13 Clyde E. Kunkel 2011-03-25 13:34:12 EDT
(In reply to comment #12)
> I tried again today with a boot.iso from yesterday evening, but I still can't
> go into custom partitioning. Got a backtrace that already was in bugzilla under
> bug 684283, but that bug is marked as a duplicate of bug 682543. James reports
> (just today that bug 682543 should be fixed now. I'm not sure where I should
> get a more recent boot.iso with this fix to test again.

If its still there try:

http://jlaska.fedorapeople.org/boot.iso
Comment 14 info@kobaltwit.be 2011-03-26 07:42:14 EDT
I used http://jlaska.fedorapeople.org/boot.iso to test again and with this image my LVM RAID setup is detected properly. I can add an LVM partition just fine now, so as far as I'm concerned you can close this bug.

Thank your for fixing this.
Comment 15 Fedora Update System 2011-03-29 16:52:18 EDT
anaconda-15.26-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/anaconda-15.26-1.fc15
Comment 16 Fedora Update System 2011-03-29 22:25:49 EDT
Package anaconda-15.26-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-15.26-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/anaconda-15.26-1.fc15
then log in and leave karma (feedback).
Comment 17 Fedora Update System 2011-04-05 17:37:44 EDT
anaconda-15.26-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.