Bug 68100 - logout->reboot / shutdown only logs off
logout->reboot / shutdown only logs off
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: gnome-session (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
: 68394 68839 68992 (view as bug list)
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-06 07:21 EDT by Thomas M Steenholdt
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-23 14:12:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas M Steenholdt 2002-07-06 07:21:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020625

Description of problem:
when selecting logoff from the foot menu, you are prompted if you want to
logoff, reboot or shutdown...

No matter what is chose from this menu, the user is logged off and that's it.
The machine will not shutdown when shutdown is selected nor will it reboot when
reboot is selected.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.log into gnome
2.click foot->log out
3.select reboot or shutdown and click OK
	

Actual Results:  The user is logged off but the system stays up

Expected Results:  followinf the user logout, the system should cave either
rebooted or shut down.

Additional info:

Selecting shutdown from GDM works fine
Comment 1 Elliot Peele 2002-07-10 09:23:40 EDT
I'm seeing this problem on several machines as well.
Comment 2 Richard Lloyd 2002-07-14 11:43:28 EDT
I know this may be off-topic (but searching Bugzilla for "reboot" isn't my
idea of fun - 680 matches :-) ), but should a non-root user be even allowed
to Reboot or Shutdown a machine ? In an environment where the box may be
used by more than one user (e.g. ssh'ed into it or X terminal session to it),
this is a significant problem (and, yes, the pre-login interface for both
KDE and Gnome *also* allow a non-root user to shut down a machine just by
walking past it and choosing the menu option with no username/password/anything
required). There's nothing in the Red Hat installation process that lets you
remove (or root-password-protect) those shutdown/halt options...there should
be. If someone wants to point me to the bug filed on this, then by all means
tell me off and show me the place to discuss this... :-)
Comment 3 Havoc Pennington 2002-07-14 12:01:09 EDT
You can only reboot/shutdown from the console, not from a remote login.
The general idea is that if you're at the console you can just push the power
button or pull the power cord anyway.
Comment 4 Havoc Pennington 2002-07-14 12:03:14 EDT
Hmm, also I noticed this bug is a dup.

Anyway the problem is that it's using /sbin/reboot not /usr/bin/reboot

Need to pass --with-halt-command --with-reboot-command to configure.
Comment 5 Havoc Pennington 2002-07-14 21:42:49 EDT
*** Bug 68839 has been marked as a duplicate of this bug. ***
Comment 6 Havoc Pennington 2002-07-14 21:43:11 EDT
*** Bug 68394 has been marked as a duplicate of this bug. ***
Comment 7 Bill Nottingham 2002-07-14 21:47:13 EDT
*** Bug 68839 has been marked as a duplicate of this bug. ***
Comment 8 Havoc Pennington 2002-07-16 15:50:52 EDT
*** Bug 68992 has been marked as a duplicate of this bug. ***
Comment 9 Havoc Pennington 2002-07-23 14:12:29 EDT
Fixed in rawhide
Comment 10 Jay Turner 2002-07-30 10:26:21 EDT
Fix confirmed with gnome-session-2.0.1-3.
Comment 11 Thomas M Steenholdt 2002-07-30 16:06:20 EDT
Maybe this is another scenario, but when I was testing wether the bug was gone
or not(in RH Limbo 7.3.93) I also tried the "Lock Screen" option which didn't
work...

Please advise wether or not to make a new bug report on this - i thought it
could be the same ting?!?
Comment 12 Havoc Pennington 2002-07-30 16:09:54 EDT
Lock screen is different - can you file a new bug?
Comment 13 Thomas M Steenholdt 2002-07-31 00:23:04 EDT
Sure can! Thanks!

Note You need to log in before you can comment on or make changes to this bug.