Bug 68133 - mc borders are wrong in the new gnome-terminal
mc borders are wrong in the new gnome-terminal
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: mc (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
: Triaged
: 68194 80327 (view as bug list)
Depends On:
Blocks: 67218 79579 CambridgeTarget
  Show dependency treegraph
 
Reported: 2002-07-06 15:57 EDT by Bernd Bartmann
Modified: 2007-04-18 12:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-24 13:26:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernd Bartmann 2002-07-06 15:57:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
The borders for mc are displayed using wrong characters in the new gnome
terminal. When I try to edit a file in mc using F4, mc takes 100% CPU time and
the whole system is not longer usable at all. F10 opens the menu of the gnome
terminal and does not close mc. System default language is german.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. startx, open a gnome terminal and start mc, system language is german
2. try to edit a file using F4, try to close mc using F10
3. watch the wrong borders of mc
	

Additional info:
Comment 1 Havoc Pennington 2002-07-06 18:18:48 EDT
F10 is not a bug; that's the "open menu" key. You can disable it in
Edit->Keybindings.
Comment 2 Bernd Bartmann 2002-07-06 19:03:17 EDT
I've opened a new bug for the "F4" edit problem as this also happens on the
console (Bug-ID:  68144). Nevertheless I think "F10" for open menu is a very
stupid choice. All people I know use mc in the gnome terminal and they all will
get very nervous with this new "feature".
Comment 3 Havoc Pennington 2002-07-06 19:14:53 EDT
F10 opens the menu in Java. F10 opens the menu on Windows. F10 is the standard
key for jumping to the menubar. There's a way to turn it off if you use mc. (mc
is the only terminal app that seems to use F10.)
Comment 4 Bill Nottingham 2002-07-08 01:49:23 EDT
borders issue is mc being ported to the new slang...
Comment 5 Bill Nottingham 2002-07-08 02:13:07 EDT
*** Bug 68194 has been marked as a duplicate of this bug. ***
Comment 6 Bill Nottingham 2003-02-21 19:29:55 EST
*** Bug 80327 has been marked as a duplicate of this bug. ***
Comment 7 Arie 2003-09-29 08:18:10 EDT
Hello.
Apparently, I had the same problem with the borders of mc displaying wrong 
characters, for the installation of HedHat 9.0 that comes with Moonlight 
Commander ver 4.6.
What I did is - simply use the Moonlight Commander ver 4.5.55 that already 
worded for me at the past.
only two things need to be done:
1) replace
/usr/bin/mc
2) add
/usr/lib/libslang.so.1
if anyone want this binaries, can contact me.
  Arie.
Comment 8 Leonard den Ottolander 2004-08-24 13:26:53 EDT
I don't believe this issue is still existent. Closing.

Note You need to log in before you can comment on or make changes to this bug.