Bug 681392 - [abrt] radiotray-0.6.3-1.fc14: pa_memblock_unref: Process /usr/bin/python was killed by signal 6 (SIGABRT)
Summary: [abrt] radiotray-0.6.3-1.fc14: pa_memblock_unref: Process /usr/bin/python was...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: radiotray
Version: 14
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jean-Francois Saucier
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:455c96fc09965308e5564ce835c...
: 691767 693902 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-02 01:13 UTC by Vlad
Modified: 2011-10-13 13:27 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-13 13:27:57 UTC


Attachments (Terms of Use)
File: backtrace (86.78 KB, text/plain)
2011-03-02 01:15 UTC, Vlad
no flags Details

Description Vlad 2011-03-02 01:13:45 UTC
abrt version: 1.1.17
architecture: i686
Attached file: backtrace, 88866 bytes
cmdline: /usr/bin/python /usr/bin/radiotray
component: radiotray
Attached file: coredump, 81735680 bytes
crash_function: pa_memblock_unref
executable: /usr/bin/python
kernel: 2.6.35.11-83.fc14.i686
package: radiotray-0.6.3-1.fc14
rating: 4
reason: Process /usr/bin/python was killed by signal 6 (SIGABRT)
release: Fedora release 14 (Laughlin)
time: 1299027746
uid: 501

How to reproduce
-----
1. run radiotray
2. use unstable network connection 
3. have frequent radiotray crash when it trying to reconnect to the server. No matter what radio station you listen at the moment

Comment 1 Vlad 2011-03-02 01:15:20 UTC
Created attachment 481757 [details]
File: backtrace

Comment 2 Vlad 2011-03-03 19:53:30 UTC
Yesterday evening i removed pulseaudio-module-bluetooth and its dependencies and must say it did not crash since then. 
 Not sure if this is related to the same bug or i should open another one but since i removed pulseaudio-module-bluetooth, pulseaudio CPU load raises to 100% when radiotray for any reason getting disconnect from radio server. However loading getting back to usual 1-5% when radiotray reconnect or i choose another radio server and it start playing again

Comment 3 Thomas Spura 2011-03-29 15:00:55 UTC
*** Bug 691767 has been marked as a duplicate of this bug. ***

Comment 4 Jean-Francois Saucier 2011-06-18 15:19:19 UTC
*** Bug 693902 has been marked as a duplicate of this bug. ***

Comment 5 Jean-Francois Saucier 2011-09-13 11:27:42 UTC
Thank you for reporting this bug. I just submitted a new update of Radiotray (0.6.4) to Fedora and you should see it in your list of updates soon.

Please report back here if your problem is still present in this new version.

If no activity are logged in this bug report in 2 weeks, I will close it.

Please fell free to reopen it or report a new one if you have any problem with Radiotray.


Note You need to log in before you can comment on or make changes to this bug.