Bug 683497 - [abrt] bluefish-2.0.3-2.fc14: file_checkNsave_cancel: Process /usr/bin/bluefish was killed by signal 11 (SIGSEGV)
Summary: [abrt] bluefish-2.0.3-2.fc14: file_checkNsave_cancel: Process /usr/bin/bluefi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: bluefish
Version: 14
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Paul Howarth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:d841c12968d5f7fce897e6325f8...
: 688061 689084 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-09 15:12 UTC by Stéphane
Modified: 2011-03-26 18:59 UTC (History)
4 users (show)

Fixed In Version: bluefish-2.0.3-3.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-21 14:22:46 UTC


Attachments (Terms of Use)
File: backtrace (13.73 KB, text/plain)
2011-03-09 15:12 UTC, Stéphane
no flags Details
Patch (708 bytes, patch)
2011-03-10 02:32 UTC, Jim Hayward
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 637990 None None None Never

Description Stéphane 2011-03-09 15:12:17 UTC
abrt version: 1.1.17
architecture: x86_64
Attached file: backtrace, 14063 bytes
cmdline: bluefish
component: bluefish
Attached file: coredump, 26193920 bytes
crash_function: file_checkNsave_cancel
executable: /usr/bin/bluefish
kernel: 2.6.35.11-83.fc14.x86_64
package: bluefish-2.0.3-2.fc14
rating: 4
reason: Process /usr/bin/bluefish was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1299683340
uid: 500

How to reproduce
-----
1.fermeture de l'application
2.
3.

Comment 1 Stéphane 2011-03-09 15:12:20 UTC
Created attachment 483236 [details]
File: backtrace

Comment 2 Jim Hayward 2011-03-10 02:32:58 UTC
Created attachment 483341 [details]
Patch

Patch is attached for a change made upstream to workaround the bug. This does not fix the root issue which appears to be that an autosave is being cancelled that isn't running.

The problem appears to randomly happen only when closing Bluefish.

Comment 3 Paul Howarth 2011-03-10 13:36:11 UTC
There are a number of autosave/closing bugs from 2.0.2 that might be related or provide some clues perhaps?

* Bug #678737
* Bug #675377
* Bug #670000
* Bug #668784
* Bug #658468
* Bug #648096

I'll prepare an update with the workaround in the meantime.

Comment 4 Fedora Update System 2011-03-10 22:17:45 UTC
bluefish-2.0.3-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/bluefish-2.0.3-3.fc15

Comment 5 Fedora Update System 2011-03-10 22:17:57 UTC
bluefish-2.0.3-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/bluefish-2.0.3-3.fc14

Comment 6 Fedora Update System 2011-03-10 22:18:08 UTC
bluefish-2.0.3-3.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/bluefish-2.0.3-3.el6

Comment 7 Fedora Update System 2011-03-10 22:18:19 UTC
bluefish-2.0.3-3.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/bluefish-2.0.3-3.fc13

Comment 8 Jim Hayward 2011-03-11 03:22:01 UTC
(In reply to comment #3)

> * Bug #678737

Appears to be a different bug. Don't recall ever seeing that specific backtrace. Appears to be a bug never reported upstream.

> * Bug #675377

Should that be #675357? Doesn't appear to be autosave related. Appears to be a bug never reported upstream.

> * Bug #670000

This is an autosave bug. This should be fixed with 2.0.3.

> * Bug #668784

Appears to be the same bug as #678737

> * Bug #658468

This should be fixed with 2.0.3.

> * Bug #648096

Appears to be that same bug as Bug #658468. Should be fixed with 2.0.3.

Comment 9 Fedora Update System 2011-03-16 04:09:20 UTC
bluefish-2.0.3-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Paul Howarth 2011-03-16 08:57:10 UTC
*** Bug 688061 has been marked as a duplicate of this bug. ***

Comment 11 Paul Howarth 2011-03-19 10:22:59 UTC
*** Bug 689084 has been marked as a duplicate of this bug. ***

Comment 12 Fedora Update System 2011-03-19 10:25:33 UTC
bluefish-2.0.3-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2011-03-19 10:29:18 UTC
bluefish-2.0.3-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2011-03-26 18:59:09 UTC
bluefish-2.0.3-3.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.