Bug 685142 - Menu problems with fallback mode
Menu problems with fallback mode
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
AcceptedNTH
:
: 684282 691179 (view as bug list)
Depends On:
Blocks: F15-accepted/F15FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2011-03-15 08:18 EDT by Elad Alfassa
Modified: 2011-04-18 12:18 EDT (History)
8 users (show)

See Also:
Fixed In Version: gnome-menus-3.0.0-2.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-15 17:36:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ship menus (2.04 KB, patch)
2011-04-11 13:38 EDT, Colin Walters
no flags Details | Diff
use it (2.62 KB, patch)
2011-04-11 13:39 EDT, Colin Walters
no flags Details | Diff

  None (edit)
Description Elad Alfassa 2011-03-15 08:18:18 EDT
Fallback mode has a long list of problems. This is one of them.
In the shell, a user can search the menu, and there, this (searching) is the only graphical way of getting to one of the system-config-something or desktop-effects and other stuff that used to live in the System menu of gnome 2.x.

But in the fallback mode in Fedora 15, there is no graphical way to get to those configuration UIs at all. the system menu lists only 3 options: System settings, logout and shutdown.

A user might think "They probably moved all the stuff I'm looking for to the System settings option" - but this is wrong, because clicking it just opens gnome-control-panel, which doesn't list any of the system-config-something UIs.

I think there are two possible solutions:
1) Bring the old "administration" menu back to fallback mode
2) Make gnome-control-panel list system-config-something UIs.

And I really think that this bug should be a blocker for Fedora 15.
Comment 1 Colin Walters 2011-03-17 09:34:25 EDT
Is it intentional that we're showing e.g. system-config-firewall in non-fallback?  I'm not sure.  I'll take this as a blocker until we decide what the design is, I agree it's inconsistent.
Comment 2 Elad Alfassa 2011-03-17 09:57:08 EDT
System-config-firewall is only one example.
What about gnome-packagekit?
If a user can't install a package graphically, then fallback mode is failing to do it's job (providing a 100% working system for hardware that can't run the shell). A user who is not familiar with the command line / terminal and uses the fallback can't launch it at all.

It is possible to take gnome-packagekit as an exception and put it in the System menu without a category or (somewhere) in the Applications menu (maybe without a category?). It is much more important than other configuration UIs.
Comment 3 Colin Walters 2011-03-17 15:11:21 EDT
Thanks for catching this!  Discussed this with Jon McCann; the plan is roughly to move the admin tools into a separate application category in both fallback and standard.  I'll link the upstream bugs here soon.
Comment 4 Colin Walters 2011-03-17 15:28:38 EDT
gnome-menus bug: https://bugzilla.gnome.org/review?bug=645061
gnome-shell bug: https://bugzilla.gnome.org/show_bug.cgi?id=645063
Comment 5 Rahul Sundaram 2011-04-07 09:13:52 EDT
*** Bug 691179 has been marked as a duplicate of this bug. ***
Comment 6 Rahul Sundaram 2011-04-07 09:15:02 EDT
*** Bug 684282 has been marked as a duplicate of this bug. ***
Comment 7 Colin Walters 2011-04-11 13:38:53 EDT
Created attachment 491289 [details]
ship menus
Comment 8 Colin Walters 2011-04-11 13:39:17 EDT
Created attachment 491290 [details]
use it
Comment 9 Colin Walters 2011-04-11 13:40:04 EDT
So both gnome-shell and gnome-panel are using redhat-menus, not gnome-menus.  These two patches fix gnome-shell to use gnome-menus as designed.
Comment 10 Matthias Clasen 2011-04-11 13:43:55 EDT
I would really like to see us drop redhat-menus for good, but that is probably F16 material at this point. The patches look fine to me for F15. Not sure if we have a hard dep on gnome-menus somewhere below gnome-shell, might be good to add an explicit one in the shell spec ?
Comment 11 Fedora Update System 2011-04-12 16:52:50 EDT
gnome-menus-3.0.0-2.fc15,gnome-shell-3.0.0.2-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gnome-menus-3.0.0-2.fc15,gnome-shell-3.0.0.2-2.fc15
Comment 12 Fedora Update System 2011-04-13 00:53:08 EDT
Package gnome-menus-3.0.0-2.fc15, gnome-shell-3.0.0.2-2.fc15, gnome-panel-3.0.0.1-2.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-menus-3.0.0-2.fc15 gnome-shell-3.0.0.2-2.fc15 gnome-panel-3.0.0.1-2.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/gnome-menus-3.0.0-2.fc15,gnome-shell-3.0.0.2-2.fc15,gnome-panel-3.0.0.1-2.fc15
then log in and leave karma (feedback).
Comment 13 Elad Alfassa 2011-04-13 09:30:20 EDT
IMO Menu items form Other should NOT be shown in All (we don't want tons of old-ish configuration UIs visible all time, do we?).
Comment 14 Colin Walters 2011-04-13 09:47:12 EDT
(In reply to comment #13)
> IMO Menu items form Other should NOT be shown in All (we don't want tons of
> old-ish configuration UIs visible all time, do we?).

The fix for not showing crap is to not have crap installed, IMO.
Comment 15 Adam Williamson 2011-04-15 14:37:35 EDT
Discussed at 2011-04-15 blocker review meeting. We're worried about this and prima facie we felt like we might want it to be a blocker, but it does not meet any existing criteria. We decided to take a pragmatic route and accept it as NTH but reject it as blocker, as there's a fix pending; we'd look more closely at writing a criterion for this if we were closer to release with no fix.

If anyone's unhappy with the fix and feels it still doesn't expose things that should be exposed, please re-open this bug if it gets closed.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 16 Elad Alfassa 2011-04-15 14:48:49 EDT
(In reply to comment #15)
> Discussed at 2011-04-15 blocker review meeting. We're worried about this and
> prima facie we felt like we might want it to be a blocker, but it does not meet
> any existing criteria. We decided to take a pragmatic route and accept it as
> NTH but reject it as blocker, as there's a fix pending; we'd look more closely
> at writing a criterion for this if we were closer to release with no fix.
> 
> If anyone's unhappy with the fix and feels it still doesn't expose things that
> should be exposed, please re-open this bug if it gets closed.
> 
> 
> 
> -- 
> Fedora Bugzappers volunteer triage team
> https://fedoraproject.org/wiki/BugZappers

Actually the current fix is a bit problematic, because it will cause showing the Other menu in default installation, and it's against the final release criteria: https://fedoraproject.org/wiki/Fedora_15_Final_Release_Criteria

To fix this, I'd suggest: not shipping system-config-services by default (doesn't work with systemd), move system-config-firewall to System Tools, but I have no idea what to do with the other items there (the correct fix will be either making an Administration menu, or changing the criteria)
Comment 17 Fedora Update System 2011-04-15 17:36:51 EDT
gnome-menus-3.0.0-2.fc15, gnome-shell-3.0.0.2-2.fc15, gnome-panel-3.0.0.1-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Adam Williamson 2011-04-18 12:18:37 EDT
elad: nice catch, can you file a separate bug for that one, then?

Note You need to log in before you can comment on or make changes to this bug.