Bug 688844 - [abrt] NetworkManager-gnome-1:0.8.3.997-1.fc14: g_object_ref: Process /usr/bin/nm-connection-editor was killed by signal 11 (SIGSEGV)
Summary: [abrt] NetworkManager-gnome-1:0.8.3.997-1.fc14: g_object_ref: Process /usr/bi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 14
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:4bb7181beaa7e1250b9c3a0ccb3...
: 677055 694319 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-18 08:15 UTC by Robert Binkhorst
Modified: 2011-05-26 21:52 UTC (History)
3 users (show)

Fixed In Version: NetworkManager-0.8.4-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-04-28 02:04:31 UTC


Attachments (Terms of Use)
File: backtrace (20.89 KB, text/plain)
2011-03-18 08:15 UTC, Robert Binkhorst
no flags Details

Description Robert Binkhorst 2011-03-18 08:15:08 UTC
abrt version: 1.1.17
architecture: x86_64
Attached file: backtrace, 21390 bytes
cmdline: /usr/bin/nm-connection-editor
comment: It also happened when enabling the wired network
component: NetworkManager
Attached file: coredump, 58327040 bytes
crash_function: g_object_ref
executable: /usr/bin/nm-connection-editor
kernel: 2.6.35.11-83.fc14.x86_64
package: NetworkManager-gnome-1:0.8.3.997-1.fc14
rating: 4
reason: Process /usr/bin/nm-connection-editor was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1300435875
uid: 500

How to reproduce
-----
1. I have wired network disabled, mobile broadband enabled
2. Go into edit connections, edit broadband settings, change nothing, edit wired settings, click on IPv4 TAB and the crash happened for me.
3.

Comment 1 Robert Binkhorst 2011-03-18 08:15:10 UTC
Created attachment 486177 [details]
File: backtrace

Comment 2 Dan Williams 2011-04-13 16:44:49 UTC
*** Bug 694319 has been marked as a duplicate of this bug. ***

Comment 3 Dan Williams 2011-04-13 19:31:46 UTC
*** Bug 677055 has been marked as a duplicate of this bug. ***

Comment 4 Dan Williams 2011-04-13 19:42:09 UTC
This is fixed upstream by the fixes for GtkBuilder and toplevels, as of 1de8ed97644803457305

Comment 5 Fedora Update System 2011-04-15 21:43:30 UTC
NetworkManager-0.8.3.999-2.git20110414.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.999-2.git20110414.fc14

Comment 6 Fedora Update System 2011-04-15 21:44:19 UTC
NetworkManager-0.8.3.999-2.git20110414.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.999-2.git20110414.fc13

Comment 7 Fedora Update System 2011-04-16 20:51:00 UTC
Package NetworkManager-0.8.3.999-2.git20110414.fc13:
* should fix your issue,
* was pushed to the Fedora 13 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing NetworkManager-0.8.3.999-2.git20110414.fc13'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.999-2.git20110414.fc13
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2011-04-20 22:43:20 UTC
NetworkManager-0.8.4-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/NetworkManager-0.8.4-1.fc14

Comment 9 Fedora Update System 2011-04-20 22:44:50 UTC
NetworkManager-0.8.4-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/NetworkManager-0.8.4-1.fc13

Comment 10 Fedora Update System 2011-04-28 02:03:45 UTC
NetworkManager-0.8.4-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2011-05-26 21:52:55 UTC
NetworkManager-0.8.4-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.