Bug 690558 - collectd FTBFS in rawhide and F15
collectd FTBFS in rawhide and F15
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: collectd (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alan Pevec
Fedora Extras Quality Assurance
:
Depends On: 691380
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-24 12:31 EDT by Tom Lane
Modified: 2013-07-02 23:36 EDT (History)
6 users (show)

See Also:
Fixed In Version: collectd-4.10.3-2.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-03 00:51:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom Lane 2011-03-24 12:31:52 EDT
Description of problem:
Build fails.  It appears to be complaining about "nut", but perusal of config.log shows that the real problem is here:

configure:22251: checking for upscli_connect in -lupsclient
configure:22276: gcc -o conftest -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic     @LIBSSL_LDFLAGS@ -lupsclient   conftest.c -lupsclient  -ldl  >&5
gcc: error: @LIBSSL_LDFLAGS@: No such file or directory
configure:22276: $? = 1

Looks like somebody's changed SSL's exported macros on you.

Version-Release number of selected component (if applicable):
collectd-4.10.2-4.fc16

How reproducible:
100%

Steps to Reproduce:
1. fedpkg build

Additional info:
This is interfering with the mysql mass rebuild in F15:
http://lists.fedoraproject.org/pipermail/devel/2011-March/149784.html
Comment 1 Tom Lane 2011-03-24 16:00:15 EDT
Note --- the temporary dist-f15-mysql tag is history.  Just build in F15 normally when you fix this.
Comment 2 Alan Pevec 2011-04-19 14:28:17 EDT
Temporary fixed by disabling collectd-nut.
For the final fix waiting on nut bug 691380 (FEDORA-2011-4774) to hit buildroots.
Comment 3 Alan Pevec 2011-04-19 15:41:41 EDT
nut fix is in buildroots but it has dependency on hal which got removed in rawhide:
DEBUG util.py:247:  ERROR with rpm_check_debug vs depsolve:
DEBUG util.py:247:  hal is needed by nut-client-2.6.0-4.fc16.x86_64

Michal, do you have a BZ for that already or you want me to open one?

In the meantime I'll re-enable nut on f15/14 branches only.
Comment 4 Fedora Update System 2011-04-19 18:48:14 EDT
collectd-4.10.3-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/collectd-4.10.3-2.fc15
Comment 5 Fedora Update System 2011-04-19 22:44:20 EDT
Package collectd-4.10.3-2.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing collectd-4.10.3-2.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/collectd-4.10.3-2.fc15
then log in and leave karma (feedback).
Comment 6 Michal Hlavinka 2011-04-20 05:01:48 EDT
(In reply to comment #3)
> nut fix is in buildroots but it has dependency on hal which got removed in
> rawhide:
> DEBUG util.py:247:  ERROR with rpm_check_debug vs depsolve:
> DEBUG util.py:247:  hal is needed by nut-client-2.6.0-4.fc16.x86_64
> 
> Michal, do you have a BZ for that already or you want me to open one?

I know about it, but open a BZ for that, so I don't forget. Thanks
Comment 7 Alan Pevec 2011-04-20 05:35:46 EDT
(In reply to comment #6)
> I know about it, but open a BZ for that, so I don't forget. Thanks

bug 698134
Comment 8 Fedora Update System 2011-05-03 00:51:05 EDT
collectd-4.10.3-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.