Bug 691370 - Fix youtube error 'An error occurred, please try again later.'
Fix youtube error 'An error occurred, please try again later.'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnash (Show other bugs)
14
x86_64 Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Hicham HAOUARI
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-28 07:28 EDT by collura
Modified: 2011-04-27 22:04 EDT (History)
5 users (show)

See Also:
Fixed In Version: gnash-0.8.9-4.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-24 00:09:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description collura 2011-03-28 07:28:33 EDT
Description of problem:

this is a tracking bug for gnash AVM2 support which is related to various things including a youtube.com error when trying to play AVM2 video:

   'An error occurred, please try again later.'

(see some AVM2 related bugs below in the additional information section.)

i dont see a current open request for enhancement tracking bug upstream yet 
but behold the prophesy of the AVM2 support:

 http://wiki.gnashdev.org/List_of_Tasks
 >AVM2 Compatibility
 >
 >Petter Reinholdtsen started a pledge on http://www.pledgebank.com/gnash-avm2 to 
 >try to raise funding to get AVM2 support into Gnash, and it is open until 
 >December 24th, 2010. As he succeeded in raising the $1400USD that was his goal, 
 >now we're looking for someone to sign up for this task.



Version-Release number of selected component (if applicable):
 firefox-3.6.16-1.f14 (x86_64)
 gnash-1:0.8.9-1.fc14 (x86_64)

How reproducible:
 always

Steps to Reproduce:
1. try to play AVM2 format youtube.com video
2. get 'An error occurred, please try again later.'
3.
  
Actual results:
 AVM2 format youtube.com videos give error instead of playing.

Expected results:
 AVM2 youtube videos play without error

Additional info:
 here are some related links:


https://bugzilla.redhat.com/show_bug.cgi?id=606170
>Upstream bug :
>>http://savannah.gnu.org/bugs/?30005
>>flash movies from youtube and facebook don't work



https://bugzilla.redhat.com/show_bug.cgi?id=652351
>FIrefox with Gnash plugin unable to display YouTube videos



https://bugzilla.redhat.com/show_bug.cgi?id=666602#c14
>The blank videos linked are avm2, which isn't supported by gnash.






https://savannah.gnu.org/bugs/?func=detailitem&item_id=21365
>AVM2: Gnash doesn't play sevenload-videos



https://savannah.gnu.org/bugs/?func=detailitem&item_id=24620
>AVM2: finance.google.com stock graphs unsupported by gnash



https://savannah.gnu.org/bugs/?func=detailitem&item_id=24635
>AVM2: Gnash plugin does not load acdc.com



https://savannah.gnu.org/bugs/?func=detailitem&item_id=30357
>all youtube fail with "An error occurred, please try again later"
...
>YouTube cookie is a redirect to a regional video server



https://savannah.gnu.org/bugs/?func=detailitem&item_id=32007
>Some yt videos appears as AVM2 so are not played by gnash.



https://savannah.gnu.org/bugs/?func=detailitem&item_id=32588
>Some YouTube movies use AVM2 watermark file
>Thu 24 Feb 2011 05:11:10 PM UTC, original submission:
>
>At least in the US, some of the commercial movies available freely load a "watermark*.swf" file, which is AVM2. This produces the infamous "error occurred": message which looked like the old issue with cookie. I verified that cookies were working 100% correctly. The big difference is that along with the error message, Gnash displays the spinning wheel forever...
>
>So this isn't exactly a Gnash bug, as it doesn't handle AVM2. A bug report has been sent to the YouTube developers, who have been helpful to make sure they only serve up AVM1 files when Gnash is the User agent. This bug is just to document the problem so it doesn't get lost. 
>
Comment 1 Hicham HAOUARI 2011-03-28 19:59:00 EDT
Thank you for reporting this bug, however, I don't think there is much we can do about this bug in downstream fedora.

Lightspark is supposed to take care of avm2 videos, as upstream doesn't plan to support avm2 AFAIK.
Comment 2 Hicham HAOUARI 2011-03-29 22:17:14 EDT
Can you give any example of non working youtube videos ?
Comment 3 collura 2011-03-30 06:54:57 EDT
regarding comment#2

i dont have example just aggregating and restating from upstream: 

(https://savannah.gnu.org/bugs/?func=detailitem&item_id=32588 which
appears above poorly formatted so reentering here)
  >Some YouTube movies use AVM2 watermark file
  >Thu 24 Feb 2011 05:11:10 PM UTC, original submission:
  >
  >At least in the US, some of the commercial movies 
  >available freely load a "watermark*.swf" file, which is AVM2. 
  >This produces the infamous "error occurred": message which 
  >looked like the old issue with cookie. I verified that 
  >cookies were working 100% correctly. The big difference is 
  >that along with the error message, Gnash displays the 
  >spinning wheel forever...
  >
  >So this isn't exactly a Gnash bug, as it doesn't handle AVM2. 
  >A bug report has been sent to the YouTube developers, 
  >who have been helpful to make sure they only serve up AVM1 files 
  >when Gnash is the User agent. This bug is just to document 
  >the problem so it doesn't get lost. 

though i did run across 

  http://www.youtube.com/user/nba?blend=1&ob=4#p/u/1/gtYFo4pJN-E

  which file-properties-stage of mousemenu lists as something like
    root_vm_version: 'avm2 (unsupported)'
    root_swf_version: swf11

  (*which didnt play but doesnt give the error message so probably need remove 
  error from this bug title but dont know if someone else has a link 
  that still gives the error.*)

but it looks like gnu-bug#32588 listed in this post might have got movement on the 'working with youtube developers on serving of avm1 for gnash user agent' 
because when i try: 

  http://www.youtube.com/watch?v=gtYFo4pJN-E

i get avm1 and swf9 and the 'an error occurred' but that error 
seems to be the [cookie / noscript addon] related error which clears when you 
[delete the cookies using the tools-clearrecenthistory] 
and also 
[either disable noscript addon or 'temporarily allow all page' in noscript]
Comment 4 Hicham HAOUARI 2011-03-30 19:39:42 EDT
you have to remove the cookies only once ?
Comment 5 collura 2011-04-03 17:12:19 EDT
looks like i have to remove the youtube.com cookie folder after each video or i get the error whether i have noscript enabled or not
Comment 6 Hicham HAOUARI 2011-04-03 18:03:49 EDT
weird, I can't reproduce this issue, I even ran gnash in a sandbox and it works without problems
Comment 7 collura 2011-04-03 21:18:47 EDT
hmm, 

i think will have to wait and report back after 
  gnash-1:0.8.9-2.fc14.testing (x86_64) 
clears testing.

i tried the 
  gnash-1:0.8.9-2.fc14.testing (x86_64) on a kde machine 
and only seemed to have to clear the youtube.com cookies once. woot.
Comment 8 Hicham HAOUARI 2011-04-05 08:43:49 EDT
(In reply to comment #7)
> i tried the 
>   gnash-1:0.8.9-2.fc14.testing (x86_64) on a kde machine 
> and only seemed to have to clear the youtube.com cookies once. woot.

This is what upstream said since 0.8.8
Comment 9 Hicham HAOUARI 2011-04-09 20:58:13 EDT
Issue seems to be related to nspluginwrapper, removing it fixes the problem.

I updated the wiki to mention that :

https://fedoraproject.org/wiki/Flash#Installing_Gnash
Comment 10 Hicham HAOUARI 2011-04-09 21:48:45 EDT
I filed a bug to blacklist gnash in nspluginwrapper : 

https://bugzilla.redhat.com/show_bug.cgi?id=695042
Comment 11 Hicham HAOUARI 2011-04-17 20:32:17 EDT
This should be fixed in gnash-0.8.9-4
Comment 12 Fedora Update System 2011-04-17 20:47:30 EDT
gnash-0.8.9-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gnash-0.8.9-4.fc15
Comment 13 Fedora Update System 2011-04-17 20:48:01 EDT
gnash-0.8.9-4.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/gnash-0.8.9-4.fc14
Comment 14 Fedora Update System 2011-04-17 20:48:06 EDT
gnash-0.8.9-4.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/gnash-0.8.9-4.fc13
Comment 15 Fedora Update System 2011-04-18 17:20:32 EDT
Package gnash-0.8.9-4.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnash-0.8.9-4.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/gnash-0.8.9-4.fc14
then log in and leave karma (feedback).
Comment 16 Fedora Update System 2011-04-24 00:09:52 EDT
gnash-0.8.9-4.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2011-04-27 21:58:56 EDT
gnash-0.8.9-4.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2011-04-27 22:04:49 EDT
gnash-0.8.9-4.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.