Bug 692433 - Cannot connect to Gnome keyring daemon dialog becomes annoying
Cannot connect to Gnome keyring daemon dialog becomes annoying
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
15
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Nikola Pajkovsky
Fedora Extras Quality Assurance
AcceptedBlocker
: Reopened
: 727540 (view as bug list)
Depends On:
Blocks: 692803 F16Alpha/F16AlphaBlocker
  Show dependency treegraph
 
Reported: 2011-03-31 07:02 EDT by David Kutálek
Modified: 2014-02-02 17:15 EST (History)
18 users (show)

See Also:
Fixed In Version: libreport-2.0.5-4.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-10 12:07:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot for i386 netinst when the save fails (27.03 KB, application/x-gzip)
2011-08-09 16:28 EDT, Andre Robatino
no flags Details

  None (edit)
Description David Kutálek 2011-03-31 07:02:57 EDT
Description of problem:

With default settings of Fedora 15 Live CD KDE spin, gnome keyring daemon is probably not configured, causing abrt-gui to pop up warning window about it. That is fine, but abrt-gui pops up this window in every step of crash analyze process, showing it at least four times per one crash reporting. That is annoying for user and definitely not needed - once per abrt-gui session should be enough.

Perhaps, if daemon comes up during abrt-gui session, abrt-gui can pop up info about successful connection. 

Version-Release number of selected component (if applicable):

[root@localhost liveuser]# rpm -q abrt abrt-gui
abrt-2.0.0-3.fc15.i686
abrt-gui-2.0.0-3.fc15.i686


How reproducible:

Always on F15 Live CD - KDE spin

Steps to Reproduce:
1. Log into KDE, create crash, try to report it
2. watch keayring warnings popping up
3.
  
Actual results:

As desribed above

Expected results:

As described above, only once per abrt-gui session, perhaps with info window when daemon comes up

Additional info:
Comment 1 ewright2 2011-04-28 18:51:56 EDT
I have the same issue.  It's rather annoying.
Comment 2 Nick Coghlan 2011-06-09 02:40:15 EDT
This also happens to me after switching a Gnome PXE boot over to KDE.

It's actually a bit more annoying than just the dialog popping up all the time, though: without the keyring, event configuration details (such as the Bugzilla login) can't be saved and instead of prompting for them when needed, the GUI repeatedly pops up warnings asking for the details to be added (even though it doesn't need them until the very last step).
Comment 3 Jiri Moskovcak 2011-08-02 10:12:20 EDT
*** Bug 727540 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2011-08-02 12:50:46 EDT
libreport-2.0.5-4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/libreport-2.0.5-4.fc16
Comment 5 Fedora Update System 2011-08-02 16:50:43 EDT
Package libreport-2.0.5-4.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreport-2.0.5-4.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/libreport-2.0.5-4.fc16
then log in and leave karma (feedback).
Comment 6 He Rui 2011-08-08 02:11:51 EDT
It still happens on anaconda 16.14.2 of F-16-Alpha-RC1. Proposed it as Alpha blocker as it blocks all the ways(local, scp, bugzilla, ftp...) to save traceback on anaconda.
Comment 7 Jiri Moskovcak 2011-08-08 04:38:32 EDT
(In reply to comment #6)
> It still happens on anaconda 16.14.2 of F-16-Alpha-RC1. Proposed it as Alpha
> blocker as it blocks all the ways(local, scp, bugzilla, ftp...) to save
> traceback on anaconda.

It's just a nagging dialog, it shouldn't prevent you from saving the traceback even though you have to close that dialog few times...
Comment 8 He Rui 2011-08-08 06:53:22 EDT
(In reply to comment #7)
> (In reply to comment #6)
> > It still happens on anaconda 16.14.2 of F-16-Alpha-RC1. Proposed it as Alpha
> > blocker as it blocks all the ways(local, scp, bugzilla, ftp...) to save
> > traceback on anaconda.
> 
> It's just a nagging dialog, it shouldn't prevent you from saving the traceback
> even though you have to close that dialog few times...

When the dialog prompted, the forward button was disabled. I clicked the 'configure events', it also didn't allow to edit any words. I filed a bug with attachments, see comment#3.
Comment 9 Tim Flink 2011-08-08 12:33:36 EDT
Discussed in the 2011-08-08 Fedora QA meeting. Accepted as a Fedora 16 alpha blocker as it violates the following alpha release criterion [1]:

The installer must be able to report failures to Bugzilla, with appropriate information included.

[1] https://fedoraproject.org/wiki/Fedora_16_Alpha_Release_Criteria
Comment 10 Fedora Update System 2011-08-09 02:03:02 EDT
libreport-2.0.5-4.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Andre Robatino 2011-08-09 04:02:02 EDT
This problem still exists on RC2, which only includes libreport-2.0.5-2.fc16.
Comment 12 James Laska 2011-08-09 10:33:20 EDT
(In reply to comment #11)
> This problem still exists on RC2, which only includes libreport-2.0.5-2.fc16.

Opening this issue back up ... since the update was not pulled into the compose.  We may choose to track this as a new bug report, since the action may only involve Fedora release engineering to ensure the updated libreport is pulled into a compose.
Comment 13 Jiri Moskovcak 2011-08-09 10:39:17 EDT
this is fixed in libreport-2.0.5-4.fc16 which was pushed to stable just today.
Comment 14 Adam Williamson 2011-08-09 12:43:48 EDT
rc3 is spinning with the updated libreport included. it fell through the gap for rc2, unfortunately.
Comment 15 Andre Robatino 2011-08-09 15:17:43 EDT
Still broken on RC3.
Comment 16 Andre Robatino 2011-08-09 15:50:33 EDT
When the failure happens, I can barely read a message behind the trace window that says (I think) "Can't execute report-cli: No such file or directory".
Comment 17 Jiri Moskovcak 2011-08-09 16:12:07 EDT
(In reply to comment #16)
> When the failure happens, I can barely read a message behind the trace window
> that says (I think) "Can't execute report-cli: No such file or directory".

- hm, does it run in graphical mode?
Comment 18 Andre Robatino 2011-08-09 16:18:40 EDT
(In reply to comment #17)
> (In reply to comment #16)
> > When the failure happens, I can barely read a message behind the trace window
> > that says (I think) "Can't execute report-cli: No such file or directory".
> 
> - hm, does it run in graphical mode?

No, the GUI crashes first. This is the same behavior as with RC2 and possibly earlier (I can't remember).
Comment 19 Andre Robatino 2011-08-09 16:28:12 EDT
Created attachment 517485 [details]
screenshot for i386 netinst when the save fails
Comment 20 Adam Williamson 2011-08-09 18:44:19 EDT
andre: are you sure this is the same bug? it doesn't really sound like it...
Comment 21 Adam Williamson 2011-08-09 18:48:52 EDT
I just ran as far as I could through an abrt report in a VM and it didn't complain about gnome-keyring once, so I think that particular bug is fixed in RC3.
Comment 22 Andre Robatino 2011-08-09 22:41:08 EDT
(In reply to comment #20)
> andre: are you sure this is the same bug? it doesn't really sound like it...

I'm not sure at all, just that the failure (being unable to save) happens in exactly the same place, and it's quick and easy to reproduce with a netinst image (just boot using "updates=http://jlaska.fedorapeople.org/updates/traceback.img", and try selecting "Save" on the traceback window). If there's a separate bug, it was probably there before, since the behavior looks almost identical between RC2 and RC3.
Comment 23 He Rui 2011-08-10 00:02:35 EDT
(In reply to comment #22)
> (In reply to comment #20)
> > andre: are you sure this is the same bug? it doesn't really sound like it...
> 
> I'm not sure at all, just that the failure (being unable to save) happens in
> exactly the same place, and it's quick and easy to reproduce with a netinst
> image (just boot using
> "updates=http://jlaska.fedorapeople.org/updates/traceback.img", and try
> selecting "Save" on the traceback window). If there's a separate bug, it was
> probably there before, since the behavior looks almost identical between RC2
> and RC3.

I reported another bug:

https://bugzilla.redhat.com/show_bug.cgi?id=729528
Comment 24 Adam Williamson 2011-08-10 01:56:09 EDT
So, I think the cause of what Andre sees is pretty simple:

[root@adam Packages]# repoquery -f /usr/bin/report-cli
libreport-cli-0:2.0.5-2.fc16.x86_64
libreport-cli-0:2.0.5-4.fc16.x86_64
[root@adam Packages]# ls libreport-*
libreport-2.0.5-4.fc16.x86_64.rpm                  libreport-plugin-kerneloops-2.0.5-4.fc16.x86_64.rpm
libreport-gtk-2.0.5-4.fc16.x86_64.rpm              libreport-plugin-logger-2.0.5-4.fc16.x86_64.rpm
libreport-newt-2.0.5-4.fc16.x86_64.rpm             libreport-python-2.0.5-4.fc16.x86_64.rpm
libreport-plugin-bugzilla-2.0.5-4.fc16.x86_64.rpm

that's the Packages directory from the DVD: libreport-cli is missing. So RC3 can't possibly report bugs from a CLI install.

The interesting wrinkle is, why are we in CLI mode? The answer seems to be that for some reason, jlaska's test image results in the installer running in text mode. I can see a message on one of the consoles: "Exception starting GUI installer: No module named xutils". Is this just how you chose to trigger an anaconda error, James?

Anyhow, this issue is clearly different from the initial report, but may well qualify as a blocker in itself. I'll file it separately. Now we need a way to trigger an exception in graphical mode so we can check that reporting works in graphical mode...
Comment 25 He Rui 2011-08-10 02:47:47 EDT

(In reply to comment #24)
> So, I think the cause of what Andre sees is pretty simple:
> 
> [root@adam Packages]# repoquery -f /usr/bin/report-cli
> libreport-cli-0:2.0.5-2.fc16.x86_64
> libreport-cli-0:2.0.5-4.fc16.x86_64
> [root@adam Packages]# ls libreport-*
> libreport-2.0.5-4.fc16.x86_64.rpm                 
> libreport-plugin-kerneloops-2.0.5-4.fc16.x86_64.rpm
> libreport-gtk-2.0.5-4.fc16.x86_64.rpm             
> libreport-plugin-logger-2.0.5-4.fc16.x86_64.rpm
> libreport-newt-2.0.5-4.fc16.x86_64.rpm            
> libreport-python-2.0.5-4.fc16.x86_64.rpm
> libreport-plugin-bugzilla-2.0.5-4.fc16.x86_64.rpm
> 
> that's the Packages directory from the DVD: libreport-cli is missing. So RC3
> can't possibly report bugs from a CLI install.

Oh, that's a different bug.

> 
> Anyhow, this issue is clearly different from the initial report, but may well
> qualify as a blocker in itself. I'll file it separately. Now we need a way to
> trigger an exception in graphical mode so we can check that reporting works in
> graphical mode...

For a temporary solution, since there's an existing bug that hasn't been fixed, the step to trigger it is:
1. Boot with ks=http://rhe.fedorapeople.org/install/partition.cfg
2. Select 'Create Custom layout' and click 'next'

Then you'll see that the reporter wouldn't allow any editing or forwarding. I've reported another bug as commented in comment#23
Comment 26 Adam Williamson 2011-08-10 12:07:30 EDT
so, let's close this specific bug - I'm pretty sure it's addressed, as a straightforward, non-installer abrt test shows - and work on #729528 and #729537 (my report for the text mode fail). they may yet turn out to have the same root cause, by the looks of it - stuff missing from lorax.

Note You need to log in before you can comment on or make changes to this bug.