Bug 695818 - SELinux is preventing /bin/bash from 'execute' accesses on the file /bin/systemctl.
SELinux is preventing /bin/bash from 'execute' accesses on the file /bin/syst...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
15
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:a6348cf2b85...
:
: 696796 696800 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-12 14:40 EDT by Steve Tyler
Modified: 2011-04-16 19:46 EDT (History)
6 users (show)

See Also:
Fixed In Version: selinux-policy-3.9.16-15.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-15 17:32:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Tyler 2011-04-12 14:40:44 EDT
SELinux is preventing /bin/bash from 'execute' accesses on the file /bin/systemctl.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that bash should be allowed execute access on the systemctl file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep ck-system-stop /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:consolekit_t:s0
Target Context                system_u:object_r:systemd_systemctl_exec_t:s0
Target Objects                /bin/systemctl [ file ]
Source                        ck-system-stop
Source Path                   /bin/bash
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           bash-4.2.8-2.fc15
Target RPM Packages           systemd-units-24-1.fc15
Policy RPM                    selinux-policy-3.9.16-14.fc15
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 2.6.38.2-9.fc15.x86_64 #1 SMP Wed Mar 30
                              16:55:57 UTC 2011 x86_64 x86_64
Alert Count                   1
First Seen                    Tue 12 Apr 2011 11:39:16 AM PDT
Last Seen                     Tue 12 Apr 2011 11:39:16 AM PDT
Local ID                      1da66864-5ac0-424c-bd72-be23833403f4

Raw Audit Messages
type=AVC msg=audit(1302633556.303:68): avc:  denied  { execute } for  pid=2165 comm="ck-system-stop" name="systemctl" dev=sdb6 ino=132937 scontext=system_u:system_r:consolekit_t:s0 tcontext=system_u:object_r:systemd_systemctl_exec_t:s0 tclass=file


type=SYSCALL msg=audit(1302633556.303:68): arch=x86_64 syscall=faccessat success=no exit=EACCES a0=ffffffffffffff9c a1=1248bd0 a2=1 a3=8 items=0 ppid=1 pid=2165 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=ck-system-stop exe=/bin/bash subj=system_u:system_r:consolekit_t:s0 key=(null)

Hash: ck-system-stop,consolekit_t,systemd_systemctl_exec_t,file,execute

audit2allow

#============= consolekit_t ==============
allow consolekit_t systemd_systemctl_exec_t:file execute;

audit2allow -R

#============= consolekit_t ==============
allow consolekit_t systemd_systemctl_exec_t:file execute;
Comment 1 Miroslav Grepl 2011-04-13 05:56:30 EDT
Fixed in selinux-policy-3.9.16-15.fc15

Thanks for testing.
Comment 2 Fedora Update System 2011-04-13 15:47:42 EDT
selinux-policy-3.9.16-15.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/selinux-policy-3.9.16-15.fc15
Comment 3 Fedora Update System 2011-04-13 20:34:20 EDT
Package selinux-policy-3.9.16-15.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.9.16-15.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/selinux-policy-3.9.16-15.fc15
then log in and leave karma (feedback).
Comment 4 Dan Beard 2011-04-15 10:48:50 EDT
*** Bug 696800 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2011-04-15 17:31:04 EDT
selinux-policy-3.9.16-15.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Christoph Wickert 2011-04-16 19:46:08 EDT
*** Bug 696796 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.