This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 696796 - XFCE logs out instead of rebooting
XFCE logs out instead of rebooting
Status: CLOSED DUPLICATE of bug 695818
Product: Fedora
Classification: Fedora
Component: xfce-utils (Show other bugs)
15
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F15Blocker-xfce
  Show dependency treegraph
 
Reported: 2011-04-14 16:35 EDT by Piscium
Modified: 2011-04-26 03:09 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-16 19:46:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Piscium 2011-04-14 16:35:02 EDT
Description of problem:

In XFCE, if on the panel I click on the green man icon, and then choose Restart, the session is logged out and comes back to lxdm screen, instead of restarting.

I am filing this against xfce-utils but I don't really know which Xfce module has the issue, probably the plugin that handles logout/restart/shutdown.

Probably the issue is in the interface between XFCE and lxdm as in previous Fedora versions XFCE used gdm.


Version-Release number of selected component (if applicable):

Beta - RC2 


How reproducible:

Always


Steps to Reproduce:
1. See descriptioin
2.
3.
  
Actual results:


Expected results:

Reboot!

Additional info:
Comment 1 Kevin Fenzi 2011-04-14 17:18:33 EDT
This may be related to bug 693152

Can you duplicate it with gdm? We switched back to gdm, but it was too late for the beta. 

I'm not sure if this is a lxdm issue or what. Testing gdm and confirming it there would let us know it's something deeper.
Comment 2 Piscium 2011-04-14 18:56:13 EDT
OK, so I did a yum update a short while ago, then tested and made sure I could still reproduce the reported issue.

The next step was to install gdm as you suggested, then switched the default display manager to gdm. After starting a XFCE session with gdm, when I clicked on the green man and chose Restart the computer did reboot.

Conclusion: the problem is solved by using gdm.

Feel free to close the issue if you want.

On the other hand it would be a good idea to see if one can reboot from within LXDE using lxdm, but I have no time to test that today.
Comment 3 hobgoblin 2011-04-15 06:43:01 EDT
(In reply to comment #1)
> This may be related to bug 693152
> 
> Can you duplicate it with gdm? We switched back to gdm, but it was too late for
> the beta. 
> 
> I'm not sure if this is a lxdm issue or what. Testing gdm and confirming it
> there would let us know it's something deeper.

I followed this, installed gdm and switched the display manager to gdm.

However I still see the issue using gdm.

Restart appears to only logout.
Comment 4 Piscium 2011-04-16 03:26:58 EDT
So yes, it was premature of me to suggest the closing of this bug. 

I have done further tests and sometimes the Restart button in GDM does restart and sometimes it just logs out. Unfortunately I have not been able to find a set of actions that would consistently reproduce the bug, in spite of putting some effort into it.

This bug may or may not be related to membership in the wheel group.
Comment 5 Piscium 2011-04-16 03:45:23 EDT
> I have done further tests and sometimes the Restart button in GDM does restart
> and sometimes it just logs out.

Clarification: "Restart button in GDM" means Restart button in XFCE using GDM as the display manager.
Comment 6 rvcsaba 2011-04-16 19:26:14 EDT
This bug is duplicated? See #695818, #696800.
Comment 7 Christoph Wickert 2011-04-16 19:46:08 EDT
Yes, it's a duplicate of bug 695818. Run 'setenforce 0' as root before trying to shutdown and it will work, so it's definitely SELinux.

*** This bug has been marked as a duplicate of bug 695818 ***
Comment 8 Piscium 2011-04-17 08:35:34 EDT
(In reply to comment #7)
> Yes, it's a duplicate of bug 695818. Run 'setenforce 0' as root before trying
> to shutdown and it will work, so it's definitely SELinux.
> 
> *** This bug has been marked as a duplicate of bug 695818 ***

Hmm, I am not sure if I am missing something. Bug 695818 is fixed and in the repos for several days, my F15 system is up-to-date, and yet I could reproduce the issue a few minutes ago. 

I also clicked on Shutdown after clicking on the green man, and it was as for Restart, it just logged out.

Also if this issue was SELinux related, should one not expect it to be consistently reproducible? (It is not.)
Comment 9 Christoph Wickert 2011-04-17 09:24:01 EDT
(In reply to comment #8)
> Bug 695818 is fixed and in the repos for several days, my F15 system is 
> up-to-date, and yet I could reproduce the issue a few minutes ago. 

selinux-policy-3.9.16-15.fc15 was pushed out to the stable repo just yesterday and needs to reach the mirrors first. Can you please check if you already have it?

> Also if this issue was SELinux related, should one not expect it to be
> consistently reproducible? (It is not.)

For me it is. Did you try using setenforce as mentioned in comment 7?
Comment 10 Piscium 2011-04-17 09:53:50 EDT
(In reply to comment #9)

> selinux-policy-3.9.16-15.fc15 was pushed out to the stable repo just yesterday
> and needs to reach the mirrors first. Can you please check if you already have
> it?

I have updates-testing enabled. My yum.log tells me that selinux-policy-3.9.16-15.fc15 was installed on Apr 14 23:30 (I am in Ireland which currently is at UTC + 1).

> For me it is. Did you try using setenforce as mentioned in comment 7?

No I didn't, but I just looked at the SELinux log and there wasn't any denial that looked like it could be related to this issue.
Comment 11 Piscium 2011-04-17 11:05:56 EDT
I logged in to F15 and tried "setenforce 0" and it made no difference, that is, just as with "setenforce 1", sometimes Restart would work and sometimes not.

This issue may be hardware related, or else manifest only on particular PCs, as it seems that only two people have it (me and  hobgoblin), and likely dozens are running F15 XFCE spin. 

hobgoblin has a 64 bits PC, so this is not 32 bits specific.
Comment 12 Shams Linux 2011-04-26 02:34:47 EDT
I downloaded and installed F15 XFCE on Apr 25. I'm facing this issue too.
Comment 13 hobgoblin 2011-04-26 03:09:50 EDT
Have you updated?

It appears to have been sorted after update to xfce4-session-4.8.1-4

This bug apparently - #693152

Note You need to log in before you can comment on or make changes to this bug.