Bug 696971 - grubby not updating arguments for all kernels when --update-kernel=ALL is used
Summary: grubby not updating arguments for all kernels when --update-kernel=ALL is used
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mkinitrd
Version: 5.5
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: 5.8
Assignee: Brian Lane
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks: 719046 726828 668957 758797
TreeView+ depends on / blocked
 
Reported: 2011-04-15 13:05 UTC by Christian Horn
Modified: 2018-11-27 21:40 UTC (History)
5 users (show)

Fixed In Version: mkinitrd-5.1.19.6-73
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-21 05:34:03 UTC
Target Upstream Version:


Attachments (Terms of Use)
Patch (1.96 KB, patch)
2011-04-18 20:36 UTC, Brian Lane
no flags Details | Diff
Test patch (1.89 KB, patch)
2011-04-18 20:36 UTC, Brian Lane
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0157 normal SHIPPED_LIVE mkinitrd bug fix update 2012-02-20 14:54:17 UTC

Description Christian Horn 2011-04-15 13:05:35 UTC
Description of problem: 
   grubby does not not update the arguments for all kernels 
   when --update-kernel=ALL is used

Version-Release number of selected component (if applicable):
   grubby-7.0.15-2.el6 (earlier and later versions show the same behaviour)

How reproducible:
   always

Steps to Reproduce:
1. cat >grubtest<<EOT
default=0
timeout=5
title Red Hat Enterprise Linux (2.6.32-71.el6.x86_64)
 root (hd0,0)
 kernel /vmlinuz-2.6.32-71.el6.x86_64 ro root=/dev/mapper/vg_rhel6-lv_root
 initrd /initramfs-2.6.32-71.el6.x86_64.img
title Red Hat Enterprise Linux (2.6.50-71.el6.x86_64)
 root (hd0,0)
 kernel /vmlinuz-2.6.50-71.el6.x86_64 ro root=/dev/mapper/vg_rhel6-lv_root
 initrd /initramfs-2.6.50-71.el6.x86_64.img
EOT

2. # setting an attribute initially for all kernels works
   grubby -c grubtest --update-kernel=ALL --args='option=0'
3. # changing the attribute now works only for the first kernel
   grubby -c grubtest --update-kernel=ALL --args='option=1'
4. grubby -c grubtest --info=ALL|grep ^args

Actual results:
args="ro option=1"
args="ro option=0"

Expected results:
args="ro option=1"
args="ro option=1"


Additional info:

Comment 1 Brian Lane 2011-04-18 20:36:08 UTC
Created attachment 493002 [details]
Patch

Comment 2 Brian Lane 2011-04-18 20:36:39 UTC
Created attachment 493003 [details]
Test patch

Comment 3 Christian Horn 2011-04-19 07:40:40 UTC
Verified the patch, fixes the problem

Comment 4 RHEL Program Management 2011-08-05 12:32:04 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 6 Jan Stodola 2012-01-02 09:57:22 UTC
Test:
[root@chicken ~]# cat >grubtest<<EOT
> default=0
> timeout=5
> title Red Hat Enterprise Linux (2.6.32-71.el6.x86_64)
>  root (hd0,0)
>  kernel /vmlinuz-2.6.32-71.el6.x86_64 ro root=/dev/mapper/vg_rhel6-lv_root
>  initrd /initramfs-2.6.32-71.el6.x86_64.img
> title Red Hat Enterprise Linux (2.6.50-71.el6.x86_64)
>  root (hd0,0)
>  kernel /vmlinuz-2.6.50-71.el6.x86_64 ro root=/dev/mapper/vg_rhel6-lv_root
>  initrd /initramfs-2.6.50-71.el6.x86_64.img
> EOT
[root@chicken ~]# grubby -c grubtest --update-kernel=ALL --args='option=0'
[root@chicken ~]# grubby -c grubtest --update-kernel=ALL --args='option=1'
[root@chicken ~]# grubby -c grubtest --info=ALL|grep ^args


Results with RHEL-5.7 (mkinitrd-5.1.19.6-71.el5):
args="ro option=1"
args="ro option=0"

Correct results with RHEL-5.8 Snapshot 2 (mkinitrd-5.1.19.6-75.el5):
args="ro option=1"
args="ro option=1"


Moving to VERIFIED

Comment 7 errata-xmlrpc 2012-02-21 05:34:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0157.html


Note You need to log in before you can comment on or make changes to this bug.