Bug 697187 - [abrt] gnome-screensaver-3.0.0-1.fc15: do_user_switch: Process /usr/libexec/gnome-screensaver-dialog was killed by signal 11 (SIGSEGV)
[abrt] gnome-screensaver-3.0.0-1.fc15: do_user_switch: Process /usr/libexec/g...
Status: CLOSED DUPLICATE of bug 698627
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
15
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
abrt_hash:df4142f1c4180491c4834bde47d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-16 10:59 EDT by Craig Robson
Modified: 2012-03-21 11:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-21 11:52:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: event_log (25.38 KB, text/plain)
2011-04-16 10:59 EDT, Craig Robson
no flags Details
File: smaps (115.37 KB, text/plain)
2011-04-16 10:59 EDT, Craig Robson
no flags Details
File: build_ids (3.84 KB, text/plain)
2011-04-16 10:59 EDT, Craig Robson
no flags Details
File: dsos (18.56 KB, text/plain)
2011-04-16 10:59 EDT, Craig Robson
no flags Details
File: maps (20.46 KB, text/plain)
2011-04-16 11:00 EDT, Craig Robson
no flags Details
File: backtrace (30.23 KB, text/plain)
2011-04-16 11:00 EDT, Craig Robson
no flags Details
abrt log and backtrace (11.43 KB, application/x-gzip)
2011-06-20 11:08 EDT, Norman Smith
no flags Details

  None (edit)
Description Craig Robson 2011-04-16 10:59:48 EDT
abrt version: 2.0.0
architecture: i686
executable: /usr/libexec/gnome-screensaver-dialog
component: gnome-screensaver
cmdline: /usr/libexec/gnome-screensaver-dialog --status-message= --enable-switch
crash_function: do_user_switch
kernel: 2.6.38.2-8.fc15.i686
reason: Process /usr/libexec/gnome-screensaver-dialog was killed by signal 11 (SIGSEGV)
uid: 5000
username: dj
package: gnome-screensaver-3.0.0-1.fc15
os_release: Fedora release 15 (Lovelock)
time: 1302961136
rating: 4

Text file: event_log, 25989 bytes
Text file: smaps, 118140 bytes
Text file: build_ids, 3936 bytes
Binary file: coredump, 27922432 bytes
Text file: dsos, 19002 bytes
Text file: maps, 20952 bytes
Text file: backtrace, 30952 bytes
Comment 1 Craig Robson 2011-04-16 10:59:52 EDT
Created attachment 492600 [details]
File: event_log
Comment 2 Craig Robson 2011-04-16 10:59:55 EDT
Created attachment 492601 [details]
File: smaps
Comment 3 Craig Robson 2011-04-16 10:59:56 EDT
Created attachment 492602 [details]
File: build_ids
Comment 4 Craig Robson 2011-04-16 10:59:58 EDT
Created attachment 492603 [details]
File: dsos
Comment 5 Craig Robson 2011-04-16 11:00:00 EDT
Created attachment 492604 [details]
File: maps
Comment 6 Craig Robson 2011-04-16 11:00:02 EDT
Created attachment 492605 [details]
File: backtrace
Comment 7 Matt 2011-04-25 21:32:17 EDT
Package: gnome-screensaver-3.0.0-1.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


How to reproduce
-----
Install of Fedora 12 upgraded to 15
Comment 8 Norman Smith 2011-06-20 11:08:59 EDT
Created attachment 505634 [details]
abrt log and backtrace

The following may be related and exists after a new install of F15.

Assume two users.

1.  Log in as user1.
2.  Switch to and log in as user2.
3.  Lock screen as user2.
4.  At screen saver dialog, switch user.
5.  Log in as already logged in user1.
6.  Log out user1.
7.  Log in as already logged in user2.
8.  Crash.

Sometimes you may see a flash of the screen saver dialog just as login completes.  Sometimes the gnome shell for user2 does not respond to input from keyboard or mouse.  Sometimes  you a black screen when logging out after the crash.

It occurs whether you lock the screen manually or allow it to time-out and lock.

I changed all my passwords that may be in the attached file.
Comment 9 Fedora Admin XMLRPC Client 2011-06-21 11:56:08 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 10 Fedora Admin XMLRPC Client 2011-06-21 11:59:23 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 11 abrt-bot 2012-03-21 11:52:47 EDT
Backtrace analysis found this bug to be similar to bug #698627, closing as duplicate.

Bugs which were found to be similar to this bug: bug #683771, bug #684515, bug #692612, bug #698627

This comment is automatically generated.

*** This bug has been marked as a duplicate of bug 698627 ***

Note You need to log in before you can comment on or make changes to this bug.