Bug 697530 - [RFE] Provide SciPy
[RFE] Provide SciPy
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: scipy (Show other bugs)
6.1
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Tomas Tomecek
Martin Kyral
: FutureFeature, Triaged
Depends On: 844974
Blocks: 782183 840699 858805
  Show dependency treegraph
 
Reported: 2011-04-18 10:26 EDT by Stanislav Ochotnicky
Modified: 2013-02-21 05:52 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Release Note
Doc Text:
New SciPy Package Red Hat Enterprise Linux 6.4 includes a new scipy package. The SciPy package provides software for mathematics, science, and engineering. The NumPy package, which is designed to manipulate large multi-dimensional arrays of arbitrary records, is the core library for SciPy. The SciPy library is built to work with NumPy arrays and provides various efficient numerical routines, for example routines for numerical integration and optimization.
Story Points: ---
Clone Of:
: 858805 (view as bug list)
Environment:
Last Closed: 2013-02-21 03:46:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 40470 None None None Never

  None (edit)
Description Stanislav Ochotnicky 2011-04-18 10:26:15 EDT
Description of problem:
Current release of RHEL 6.x contains NumPy package but no SciPy package. SciPy package is closely tied to NumPy package and it depends on certain NumPy version to work. These projects are developed and maintained together upstream at http://numpy.org/

Adding SciPy to main distribution would create more closely tied relationship while making sure SciPy always works.
Comment 1 J.H.M. Dassen (Ray) 2011-05-18 05:38:56 EDT
What is the nature and description of the request?
   Customer seeks the inclusion of ipython and scipy in the official RHEL 6.x
repository

Why does the customer need this? (List the business requirements here)
   Customer uses RHEL6 in a workstation environment and does a lot of numerical
calculations. They I need to compile and install ipython, and scipy from the
source rpms available for Fedora 12 on each machine that they use. Scipy and
ipython for RHEL 6.x have recently been added to the EPEL repository, but since
RHEL6 presently includes numpy, the customer would rather bring them into RHEL
so that they could be maintained and upgraded together. From the customer: "The
combination of numpy, python-matplotlib, ipython, and scipy make an excellent
free software replacement for the commercial MATLAB package.:

How would the customer like to achieve this? (List the functional requirements
here)
   Include a version of the scipy and ipython packages in the official RHEL
repository as opposed to Fedora or EPEL repositories

For each functional requirement listed in question 4, specify how Red Hat and
the customer can test to confirm the requirement is successfully implemented.
   Downloading and installing the effected packages via yum or rpm without
using EPEL

Is there already an existing RFE upstream or in Red Hat bugzilla?
   No

How quickly does this need resolved? (desired target release)
   Next service pack release if possible

Does this request meet the RHEL Bug and Feature Inclusion Criteria (please
review)
   Yes

List the affected packages
   ipython, scipy

Would the customer be able to assist in testing this functionality if
implemented?
   Yes
Comment 3 RHEL Product and Program Management 2011-07-05 20:47:49 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 5 Suzanne Yeghiayan 2012-01-31 16:18:30 EST
This request was evaluated by Red Hat Product Management for inclusion in the
current release of Red Hat Enterprise Linux. Because the affected component is
not scheduled to be updated in the current release, Red Hat is unfortunately
unable to address this request at this time.  It has been proposed for the next
release. If you would like it considered as an exception in the current
release, please ask your support representative.
Comment 11 Ludek Smid 2012-07-10 11:17:25 EDT
This request was erroneously removed from consideration in
Red Hat Enterprise Linux 6.4, which is currently under
development.  This request will be evaluated for inclusion
in Red Hat Enterprise Linux 6.4.
Comment 24 errata-xmlrpc 2013-02-21 03:46:51 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-0341.html

Note You need to log in before you can comment on or make changes to this bug.