Bug 698151 - Remove documentation for "order" keyword in /etc/host.conf manpage
Remove documentation for "order" keyword in /etc/host.conf manpage
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: man-pages-overrides (Show other bugs)
6.0
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Peter Schiffer
BaseOS QE - Apps
: ManPageChange
Depends On: 698149
Blocks: 698153 699701 714078 743047
  Show dependency treegraph
 
Reported: 2011-04-20 06:21 EDT by Siddhesh Poyarekar
Modified: 2015-09-13 20:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The host.conf(5) manual page contained a description for the unsupported "order" keyword. With this update, the description of the "order" keyword is removed.
Story Points: ---
Clone Of: 698149
: 698153 714078 (view as bug list)
Environment:
Last Closed: 2011-12-06 06:46:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Siddhesh Poyarekar 2011-04-20 06:21:43 EDT
+++ This bug was initially created as a clone of Bug #698149 +++

Description of problem:

glibc has been ignoring the "order" keyword in /etc/host.conf for some years now, but the manpage for host.conf still documents the option without mentioning that it does not do anything any more.

The order keyword support was removed in the following commit upstream:

http://sourceware.org/git/?p=glibc.git;a=commitdiff;h=b9c65d0902e5890c4f025b574725154032f8120a

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. man host.conf
2.
3.
  
Actual results:
man page has information for the "order" keyword

Expected results:
man page should not have information for the "order" keyword or at least mention that the keyword does not do anything and that one needs to use /etc/nsswitch.conf now for this functionality.

Additional info:
Comment 4 Eliska Slobodova 2011-09-29 07:13:38 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The host.conf(5) manual page contained a description for the unsupported "order" keyword. With this update, the description of the "order" keyword is removed.
Comment 5 errata-xmlrpc 2011-12-06 06:46:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1571.html

Note You need to log in before you can comment on or make changes to this bug.