This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 699701 - Remove documentation for "order" keyword in /etc/host.conf manpage
Remove documentation for "order" keyword in /etc/host.conf manpage
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: man-pages (Show other bugs)
5.5
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Peter Schiffer
BaseOS QE - Apps
: ManPageChange
Depends On: 698149 698151 698153 714078
Blocks: 749319
  Show dependency treegraph
 
Reported: 2011-04-26 08:14 EDT by Ivana Varekova
Modified: 2013-04-15 05:13 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 698153
Environment:
Last Closed: 2011-11-21 02:20:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ivana Varekova 2011-04-26 08:14:24 EDT
+++ This bug was initially created as a clone of Bug #698153 +++

+++ This bug was initially created as a clone of Bug #698151 +++

+++ This bug was initially created as a clone of Bug #698149 +++

Description of problem:

glibc has been ignoring the "order" keyword in /etc/host.conf for some years now, but the manpage for host.conf still documents the option without mentioning that it does not do anything any more.

The order keyword support was removed in the following commit upstream:

http://sourceware.org/git/?p=glibc.git;a=commitdiff;h=b9c65d0902e5890c4f025b574725154032f8120a

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. man host.conf
2.
3.
  
Actual results:
man page has information for the "order" keyword

Expected results:
man page should not have information for the "order" keyword or at least mention that the keyword does not do anything and that one needs to use /etc/nsswitch.conf now for this functionality.

Additional info:

--- Additional comment from pm-rhel@redhat.com on 2011-04-20 06:22:23 EDT ---

Since this issue was entered in bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 1 Brian Gollaher 2011-09-02 12:35:20 EDT
Moving to 5.9.
Comment 5 errata-xmlrpc 2011-11-21 02:20:07 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1461.html

Note You need to log in before you can comment on or make changes to this bug.