This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 698153 - Remove documentation for "order" keyword in /etc/host.conf manpage
Remove documentation for "order" keyword in /etc/host.conf manpage
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: man-pages-overrides (Show other bugs)
5.5
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Ivana Varekova
: ManPageChange
Depends On: 698149 698151 714078
Blocks: 699701
  Show dependency treegraph
 
Reported: 2011-04-20 06:25 EDT by Siddhesh Poyarekar
Modified: 2015-09-13 20:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The unsupported keyword "order" has been removed from the host.conf(5) manual page.
Story Points: ---
Clone Of: 698151
: 699701 (view as bug list)
Environment:
Last Closed: 2011-07-21 03:37:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Siddhesh Poyarekar 2011-04-20 06:25:29 EDT
+++ This bug was initially created as a clone of Bug #698151 +++

+++ This bug was initially created as a clone of Bug #698149 +++

Description of problem:

glibc has been ignoring the "order" keyword in /etc/host.conf for some years now, but the manpage for host.conf still documents the option without mentioning that it does not do anything any more.

The order keyword support was removed in the following commit upstream:

http://sourceware.org/git/?p=glibc.git;a=commitdiff;h=b9c65d0902e5890c4f025b574725154032f8120a

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. man host.conf
2.
3.
  
Actual results:
man page has information for the "order" keyword

Expected results:
man page should not have information for the "order" keyword or at least mention that the keyword does not do anything and that one needs to use /etc/nsswitch.conf now for this functionality.

Additional info:

--- Additional comment from pm-rhel@redhat.com on 2011-04-20 06:22:23 EDT ---

Since this issue was entered in bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 3 Miroslav Svoboda 2011-07-15 12:39:35 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The unsupported keyword "order" has been removed from the host.conf(5) manual page.
Comment 4 errata-xmlrpc 2011-07-21 03:37:45 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-1009.html

Note You need to log in before you can comment on or make changes to this bug.