Bug 699099 - (telepathyunlabeled) Empathy starts with error message: Failed to execute program /usr/libexec/mission-control-5
Empathy starts with error message: Failed to execute program /usr/libexec/mis...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
15
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
:
: 699012 699150 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-23 01:53 EDT by Fred
Modified: 2011-04-25 09:56 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-25 09:30:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Fred 2011-04-23 01:53:08 EDT
Description of problem:
Empathy starts with the following error message preventing to access the accounts information:
"Failed to access account manager: Failed to
execute program /usr/libexec/mission-control-5: Success"

Version-Release number of selected component (if applicable):
selinux-policy-3.9.16-16.fc15.noarch

How reproducible:
always

Steps to Reproduce:
1. launch empathy
  
Actual results:
Error message at launch, accounts are unavailable

Expected results:
Empathy should start normally

Additional info:
It happened after a selinux-policy update. Happens on 3 different machines.
avc for 2 machines here: http://fpaste.org/HvxQ/ and here: http://fpaste.org/71VI/

Fixed using information in F13 bug: https://bugzilla.redhat.com/show_bug.cgi?id=616506
Comment 1 Yusuf Ma 2011-04-23 02:55:29 EDT
Confirm this bug.
Comment 2 Fred 2011-04-23 05:19:09 EDT
I was told on #fedora-test that su -c 'fixfiles -R -a restore; reboot;' should also fix this. The person is also convinced "I did something" as the error is due to "unlabeled_t" which is unlabeled files (a start with SELinux disabled?). However one of the machine is a fresh install from LiveCD updated once on Friday (no problem) and once on Saturday (the issue arose). Nothing else was done on that machine.

Fred
Comment 3 Onyeibo 2011-04-24 05:51:59 EDT
(In reply to comment #2)
> I was told on #fedora-test that su -c 'fixfiles -R -a restore; reboot;' should
> also fix this. The person is also convinced "I did something" as the error is
> due to "unlabeled_t" which is unlabeled files (a start with SELinux disabled?).
> Fred

Well, that doesn't solve the problem for me.  I still get the message after running fixfiles.
Comment 4 Josef 2011-04-24 07:08:23 EDT
chcon -t bin_t /usr/libexec/mission-control*  /usr/libexec/telepathy*

fixes it for me, taken from https://bugzilla.redhat.com/show_bug.cgi?id=616506#c5.
Comment 5 Pavel Šimerda (pavlix) 2011-04-24 15:06:44 EDT
I was updating a Fedora 15 alpha/beta/whatever installation and it also happend after some update, with no other action involved.

The command above fixes it for me too.
Comment 6 Pavel Šimerda (pavlix) 2011-04-24 15:08:18 EDT
Is there any valid reason to display an error message saying “success”?
Comment 7 Daniel Walsh 2011-04-25 09:30:21 EDT
We turned off the transition from unconfined_t to telepathy confined domains, which broke running telepathy sessions.  If you just killall telepathy sessions and restart, or log out and back in, it should fix the problems.

Sadly we can not fix this problem cleanly on a running F15 Beta system, it will not be seen on fresh installs of the next F15 release.
Comment 8 Daniel Walsh 2011-04-25 09:33:59 EDT
Pavel Not sure where you are seeing success, but the kernel is reporting whether the syscall completed successfully.  The kernel can generate an AVC and have the syscall succeed, This can happen if the syscall went down a different path and worked, or if the machine is in permissive mode or the process is in permissive mode.
Comment 9 Daniel Walsh 2011-04-25 09:38:18 EDT
*** Bug 699012 has been marked as a duplicate of this bug. ***
Comment 10 Daniel Walsh 2011-04-25 09:52:35 EDT
*** Bug 699150 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.