Bug 616506 - SELinux policy needs to be updated for telepathy/Empathy to work
Summary: SELinux policy needs to be updated for telepathy/Empathy to work
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy   
(Show other bugs)
Version: 13
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 614991 615749 616662 616747 616844 616936 617132 617213 617216 617295 617650 617737 617806 617859 617925 618113 618352 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-20 16:25 UTC by Matthew Booth
Modified: 2010-07-26 21:52 UTC (History)
28 users (show)

Fixed In Version: selinux-policy-3.7.19-39.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-23 02:27:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum.log of transaction which apparently resulted in empathy failure (5.85 KB, text/plain)
2010-07-21 12:02 UTC, Matthew Booth
no flags Details
transaction that apparently broke empathy (2.47 KB, text/plain)
2010-07-21 12:36 UTC, Renke Grunwald
no flags Details

Description Matthew Booth 2010-07-20 16:25:24 UTC
Description of problem:
Although I can launch empathy, it no longer displays any of my accounts. This worked this morning before a yum upgrade.

empathy-debugger displays:

publish_to_all_am_prepared_cb: Failed to prepare account manager: Failed to execute program /usr/libexec/mission-control-5: Success

If I execute this program directly and then run empathy my accounts show up but they all have a 'Network error. The output from mission control is:

mcd-Message: Failed to get item from keyring: No matching results
mcd-Message: Falling back to looking in the keyfile
...repeated many times...

(process:13597): mcd-WARNING **: request_connection_cb: RequestConnection failed: Failed to execute program /usr/libexec/telepathy-gabble: Success
...repeated for many telepathy backends...

If I then also run /usr/libexec/telepathy-idle from the command line and then try to reconnect to one of my IRC accounts, it works.

Version-Release number of selected component (if applicable):
empathy.x86_64                   2.30.2-3.fc13  @updates                        
telepathy-butterfly.noarch       0.5.12-1.fc13  @updates-testing                
telepathy-farsight.x86_64        0.0.13-1.fc13  @anaconda-InstallationRepo-201005190213.x86_64
telepathy-filesystem.noarch      0.0.2-1.fc12   @anaconda-InstallationRepo-201005190213.x86_64
telepathy-gabble.x86_64          0.9.11-2.fc13  @updates                        
telepathy-glib.x86_64            0.10.7-1.fc13  @updates-testing                
telepathy-haze.x86_64            0.3.3-2.fc13   @anaconda-InstallationRepo-201005190213.x86_64
telepathy-idle.x86_64            0.1.6-1.fc13   @anaconda-InstallationRepo-201005190213.x86_64
telepathy-mission-control.x86_64 1:5.4.3-1.fc13 @updates                        
telepathy-salut.x86_64           0.3.10-2.fc13  @anaconda-InstallationRepo-201005190213.x86_64

How reproducible:
Always

Comment 1 Brian Pepple 2010-07-20 23:03:13 UTC
Looking at your error msg it looks like tp-mission-control is failing to get your passwords from gnome-keyring, which in turn is causing the login to the appropriate connection manager to fail. I'm going to re-assign this to tp-mission-control since it looks like the problem lies there, and see if I can reproduce this locally to get some more info.

Comment 2 Rex Dieter 2010-07-20 23:51:35 UTC
fwiw, I saw similar symptoms (in the debugger) trying and failing to use empathy to setup a google-talk account for the first time today.  I'd get to the end of the new account wizard, click "accept", and nothing...

Comment 3 Matthew Booth 2010-07-21 12:02:48 UTC
Created attachment 433395 [details]
yum.log of transaction which apparently resulted in empathy failure

I've attached the yum.log showing all packages I updated between empathy working and not working. It was unfortunately quite a large transaction.

Comment 4 Renke Grunwald 2010-07-21 12:36:25 UTC
Created attachment 433402 [details]
transaction that apparently broke empathy

I have the same problems. The account wizard behaves strangely, no icon shows up in the notification and I can't connect with any existing account (they don't show up anyway).

I have attached the relevant portions of the yum.log file. The only common packaged (comparing to Matthews log file) that are related (as far as I can tell) to telepathy (or empathy, that is) are telepathy-butterfly and farsight.

Comment 5 Brian Pepple 2010-07-21 14:14:06 UTC
This bug is apparently being caused by selinux. According to D. Walsh, running this should fix it:

chcon -t bin_t /usr/libexec/mission-control*  /usr/libexec/telepathy*

Comment 6 Ankur Sinha (FranciscoD) 2010-07-21 14:18:42 UTC
hi,

Experienced the same thing. The above solution fixed it (apparently)

Ankur

Comment 7 Rex Dieter 2010-07-21 14:32:21 UTC
comment #5 fix confirmed mmm, mmm, good.

Comment 8 Matthew Booth 2010-07-21 14:40:21 UTC
fix confirmed here too. Should we move this to selinux-policy?

Comment 9 Brian Pepple 2010-07-21 14:45:51 UTC
(In reply to comment #8)
> fix confirmed here too. Should we move this to selinux-policy?    

Yeah, probably should.

Comment 10 Daniel Walsh 2010-07-21 15:21:03 UTC
Yes this is an SELinux issue.

Comment 11 Miroslav Grepl 2010-07-21 15:21:43 UTC
Fixed in selinux-policy-3.7.19-39.fc13

Comment 12 Fedora Update System 2010-07-21 15:34:00 UTC
selinux-policy-3.7.19-39.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/selinux-policy-3.7.19-39.fc13

Comment 13 Brian Pepple 2010-07-21 16:00:06 UTC
*** Bug 616844 has been marked as a duplicate of this bug. ***

Comment 14 Brian Pepple 2010-07-21 16:01:30 UTC
*** Bug 616662 has been marked as a duplicate of this bug. ***

Comment 15 Brian Pepple 2010-07-21 16:01:44 UTC
*** Bug 616747 has been marked as a duplicate of this bug. ***

Comment 16 Brian Pepple 2010-07-21 18:55:27 UTC
*** Bug 614991 has been marked as a duplicate of this bug. ***

Comment 17 Brian Pepple 2010-07-21 18:55:54 UTC
*** Bug 615749 has been marked as a duplicate of this bug. ***

Comment 18 Brian Pepple 2010-07-21 19:17:16 UTC
*** Bug 616936 has been marked as a duplicate of this bug. ***

Comment 19 Dawid Zamirski 2010-07-21 20:08:13 UTC
Hi,

I'm just wondering one thing - how come I was affected by this selinux issue when I have selinux set to permissive mode? Shouldn't it be just logged by the setrobleshooter and keep empathy running? Is selinux still blocking some stuff even when in permissive mode?

Regards

Comment 20 Rasmus Kaj 2010-07-22 07:58:05 UTC
Package: telepathy-mission-control-1:5.4.3-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Hava a jabber account configured in empthy-
2. Update to telepathy-mission-control-1:5.4.3-1.fc13 (and related packages of the same update time).
3. Log in.
4. Note there is a crash report and no way to get jabber connectivity.

Comment
-----
I ran the fedora 13 update as of 2010-07-21, after that all attempts to start empathy fails.  Sorry for lack of details here, I'll be happy to test run any suggestions and send in further details.

I tried to "setenforce 0", log out, log in, and I do get the same problem in selinux permissive mode.

Comment 21 Rasmus Kaj 2010-07-22 08:05:06 UTC
Comment #5 works for me to -- even though running in permissive mode didn't help.  Strange?

Comment 22 Bob 2010-07-22 10:21:11 UTC
Package: telepathy-mission-control-1:5.4.3-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.Start Empathy
2.Get segfault on mission-control; icon disappears in system tray
3.Empathy contact list stays open.


Comment
-----
First time, the system tray icon stayed for awhile, then crashed.  After that, it would seg fault as soon as Empathy was started.

Comment 23 Bryan Frechette 2010-07-22 11:21:51 UTC
Package: telepathy-mission-control-1:5.4.3-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.start empathy
2.
3.

Comment 24 Theophanis Kontogiannis 2010-07-22 13:49:43 UTC
Package: telepathy-mission-control-1:5.4.3-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


Comment
-----
Just loged into my account

Comment 25 Theophanis Kontogiannis 2010-07-22 13:52:03 UTC
Package: telepathy-mission-control-1:5.4.3-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


Comment
-----
Edit --> Accounts  and it crashed

Comment 26 Daniel Walsh 2010-07-22 13:54:56 UTC
    That sounds like a bug in dbus, not following permissive mode.  

    The problem that leaked into F13 was an update to telepathy policy for confined
    users. 

    A confined users starts telepathy/empathy through dbus session bus.  For
    unconfined_t we want to stay unconfined_t, but for staff_t we want to run in a
    confined mode.  The problem was transition was partially happening for
    unconfined_t, but the policy was not complete and dbus was refusing to
    transition to telepathy/empathy types.  When dbus sees the failure to
    transition it is supposed to check whether the system is in permissive mode and
    continue.

    By changing the labels on the executables to bin_t, the transition is no longer
    attempted.

    We will attempt to turn the complete policy on in Rawhide, and see if we can
    run a secure telepathy/empathy from unconfined_t.

Comment 27 Daniel Walsh 2010-07-22 13:56:01 UTC
yum update --enablerepo=updates-testing selinux-policy


And update karma if this fixes the problem.

Comment 28 Brian Pepple 2010-07-22 14:57:16 UTC
*** Bug 617213 has been marked as a duplicate of this bug. ***

Comment 29 Brian Pepple 2010-07-22 14:59:08 UTC
*** Bug 617216 has been marked as a duplicate of this bug. ***

Comment 30 Brian Pepple 2010-07-22 15:49:35 UTC
*** Bug 617132 has been marked as a duplicate of this bug. ***

Comment 31 Nuno Anjos 2010-07-22 16:30:11 UTC
Package: telepathy-mission-control-1:5.4.3-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.just connecting empathy
2. can't connect IM 
3.


Comment
-----
it's gotten worse!

Comment 32 Nuno Anjos 2010-07-22 16:54:20 UTC
sorry

got it working by doing:

chcon -t bin_t /usr/libexec/mission-control*  /usr/libexec/telepathy*

Comment 33 Brian Pepple 2010-07-22 17:23:46 UTC
*** Bug 617295 has been marked as a duplicate of this bug. ***

Comment 34 Anthony 2010-07-23 00:32:27 UTC
Package: telepathy-mission-control-1:5.4.3-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Update all packages.
2. Make SELinux permissible.
3. Try to run "buggy" Empathy Account Wizard (System->Preferences->Messaging and VOIP Accounts).


Comment
-----
First of all. I just installed Fedora 13 and updated it completely.

When I tried to use Empathy Wizard I was unable to complete the configuration of my MSN account. Empathy debug, Help Contents and the edit->accounts windows where not showing on Empathy. The Help one is giving the error "Unable to open URI Failed to fork (Cannot allocate memory)".

Then I changed SELinux to permissible and tried to open the Messaging and VOIP Accounts again giving me this error.

Comment 35 Brian Pepple 2010-07-23 00:40:39 UTC
(In reply to comment #34)
> -----
> First of all. I just installed Fedora 13 and updated it completely.
> 
> When I tried to use Empathy Wizard I was unable to complete the configuration
> of my MSN account. Empathy debug, Help Contents and the edit->accounts windows
> where not showing on Empathy. The Help one is giving the error "Unable to open
> URI Failed to fork (Cannot allocate memory)".
> 
> Then I changed SELinux to permissible and tried to open the Messaging and VOIP
> Accounts again giving me this error.    

Did you grab the updates selinux-policy in bodhi? If not, please read the earlier comments in this bug.

Comment 36 Anthony 2010-07-23 00:50:55 UTC
The chcon -t bin_t /usr/libexec/mission-control*  /usr/libexec/telepathy*
also worked for me.

Thanks

Comment 37 Fedora Update System 2010-07-23 02:26:49 UTC
selinux-policy-3.7.19-39.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 38 Brian Pepple 2010-07-23 17:05:22 UTC
*** Bug 617650 has been marked as a duplicate of this bug. ***

Comment 39 Brian Pepple 2010-07-23 21:26:45 UTC
*** Bug 617737 has been marked as a duplicate of this bug. ***

Comment 40 Brian Pepple 2010-07-24 15:27:05 UTC
*** Bug 617859 has been marked as a duplicate of this bug. ***

Comment 41 Peter Robinson 2010-07-26 21:51:39 UTC
*** Bug 617806 has been marked as a duplicate of this bug. ***

Comment 42 Peter Robinson 2010-07-26 21:51:47 UTC
*** Bug 617925 has been marked as a duplicate of this bug. ***

Comment 43 Peter Robinson 2010-07-26 21:51:58 UTC
*** Bug 618113 has been marked as a duplicate of this bug. ***

Comment 44 Peter Robinson 2010-07-26 21:52:04 UTC
*** Bug 618352 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.