Bug 701622 - libproxy.so.1: cannot open shared object file: No such file or directory
Summary: libproxy.so.1: cannot open shared object file: No such file or directory
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: lorax
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Gracik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker, AcceptedNTH
: 699474 702129 (view as bug list)
Depends On:
Blocks: F15-accepted, F15FinalFreezeExcept
TreeView+ depends on / blocked
 
Reported: 2011-05-03 12:00 UTC by James Laska
Modified: 2013-09-02 06:56 UTC (History)
10 users (show)

Fixed In Version: lorax-0.4.6-1.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-16 19:09:08 UTC
Type: ---


Attachments (Terms of Use)
Screenshot.png (4.75 KB, image/png)
2011-05-10 12:41 UTC, James Laska
no flags Details

Description James Laska 2011-05-03 12:00:08 UTC
Description of problem:

When initiating a VNC install of F15-Final-TC1, I get a library missing error on the console.  It appears a library is missing from the install image, or an existing library developed a new dependency that isn't be tracked/followed by lorax during tree compose.

Version-Release number of selected component (if applicable):
 * anaconda-15.30-1

How reproducible:
 * 100%

Steps to Reproduce:
1. Follow instructions at https://fedoraproject.org/wiki/QA:Testcase_Anaconda_User_Interface_VNC
2. Choose no password
  
Actual results:

11:45:01 Please manually connect your vnc client to test1247.test.redhat.com:1 (10.10.10.247) to begin the install.
Press <enter> for a shell
11:45:01 Starting graphical installation.
libproxy.so.1: cannot open shared object file: No such file or directory
Failed to load module: /usr/lib64/gio/modules/libgiolibproxy.so


Expected results:

No module load errors while attempting to install

Additional info:

 * Raising as a release blocker ... having this error display on every install looks bad.  I'm not yet aware of specific functionality that is blocked by the presence of this missing library, perhaps proxy ... which would represent a significant regression during installation.

Comment 1 Martin Gracik 2011-05-03 13:36:56 UTC
We are removing the libproxy package from the ramdisk, because it was not needed before. Trivial fix this is. Will only make the ramdisk a bit bigger, nothing else should be affected.

Comment 2 Fedora Update System 2011-05-03 14:19:58 UTC
lorax-0.4.5-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/lorax-0.4.5-1.fc15

Comment 3 Brian Lane 2011-05-03 19:00:48 UTC
*** Bug 699474 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2011-05-05 04:45:08 UTC
Package lorax-0.4.5-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lorax-0.4.5-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/lorax-0.4.5-1.fc15
then log in and leave karma (feedback).

Comment 5 Martin Gracik 2011-05-05 07:05:05 UTC
*** Bug 702129 has been marked as a duplicate of this bug. ***

Comment 6 Tim Flink 2011-05-06 18:28:22 UTC
Discussed in the 2011-05-06 blocker review meeting. Rejected as F15 final blocker as it does not clearly hit any release criteria. Accepted as NTH since it would be nice to fix the error message and a fix is already available.

Comment 7 James Laska 2011-05-10 12:41:55 UTC
Created attachment 497997 [details]
Screenshot.png

The original bug is fixed, but I'm now seeing a new missing library.  See attached screenshot (libmodman.so.1).

Comment 8 Fedora Update System 2011-05-10 15:19:06 UTC
lorax-0.4.6-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/lorax-0.4.6-1.fc15

Comment 9 James Laska 2011-05-10 18:58:14 UTC
Confirmed fix using a custom-built boot.iso using lorax-0.4.6-1.fc15

Comment 10 Fedora Update System 2011-05-11 05:50:12 UTC
Package lorax-0.4.6-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lorax-0.4.6-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/lorax-0.4.6-1.fc15
then log in and leave karma (feedback).

Comment 11 Mike C 2011-05-12 07:00:12 UTC
I have been seeing this using a personal DVD iso build from the f15 devel repo - the DVD iso was written to a usb key using livecd-iso-to-disk - and then a straightforward install attempted. I see exactly the same symptoms as reported above.

I hope that the new lorax build will be pushed to stable as soon as possible so that I can test a new build to see if my case is fixed also.

Comment 12 James Laska 2011-05-12 12:21:00 UTC
Fixed for me in RC1.

Comment 13 Fedora Update System 2011-05-16 19:08:57 UTC
lorax-0.4.6-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.