Bug 702480 - [abrt] sugar-browse-120-3.fc15: activitybundle.py:70:__init__:MalformedBundleException: No activity.info file
[abrt] sugar-browse-120-3.fc15: activitybundle.py:70:__init__:MalformedBundle...
Status: CLOSED DUPLICATE of bug 697689
Product: Fedora
Classification: Fedora
Component: sugar-browse (Show other bugs)
15
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Simon Schampijer
Fedora Extras Quality Assurance
abrt_hash:0d1abe14ccc611aafa9db17f616...
:
Depends On:
Blocks: F15Blocker-sugar
  Show dependency treegraph
 
Reported: 2011-05-05 15:28 EDT by Adam Williamson
Modified: 2011-06-07 18:33 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-07 18:33:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (953 bytes, text/plain)
2011-05-05 15:28 EDT, Adam Williamson
no flags Details

  None (edit)
Description Adam Williamson 2011-05-05 15:28:07 EDT
abrt version: 2.0.1
comment: Tried to launch Browse activity within Sugar.
executable: /usr/share/sugar/activities/Browse.activity/setup.py
component: sugar-browse
architecture: x86_64
kernel: 2.6.38.4-20.fc15.x86_64
reason: activitybundle.py:70:__init__:MalformedBundleException: No activity.info file
uid: 500
username: test
package: sugar-browse-120-3.fc15
os_release: Fedora release 15 (Lovelock)
time: 1304623541

event_log
-----
2011-05-05-12:26:52> Logging into Bugzilla at https://bugzilla.redhat.com
2011-05-05-12:26:52  Can't login. Server said: libcurl failed to execute the HTTP POST transaction, explaining:  Could not resolve host: bugzilla.redhat.com; Connection refused
2011-05-05-12:26:52* (exited with 1)

backtrace
-----
activitybundle.py:70:__init__:MalformedBundleException: No activity.info file

Traceback (most recent call last):
  File "/usr/share/sugar/activities/Browse.activity/setup.py", line 21, in <module>
    bundlebuilder.start()
  File "/usr/lib/python2.7/site-packages/sugar/activity/bundlebuilder.py", line 421, in start
    config = Config()
  File "/usr/lib/python2.7/site-packages/sugar/activity/bundlebuilder.py", line 81, in __init__
    self.update()
  File "/usr/lib/python2.7/site-packages/sugar/activity/bundlebuilder.py", line 84, in update
    self.bundle = bundle = ActivityBundle(self.source_dir)
  File "/usr/lib/python2.7/site-packages/sugar/bundle/activitybundle.py", line 70, in __init__
    raise MalformedBundleException('No activity.info file')
MalformedBundleException: No activity.info file

Local variables in innermost frame:
path: '/home/test'
self: <sugar.bundle.activitybundle.ActivityBundle object at 0x20a6350>
info_file: None
Comment 1 Adam Williamson 2011-05-05 15:28:09 EDT
Created attachment 497207 [details]
File: backtrace
Comment 2 Adam Williamson 2011-05-05 15:31:32 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Adam Williamson 2011-05-05 15:32:11 EDT
Proposed as NTH (via Sugar blocker): clear criteria breakage in non-blocking desktop (Sugar).



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Tim Flink 2011-05-06 15:28:25 EDT
Discussed in the 2011-05-06 blocker review meeting. Accepted as NTH because it violates the following alpha release criteria [1] for Sugar:

It must be possible to run the default web browser and a terminal application from the default desktop environment. The web browser must be able to download files, load extensions, and log into FAS.

[1] https://fedoraproject.org/wiki/Fedora_15_Alpha_Release_Criteria
Comment 5 Simon Schampijer 2011-06-06 04:29:16 EDT
I do not fully understand what you did. You were not able to start Browse by clicking on the icon in the Home View?
Comment 6 Adam Williamson 2011-06-06 12:45:34 EDT
That's correct. Just tried to launch it, on a clean SoaS live image.
Comment 7 Peter Robinson 2011-06-07 18:33:50 EDT
This is a problem because hulahop hasn't been ported to XULRunner 2

*** This bug has been marked as a duplicate of bug 697689 ***

Note You need to log in before you can comment on or make changes to this bug.