Bug 70254 - limbo2: xmms doesn't output sound by default
Summary: limbo2: xmms doesn't output sound by default
Status: CLOSED DUPLICATE of bug 71397
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: xmms   
(Show other bugs)
Version: limbo
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
: 72238 (view as bug list)
Depends On:
Blocks: 67218
TreeView+ depends on / blocked
 
Reported: 2002-07-31 10:57 UTC by Marius Andreiana
Modified: 2014-03-17 02:29 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-23 06:28:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Marius Andreiana 2002-07-31 10:57:22 UTC
The default output plugin (in gnome) is esound. It doesn't output any sound when
playing (the vu-meter works though). I switched to OSS driver and I've got sound
too.

Please make it work with the default output plugin.

Comment 1 petrosyan 2002-07-31 14:46:08 UTC
I would actually suggest to use OSS as the default plugin because:

1. I like OSS better than esound.
2. KDE users are not gonna have esound running
3. OSS should satisfy GNOME and KDE users simultaneously

Comment 2 David L. Parsley 2002-08-02 20:23:25 UTC
Try going into your desktop preferences, sound, and enable sound server startup,
then log out & back in.  I noticed the same problem, and esd was running, but
when I checked sound-server-startup it mysteriously worked.  This is probably a
bug in esd, I'll check into it early next week.

Comment 3 Marius Andreiana 2002-08-03 07:20:52 UTC
I want it to work from the very first time, with no other tweaking.

Install redhat, start gnome, start xmms, listen to music.

Comment 4 Warren Togami 2002-08-12 22:50:46 UTC
Umm... if OSS plugin were set as XMMS default, wouldn't that break both GNOME
and KDE?

GNOME takes over the OSS sound device completely with the esd sound daemon.  KDE
does the same with artsd.  This means no other program can use the device,
except during periods in which esd or artsd was idle for a while and it gives up
control of the OSS device.

Of course, OSS works for you in Limbo because esd doesn't enable itself by
default  (another bug).

I think the real fix here would be XMMS should somehow *detect* if artsd or esd
is running, and use the appropriate sound plugin.  Is this possible?


Comment 5 Bill Nottingham 2002-08-23 01:14:40 UTC
*** Bug 72238 has been marked as a duplicate of this bug. ***

Comment 6 Dax Kelson 2002-08-23 06:28:09 UTC
On a fresh install of Null, esd is in fact running: 
 
esd -terminate -nobeeps -as 2 -spawnfd 9 
 
But EVEN THOUGH it is running, XMMS using the esound output plugin produces no 
sound. 
 
If I killall esd, and then run "esd &", then I DO GET sound from XMMS.

Comment 7 Elliot Lee 2002-08-23 20:35:04 UTC

*** This bug has been marked as a duplicate of 71397 ***


Note You need to log in before you can comment on or make changes to this bug.