Bug 703471 - NetworkManager does not autoconnect for a wireless network without broadcast
NetworkManager does not autoconnect for a wireless network without broadcast
Status: CLOSED DUPLICATE of bug 707406
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-10 09:04 EDT by Brian C. Huffman
Modified: 2011-06-28 04:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-28 04:20:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output on resume (12.39 KB, application/octet-stream)
2011-05-29 00:29 EDT, Josh
no flags Details

  None (edit)
Description Brian C. Huffman 2011-05-10 09:04:12 EDT
Description of problem:
I have a Dell Latitude D630 laptop.  After resume, NetworkManager does not reconnect even though I have the autoconnect option checked in settings.

Version-Release number of selected component (if applicable):
NetworkManager-0.8.999-1.fc15.i686

How reproducible:
always

Steps to Reproduce:
1. close laptop lid
2. open laptop lid
3. no reconnect
  
Actual results:
no reconnect

Expected results:
reconnect

Additional info:
I do have a hidden ESSID.  I don't know if that matters or not.
Comment 1 Josh 2011-05-29 00:29:30 EDT
Created attachment 501557 [details]
dmesg output on resume

I've attached the output of dmesg from after resuming when I opened the lid.  Could it have something to do with the iwl3945 message toward the bottom?

Thanks!
Comment 2 Brian C. Huffman 2011-05-31 09:58:40 EDT
I changed the title of this bug after realizing that the network will not start automatically on boot up either.  And after testing with a different network that does not hide the ESSID, I have concluded that it will not automatically connect to a network with a hidden ESSID (broadcast off).
Comment 3 collura 2011-06-03 01:44:32 EDT
close https://bugzilla.redhat.com/show_bug.cgi?id=707434 as duplicate of this bug?
Comment 4 Brian C. Huffman 2011-06-03 06:42:36 EDT
I'm not sure if they're duplicates or not.  The other reporter claims to not be able to connect at all.  I can connect manually, but on reboot or resume from suspend, it will not connect automatically.
Comment 5 collura 2011-06-24 05:23:18 EDT
noted.

f15-gnome seems to be autoconnecting the wifi after reboot as of last few days. 

not sure what triggered it but currently running:

  NetworkManager-1:0.8.9997-4.git20110620.fc15 (x86_64)
  gnome-settings-daemon-3.0.1-6.fc15 (x86_64)

(f15-kde wifi still wont connect)
Comment 6 Jirka Klimes 2011-06-28 04:20:06 EDT
Auto-connection feature to hidden SSIDs is added to 0.8.9997-4.git20110620.fc15in bug 707406.
There is an issue with NetworkManager-1:0.8.9997-4.git20110620.fc15 and KDE though, that's handled in bug 716591 and bug 716527.

*** This bug has been marked as a duplicate of bug 707406 ***

Note You need to log in before you can comment on or make changes to this bug.